summaryrefslogtreecommitdiffstats
path: root/recipes-extended/libvirt
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2015-04-08 13:12:56 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-04-08 13:12:56 -0400
commit29bca75fa656713e3ab64f6ff8d26a679f10a13c (patch)
tree7b3966430444078c0997701f4725b4838bbfea87 /recipes-extended/libvirt
parent9a095cb70e8f221619dbab50be0d27e8ed55b8b0 (diff)
downloadmeta-virtualization-29bca75fa656713e3ab64f6ff8d26a679f10a13c.tar.gz
libvirt: use pkg-config to locate libcap
libvirt wants to use pcap-config to locate the exisence and location of libpcap. oe-core stubs this script and replaces it with pkg-config, which can lead to the host pcap-config triggering and either breaking the build or introducing host contamination. To fix this issue, we patch configure to use 'pkg-config libcap' to locate the correct libraries. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-extended/libvirt')
-rw-r--r--recipes-extended/libvirt/libvirt/libvirt-use-pkg-config-to-locate-libcap.patch45
-rw-r--r--recipes-extended/libvirt/libvirt_1.2.12.bb1
2 files changed, 46 insertions, 0 deletions
diff --git a/recipes-extended/libvirt/libvirt/libvirt-use-pkg-config-to-locate-libcap.patch b/recipes-extended/libvirt/libvirt/libvirt-use-pkg-config-to-locate-libcap.patch
new file mode 100644
index 00000000..65b046ee
--- /dev/null
+++ b/recipes-extended/libvirt/libvirt/libvirt-use-pkg-config-to-locate-libcap.patch
@@ -0,0 +1,45 @@
1From 3e271f6db12ffe34843428ec2f0bca7a8fe3aa65 Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@windriver.com>
3Date: Wed, 8 Apr 2015 13:03:03 -0400
4Subject: [PATCH] libvirt: use pkg-config to locate libcap
5
6libvirt wants to use pcap-config to locate the exisence and location
7of libpcap. oe-core stubs this script and replaces it with pkg-config,
8which can lead to the host pcap-config triggering and either breaking
9the build or introducing host contamination.
10
11To fix this issue, we patch configure to use 'pkg-config libcap' to
12locate the correct libraries.
13
14Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
15---
16 configure.ac | 6 +++---
17 1 file changed, 3 insertions(+), 3 deletions(-)
18
19diff --git a/configure.ac b/configure.ac
20index f37047599b76..5f9b84363b96 100644
21--- a/configure.ac
22+++ b/configure.ac
23@@ -1553,7 +1553,7 @@ fi
24 AM_CONDITIONAL([HAVE_NUMAD], [test "$with_numad" != "no"])
25
26 dnl pcap lib
27-LIBPCAP_CONFIG="pcap-config"
28+LIBPCAP_CONFIG="pkg-config libpcap"
29 LIBPCAP_CFLAGS=""
30 LIBPCAP_LIBS=""
31 LIBPCAP_FOUND="no"
32@@ -1563,8 +1563,8 @@ AC_ARG_WITH([libpcap], [AS_HELP_STRING([--with-libpcap=@<:@PFX@:>@],
33 if test "$with_qemu" = "yes"; then
34 case $with_libpcap in
35 no) LIBPCAP_CONFIG= ;;
36- ''|yes) LIBPCAP_CONFIG="pcap-config" ;;
37- *) LIBPCAP_CONFIG="$with_libpcap/bin/pcap-config" ;;
38+ ''|yes) LIBPCAP_CONFIG="pkg-config libpcap" ;;
39+ *) LIBPCAP_CONFIG="$with_libpcap/bin/pkg-config libpcap" ;;
40 esac
41 AS_IF([test "x$LIBPCAP_CONFIG" != "x"], [
42 AC_MSG_CHECKING(libpcap $LIBPCAP_CONFIG >= $LIBPCAP_REQUIRED )
43--
442.1.0
45
diff --git a/recipes-extended/libvirt/libvirt_1.2.12.bb b/recipes-extended/libvirt/libvirt_1.2.12.bb
index dca2d1b2..5de95c36 100644
--- a/recipes-extended/libvirt/libvirt_1.2.12.bb
+++ b/recipes-extended/libvirt/libvirt_1.2.12.bb
@@ -31,6 +31,7 @@ SRC_URI = "http://libvirt.org/sources/libvirt-${PV}.tar.gz;name=libvirt \
31 file://run-ptest \ 31 file://run-ptest \
32 file://tests-allow-separated-src-and-build-dirs.patch \ 32 file://tests-allow-separated-src-and-build-dirs.patch \
33 file://libvirt-Fix-cannot-symlink-cpu_map.xml-error.patch \ 33 file://libvirt-Fix-cannot-symlink-cpu_map.xml-error.patch \
34 file://libvirt-use-pkg-config-to-locate-libcap.patch \
34 " 35 "
35 36
36SRC_URI[libvirt.md5sum] = "2ae99535265ce4687d8718d744024c27" 37SRC_URI[libvirt.md5sum] = "2ae99535265ce4687d8718d744024c27"