diff options
author | Amarnath Valluri <amarnath.valluri@intel.com> | 2017-02-08 18:57:51 +0200 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2017-02-09 09:13:57 -0500 |
commit | ee0b5e316af429d4352abcad4a4110deae99e4f6 (patch) | |
tree | de74206c83edb2d5153f8de99e78dcf736373c46 /recipes-extended/libvirt | |
parent | 0343d3f8bb6ba0e9afc52e3fd4f5db87195f972e (diff) | |
download | meta-virtualization-ee0b5e316af429d4352abcad4a4110deae99e4f6.tar.gz |
libvirt: Place systemd units at appropriate location.
Systemd untis should be placed as per ${systemd_system_unitdir}.
Patched the source code to support configure variable to set the systemd units
directory.
Signed-off-by: Amarnath Valluri <amarnath.valluri@intel.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-extended/libvirt')
-rw-r--r-- | recipes-extended/libvirt/libvirt-1.3.5/0001-Added-configure-variable-for-placing-systemd-untis-l.patch | 55 | ||||
-rw-r--r-- | recipes-extended/libvirt/libvirt_1.3.5.bb | 3 |
2 files changed, 57 insertions, 1 deletions
diff --git a/recipes-extended/libvirt/libvirt-1.3.5/0001-Added-configure-variable-for-placing-systemd-untis-l.patch b/recipes-extended/libvirt/libvirt-1.3.5/0001-Added-configure-variable-for-placing-systemd-untis-l.patch new file mode 100644 index 00000000..a64739c3 --- /dev/null +++ b/recipes-extended/libvirt/libvirt-1.3.5/0001-Added-configure-variable-for-placing-systemd-untis-l.patch | |||
@@ -0,0 +1,55 @@ | |||
1 | From 531178d7fbb5d4b3404766cfd0fc999398cccd58 Mon Sep 17 00:00:00 2001 | ||
2 | From: Amarnath Valluri <amarnath.valluri@intel.com> | ||
3 | Date: Wed, 8 Feb 2017 18:39:48 +0200 | ||
4 | Subject: [PATCH] Added configure variable for placing systemd untis location | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: Amarnath Valluri <amarnath.valluri@intel.com> | ||
9 | --- | ||
10 | configure.ac | 3 +++ | ||
11 | daemon/Makefile.am | 1 - | ||
12 | tools/Makefile.am | 1 - | ||
13 | 3 files changed, 3 insertions(+), 2 deletions(-) | ||
14 | |||
15 | diff --git a/configure.ac b/configure.ac | ||
16 | index 0e5b8e3..5a6408c 100644 | ||
17 | --- a/configure.ac | ||
18 | +++ b/configure.ac | ||
19 | @@ -2687,6 +2687,9 @@ AC_DEFINE_UNQUOTED([isbase64],[libvirt_gl_isbase64],[Hack to avoid symbol clash] | ||
20 | AC_DEFINE_UNQUOTED([base64_encode],[libvirt_gl_base64_encode],[Hack to avoid symbol clash]) | ||
21 | AC_DEFINE_UNQUOTED([base64_encode_alloc],[libvirt_gl_base64_encode_alloc],[Hack to avoid symbol clash]) | ||
22 | |||
23 | +AC_ARG_VAR(SYSTEMD_UNIT_DIR, 'location for systemd units, defautls to /lib/systemd/system') | ||
24 | +AS_IF([test "x$SYSTEMD_UNIT_DIR" = "x"], [SYSTEMD_UNIT_DIR="/lib/systemd/system"]) | ||
25 | + | ||
26 | AC_CONFIG_FILES([run], | ||
27 | [chmod +x,-w run]) | ||
28 | AC_CONFIG_FILES([\ | ||
29 | diff --git a/daemon/Makefile.am b/daemon/Makefile.am | ||
30 | index edb75e8..2ab42a6 100644 | ||
31 | --- a/daemon/Makefile.am | ||
32 | +++ b/daemon/Makefile.am | ||
33 | @@ -449,7 +449,6 @@ endif ! LIBVIRT_INIT_SCRIPT_UPSTART | ||
34 | |||
35 | if LIBVIRT_INIT_SCRIPT_SYSTEMD | ||
36 | |||
37 | -SYSTEMD_UNIT_DIR = /lib/systemd/system | ||
38 | BUILT_SOURCES += libvirtd.service | ||
39 | |||
40 | install-init-systemd: install-sysconfig libvirtd.service | ||
41 | diff --git a/tools/Makefile.am b/tools/Makefile.am | ||
42 | index 27ecbf1..8cefe1a 100644 | ||
43 | --- a/tools/Makefile.am | ||
44 | +++ b/tools/Makefile.am | ||
45 | @@ -380,7 +380,6 @@ libvirt-guests.init: libvirt-guests.init.in libvirt-guests.sh | ||
46 | |||
47 | |||
48 | EXTRA_DIST += libvirt-guests.service.in | ||
49 | -SYSTEMD_UNIT_DIR = /lib/systemd/system | ||
50 | |||
51 | if LIBVIRT_INIT_SCRIPT_SYSTEMD | ||
52 | install-systemd: libvirt-guests.service install-sysconfig libvirt-guests.sh | ||
53 | -- | ||
54 | 2.7.4 | ||
55 | |||
diff --git a/recipes-extended/libvirt/libvirt_1.3.5.bb b/recipes-extended/libvirt/libvirt_1.3.5.bb index c848c99b..152130d0 100644 --- a/recipes-extended/libvirt/libvirt_1.3.5.bb +++ b/recipes-extended/libvirt/libvirt_1.3.5.bb | |||
@@ -37,6 +37,7 @@ SRC_URI = "http://libvirt.org/sources/libvirt-${PV}.tar.gz;name=libvirt \ | |||
37 | file://0001-qemu-Let-empty-default-VNC-password-work-as-document.patch \ | 37 | file://0001-qemu-Let-empty-default-VNC-password-work-as-document.patch \ |
38 | file://0001-ptest-add-missing-test_helper-files.patch \ | 38 | file://0001-ptest-add-missing-test_helper-files.patch \ |
39 | file://0001-ptest-Remove-Windows-1252-check-from-esxutilstest.patch \ | 39 | file://0001-ptest-Remove-Windows-1252-check-from-esxutilstest.patch \ |
40 | file://0001-Added-configure-variable-for-placing-systemd-untis-l.patch \ | ||
40 | " | 41 | " |
41 | 42 | ||
42 | SRC_URI[libvirt.md5sum] = "f9dc1e63d559eca50ae0ee798a4c6c6d" | 43 | SRC_URI[libvirt.md5sum] = "f9dc1e63d559eca50ae0ee798a4c6c6d" |
@@ -264,7 +265,7 @@ EXTRA_OECONF += " \ | |||
264 | --with-init-script=systemd \ | 265 | --with-init-script=systemd \ |
265 | " | 266 | " |
266 | 267 | ||
267 | EXTRA_OEMAKE = "BUILD_DIR=${B} DEST_DIR=${D}${PTEST_PATH} PTEST_DIR=${PTEST_PATH}" | 268 | EXTRA_OEMAKE = "BUILD_DIR=${B} DEST_DIR=${D}${PTEST_PATH} PTEST_DIR=${PTEST_PATH} SYSTEMD_UNIT_DIR=${systemd_system_unitdir}" |
268 | 269 | ||
269 | do_compile_ptest() { | 270 | do_compile_ptest() { |
270 | oe_runmake -C tests buildtest-TESTS | 271 | oe_runmake -C tests buildtest-TESTS |