summaryrefslogtreecommitdiffstats
path: root/recipes-extended/ceph
diff options
context:
space:
mode:
authorYanfei Xu <yanfei.xu@windriver.com>2020-11-11 11:19:51 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-11-14 23:07:20 -0500
commit9fe997733d9bad4ac24dfb41e91a0e06b9e82791 (patch)
tree32c9fcf48f4bd14f69af474d4e4f857155c0b2c9 /recipes-extended/ceph
parent6687be2233ef7d9758ddb7ccd2b53e55282fcd05 (diff)
downloadmeta-virtualization-9fe997733d9bad4ac24dfb41e91a0e06b9e82791.tar.gz
ceph: add support for python3.9
Add support for python3.9, or it will do_configure failed. Signed-off-by: Yanfei Xu <yanfei.xu@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-extended/ceph')
-rw-r--r--recipes-extended/ceph/ceph/0001-cmake-add-support-for-python3.9.patch30
-rw-r--r--recipes-extended/ceph/ceph_15.2.0.bb1
2 files changed, 31 insertions, 0 deletions
diff --git a/recipes-extended/ceph/ceph/0001-cmake-add-support-for-python3.9.patch b/recipes-extended/ceph/ceph/0001-cmake-add-support-for-python3.9.patch
new file mode 100644
index 00000000..d9116c4f
--- /dev/null
+++ b/recipes-extended/ceph/ceph/0001-cmake-add-support-for-python3.9.patch
@@ -0,0 +1,30 @@
1From 1060f2e4362ebd6db23870d442dcd158d219ee92 Mon Sep 17 00:00:00 2001
2From: Yanfei Xu <yanfei.xu@windriver.com>
3Date: Tue, 10 Nov 2020 17:17:30 +0800
4Subject: [PATCH] cmake: add support for python3.9
5
6add support for python3.9.
7
8Upstream-Status: Pending
9
10Signed-off-by: Yanfei Xu <yanfei.xu@windriver.com>
11---
12 cmake/modules/FindPython/Support.cmake | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/cmake/modules/FindPython/Support.cmake b/cmake/modules/FindPython/Support.cmake
16index 6584699b79..c05bbe3306 100644
17--- a/cmake/modules/FindPython/Support.cmake
18+++ b/cmake/modules/FindPython/Support.cmake
19@@ -17,7 +17,7 @@ if (NOT DEFINED _${_PYTHON_PREFIX}_REQUIRED_VERSION_MAJOR)
20 message (FATAL_ERROR "FindPython: INTERNAL ERROR")
21 endif()
22 if (_${_PYTHON_PREFIX}_REQUIRED_VERSION_MAJOR EQUAL 3)
23- set(_${_PYTHON_PREFIX}_VERSIONS 3.8 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0)
24+ set(_${_PYTHON_PREFIX}_VERSIONS 3.9 3.8 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0)
25 elseif (_${_PYTHON_PREFIX}_REQUIRED_VERSION_MAJOR EQUAL 2)
26 set(_${_PYTHON_PREFIX}_VERSIONS 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0)
27 else()
28--
292.18.2
30
diff --git a/recipes-extended/ceph/ceph_15.2.0.bb b/recipes-extended/ceph/ceph_15.2.0.bb
index bdc794ff..8454a200 100644
--- a/recipes-extended/ceph/ceph_15.2.0.bb
+++ b/recipes-extended/ceph/ceph_15.2.0.bb
@@ -21,6 +21,7 @@ SRC_URI = "http://download.ceph.com/tarballs/ceph-${PV}.tar.gz \
21 file://0002-mon-enforce-caps-for-pre-octopus-client-tell-command.patch \ 21 file://0002-mon-enforce-caps-for-pre-octopus-client-tell-command.patch \
22 file://0003-PendingReleaseNotes-note-about-security-fix.patch \ 22 file://0003-PendingReleaseNotes-note-about-security-fix.patch \
23 file://0001-add-missing-include-for-atomic-bool.patch \ 23 file://0001-add-missing-include-for-atomic-bool.patch \
24 file://0001-cmake-add-support-for-python3.9.patch \
24" 25"
25 26
26SRC_URI[md5sum] = "1f9af648b4c6d19975aab2583ab99710" 27SRC_URI[md5sum] = "1f9af648b4c6d19975aab2583ab99710"