summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2023-05-29 09:40:56 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2023-05-29 09:41:07 -0400
commite11b230d0eaf5be4a9831fbfd2323b0ecfc47d59 (patch)
tree883a84654ea0b7715c7da82639b9393c3fcd1685 /recipes-devtools
parent876a9da42acde2a72ad1e052df4f565d15160e54 (diff)
downloadmeta-virtualization-e11b230d0eaf5be4a9831fbfd2323b0ecfc47d59.tar.gz
Revert "yq: Redefine do_compile"
This reverts commit 49a6827cbdb6e00d3af5e5c4a4479c47573a4533. The workaround is no longer needed, as oe-core has upgraded go to a version that has fixed the issue. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/yq/yq_git.bb3
1 files changed, 1 insertions, 2 deletions
diff --git a/recipes-devtools/yq/yq_git.bb b/recipes-devtools/yq/yq_git.bb
index bd474a79..45f2f970 100644
--- a/recipes-devtools/yq/yq_git.bb
+++ b/recipes-devtools/yq/yq_git.bb
@@ -50,7 +50,7 @@ GO_IMPORT = "github.com/mikefarah/yq"
50 50
51inherit go ptest 51inherit go ptest
52 52
53do_compile() { 53do_compile:prepend() {
54 # arrange for some of the golang built ins to be found 54 # arrange for some of the golang built ins to be found
55 ( 55 (
56 cd ${WORKDIR}/build/src/ 56 cd ${WORKDIR}/build/src/
@@ -60,7 +60,6 @@ do_compile() {
60 # arrange for the fetched dependencies to be found 60 # arrange for the fetched dependencies to be found
61 export GOPATH="${GOPATH}:${WORKDIR}/build/vendor/" 61 export GOPATH="${GOPATH}:${WORKDIR}/build/vendor/"
62 export GO111MODULE=off 62 export GO111MODULE=off
63 ${GO} install ${GOBUILDFLAGS} `go_list_packages`
64} 63}
65 64
66do_install:append() { 65do_install:append() {