summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorChandana kalluri <ckalluri@xilinx.com>2020-04-08 09:52:40 -0700
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-04-08 23:07:43 -0400
commit16134e66ca8863869a8c69924daeae9dc6eb56bf (patch)
tree9dd85bbb301531b149bb2ecc4d0902d0700731c1 /recipes-devtools
parent40f79e8d17518285502425c537cd4e3e19c95ca7 (diff)
downloadmeta-virtualization-16134e66ca8863869a8c69924daeae9dc6eb56bf.tar.gz
go-build: Set up dependencies and GOPATH before do_compile
go-build recipe depends on runc source and during compilation tries to run the command: go get github.com/opencontainers/runc. This is incorrect as a source fetch shouldn't occur during compilation. Also, even after a fetch occurs during compilation, the go build path GOPATH points to the incorrect path hence the runc source is never found. Fetch the opencontainers/runc source and create links in the correct GOPATH before compilation for a successful build. Signed-off-by: Sai Hari Chandana Kalluri <chandana.kalluri@xilinx.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/go/go-build_git.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes-devtools/go/go-build_git.bb b/recipes-devtools/go/go-build_git.bb
index c11ad99e..f94a7225 100644
--- a/recipes-devtools/go/go-build_git.bb
+++ b/recipes-devtools/go/go-build_git.bb
@@ -3,8 +3,11 @@ SUMMARY = "console for runx"
3DESCRIPTION = "Xen Runtime for OCI" 3DESCRIPTION = "Xen Runtime for OCI"
4 4
5SRCREV_runx = "da0c75c58ae5232d19b1791c33545db3225e1ea9" 5SRCREV_runx = "da0c75c58ae5232d19b1791c33545db3225e1ea9"
6SRCREV_runc = "e4363b038787addfa12e8b0acf5417d4fba01693"
7
6SRC_URI = "\ 8SRC_URI = "\
7 git://github.com/lf-edge/runx;nobranch=1;name=runx \ 9 git://github.com/lf-edge/runx;nobranch=1;name=runx \
10 git://github.com/opencontainers/runc.git;nobranch=1;destsuffix=runc;name=runc \
8 " 11 "
9SRC_URI[md5sum] = "0d701ac1e2a67d47ce7127432df2c32b" 12SRC_URI[md5sum] = "0d701ac1e2a67d47ce7127432df2c32b"
10SRC_URI[sha256sum] = "5a26478906d5005f4f809402e981518d2b8844949199f60c4b6e1f986ca2a769" 13SRC_URI[sha256sum] = "5a26478906d5005f4f809402e981518d2b8844949199f60c4b6e1f986ca2a769"
@@ -29,6 +32,9 @@ do_compile() {
29 32
30 export GOARCH="${TARGET_GOARCH}" 33 export GOARCH="${TARGET_GOARCH}"
31 cd ${S}/src/import/gobuild 34 cd ${S}/src/import/gobuild
35 mkdir -p go/src/github.com/opencontainers
36 ln -s ${WORKDIR}/runc ${S}/src/import/gobuild/go/src/github.com/opencontainers/runc
37 export GOPATH="${S}/src/import/gobuild/go/src/github.com/opencontainers/runc"
32 oe_runmake 38 oe_runmake
33} 39}
34 40