diff options
author | Mark Asselstine <mark.asselstine@windriver.com> | 2017-11-14 12:55:06 -0500 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2017-11-15 16:00:18 -0500 |
commit | 34dee81d0c5a0e2e1b1633ad4293171163c3bb62 (patch) | |
tree | 5fc66467b4c5b5c0e949e6b7f8cefc0e3ca2ab91 /recipes-devtools | |
parent | 62823d7de00b42728cf5ca67cccc8e7c579eb8dc (diff) | |
download | meta-virtualization-34dee81d0c5a0e2e1b1633ad4293171163c3bb62.tar.gz |
python-*: switch remaining pypi recipes to use the pypi class
Cleanup the various python-* recipes which download from pypi. The
biggest change is to "inherit pypi" which should result in us always
using current pypi best practices. This will for example ensure we are
using https and not http which is apparently going to be disabled
soon.
Where the default behavior in the pypi class wasn't sufficient we make
use of the PYPI_* variables to overwrite the defaults.
Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r-- | recipes-devtools/python/python-gevent_1.0.1.bb | 7 | ||||
-rw-r--r-- | recipes-devtools/python/python-m2crypto_0.22.3.bb | 11 | ||||
-rw-r--r-- | recipes-devtools/python/python-sphinx_1.4.1.bb | 9 |
3 files changed, 8 insertions, 19 deletions
diff --git a/recipes-devtools/python/python-gevent_1.0.1.bb b/recipes-devtools/python/python-gevent_1.0.1.bb index 47f1267a..7f1d2622 100644 --- a/recipes-devtools/python/python-gevent_1.0.1.bb +++ b/recipes-devtools/python/python-gevent_1.0.1.bb | |||
@@ -11,15 +11,10 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=2dbb33d00e1fd31c7041460a81ac0bd2" | |||
11 | DEPENDS += "python-greenlet libevent" | 11 | DEPENDS += "python-greenlet libevent" |
12 | RDEPENDS_${PN} += "python-greenlet python-mime python-pprint python-re" | 12 | RDEPENDS_${PN} += "python-greenlet python-mime python-pprint python-re" |
13 | 13 | ||
14 | SRCNAME = "gevent" | ||
15 | |||
16 | SRC_URI = "http://pypi.python.org/packages/source/g/gevent/${SRCNAME}-${PV}.tar.gz" | ||
17 | SRC_URI[md5sum] = "7b952591d1a0174d6eb6ac47bd975ab6" | 14 | SRC_URI[md5sum] = "7b952591d1a0174d6eb6ac47bd975ab6" |
18 | SRC_URI[sha256sum] = "4627e215d058f71d95e6b26d9e7be4c263788a4756bd2858a93775f6c072df43" | 15 | SRC_URI[sha256sum] = "4627e215d058f71d95e6b26d9e7be4c263788a4756bd2858a93775f6c072df43" |
19 | 16 | ||
20 | S = "${WORKDIR}/${SRCNAME}-${PV}" | 17 | inherit setuptools pypi |
21 | |||
22 | inherit setuptools | ||
23 | 18 | ||
24 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | 19 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
25 | SRC_URI += "file://libev-conf.patch" | 20 | SRC_URI += "file://libev-conf.patch" |
diff --git a/recipes-devtools/python/python-m2crypto_0.22.3.bb b/recipes-devtools/python/python-m2crypto_0.22.3.bb index 95d6eecf..2c2625d3 100644 --- a/recipes-devtools/python/python-m2crypto_0.22.3.bb +++ b/recipes-devtools/python/python-m2crypto_0.22.3.bb | |||
@@ -13,23 +13,22 @@ DESCRIPTION = "\ | |||
13 | LICENSE = "BSD" | 13 | LICENSE = "BSD" |
14 | LIC_FILES_CHKSUM = "file://PKG-INFO;md5=0ccca7097c1d29fa42e75e9c15c6ff2e" | 14 | LIC_FILES_CHKSUM = "file://PKG-INFO;md5=0ccca7097c1d29fa42e75e9c15c6ff2e" |
15 | 15 | ||
16 | SRCNAME = "M2Crypto" | 16 | PYPI_PACKAGE = "M2Crypto" |
17 | SRC_URI = "http://pypi.python.org/packages/source/M/M2Crypto/${SRCNAME}-${PV}.tar.gz \ | 17 | |
18 | SRC_URI += " \ | ||
18 | file://m2crypto-Fix-build-with-SWIG-3.0.5.patch \ | 19 | file://m2crypto-Fix-build-with-SWIG-3.0.5.patch \ |
19 | " | 20 | " |
20 | 21 | ||
21 | SRC_URI[md5sum] = "573f21aaac7d5c9549798e72ffcefedd" | 22 | SRC_URI[md5sum] = "573f21aaac7d5c9549798e72ffcefedd" |
22 | SRC_URI[sha256sum] = "6071bfc817d94723e9b458a010d565365104f84aa73f7fe11919871f7562ff72" | 23 | SRC_URI[sha256sum] = "6071bfc817d94723e9b458a010d565365104f84aa73f7fe11919871f7562ff72" |
23 | 24 | ||
24 | S = "${WORKDIR}/${SRCNAME}-${PV}" | 25 | inherit setuptools pypi |
25 | |||
26 | inherit setuptools | ||
27 | 26 | ||
28 | DEPENDS += "openssl swig-native" | 27 | DEPENDS += "openssl swig-native" |
29 | 28 | ||
30 | DISTUTILS_BUILD_ARGS += "build_ext -I${STAGING_INCDIR}" | 29 | DISTUTILS_BUILD_ARGS += "build_ext -I${STAGING_INCDIR}" |
31 | 30 | ||
32 | inherit setuptools | 31 | inherit setuptools pypi |
33 | 32 | ||
34 | SWIG_FEATURES_x86-64 = "-D__x86_64__" | 33 | SWIG_FEATURES_x86-64 = "-D__x86_64__" |
35 | SWIG_FEATURES ?= "" | 34 | SWIG_FEATURES ?= "" |
diff --git a/recipes-devtools/python/python-sphinx_1.4.1.bb b/recipes-devtools/python/python-sphinx_1.4.1.bb index 835b369d..476ff977 100644 --- a/recipes-devtools/python/python-sphinx_1.4.1.bb +++ b/recipes-devtools/python/python-sphinx_1.4.1.bb | |||
@@ -4,14 +4,9 @@ SECTION = "devel/python" | |||
4 | LICENSE = "BSD" | 4 | LICENSE = "BSD" |
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=72f034adc6f7b05b09bc00d1a05bb065" | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=72f034adc6f7b05b09bc00d1a05bb065" |
6 | 6 | ||
7 | PR = "r0" | 7 | PYPI_PACKAGE = "Sphinx" |
8 | SRCNAME = "Sphinx" | ||
9 | |||
10 | SRC_URI = "http://pypi.python.org/packages/source/S/${SRCNAME}/${SRCNAME}-${PV}.tar.gz" | ||
11 | 8 | ||
12 | SRC_URI[md5sum] = "4c4988e0306a04cef8dccc384281e585" | 9 | SRC_URI[md5sum] = "4c4988e0306a04cef8dccc384281e585" |
13 | SRC_URI[sha256sum] = "c6871a784d24aba9270b6b28541537a57e2fcf4d7c799410eba18236bc76d6bc" | 10 | SRC_URI[sha256sum] = "c6871a784d24aba9270b6b28541537a57e2fcf4d7c799410eba18236bc76d6bc" |
14 | 11 | ||
15 | S = "${WORKDIR}/${SRCNAME}-${PV}" | 12 | inherit setuptools pypi |
16 | |||
17 | inherit setuptools | ||