diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2021-04-14 18:14:30 +0300 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2021-04-15 10:15:25 -0400 |
commit | b8eac951211614ccac74010ff978274338faed0b (patch) | |
tree | 746c1c2e9a92254fd4d4f050efbfbc060ad7e2a2 /recipes-devtools/python | |
parent | f3e19029b0c5952a27922c1f5145fe636b126fe4 (diff) | |
download | meta-virtualization-b8eac951211614ccac74010ff978274338faed0b.tar.gz |
python3-bugsnag: Upgrade 3.6.1 -> 4.0.2
Upgrade to release 4.0.2:
- Fixed an issue preventing code being fetched from files in the
project root but not in the PWD
- Fix issue where types were not packaged with the library
- Added __all__ lists throughout to indicate the boundaries of the
public interface. This may affect your integration if using
import *.
- Removed Configuration.use_ssl and Configuration.get_endpoint()
in favor of including the protocol in Configuration.endpoint
- Configuration.send_environment is now False by default. Enable
it as a part of your configuration to send the full request
context (if any) as a part of each event.
- Removed bugsnag.utils.ThreadLocals as it has been superseded by
the contextvars API
- Removed bugsnag.utils.merge_dicts, an unused helper function
- Removed bugsnag.send_sessions
- Deprecated bugsnag.notification.Notification in favor of
bugsnag.event.Event to better align with Bugsnag libraries on
other platforms. The Notification class is functionally
equivalent and will be removed in a future release.
- Added a request property to Event.
- Added type signatures throughout the library.
- [WSGI] Use X-Forwarded-For header if present to determine the IP
address used as the default user ID. The remote address remains
available in the request metadata attached to the event.
License-Update: Check only a single line from PKG-INFO
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-devtools/python')
-rw-r--r-- | recipes-devtools/python/python3-bugsnag_4.0.2.bb (renamed from recipes-devtools/python/python3-bugsnag_3.6.1.bb) | 5 |
1 files changed, 2 insertions, 3 deletions
diff --git a/recipes-devtools/python/python3-bugsnag_3.6.1.bb b/recipes-devtools/python/python3-bugsnag_4.0.2.bb index 32385798..96550bb1 100644 --- a/recipes-devtools/python/python3-bugsnag_3.6.1.bb +++ b/recipes-devtools/python/python3-bugsnag_4.0.2.bb | |||
@@ -8,10 +8,9 @@ DESCRIPTION = "\ | |||
8 | " | 8 | " |
9 | SECTION = "devel/python" | 9 | SECTION = "devel/python" |
10 | LICENSE = "MIT" | 10 | LICENSE = "MIT" |
11 | LIC_FILES_CHKSUM = "file://PKG-INFO;md5=3bc101ebc0815bd849021892cd333dd4" | 11 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=8227180126797a0148f94f483f3e1489" |
12 | 12 | ||
13 | SRC_URI[md5sum] = "93443091b052130cfe1daf7595249f9f" | 13 | SRC_URI[sha256sum] = "7a49dacf055a8c6dda4ce714acd91fabe9546f1ad826276918a26603a8b5489a" |
14 | SRC_URI[sha256sum] = "8878437aa44ec485cecb255742035b3b98a6c7e7d167a943b5fbe597b2f8f7f9" | ||
15 | 14 | ||
16 | inherit pypi setuptools3 | 15 | inherit pypi setuptools3 |
17 | 16 | ||