summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorPhilip Tricca <flihp@twobit.us>2013-11-26 13:08:55 +0000
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-12-04 01:36:19 -0500
commit851a4ae2ce2a10f20a586d447f22b0e8e4c7ad54 (patch)
tree0af390a8399b746482c5b23c3e927b3dd3de6c8a /recipes-core
parent61f1cd9c44f2bf1cb6b3605d2587baf9f439db9a (diff)
downloadmeta-virtualization-851a4ae2ce2a10f20a586d447f22b0e8e4c7ad54.tar.gz
base-files: add xenfs entry to fstab if xen DISTRO_FEATURE is enabled
Xen handles mounting xenfs with an init script. Unfortunately this script is the same one that starts xenstored and xenconsoled. That's great for dom0 but a domU may need xenfs but running xenstored/ xenconsoled in a domU makes no sense. A simple fstab entry is preferrable. Signed-off-by: Philip Tricca <flihp@twobit.us> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/base-files/base-files_3.0.14.bbappend5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes-core/base-files/base-files_3.0.14.bbappend b/recipes-core/base-files/base-files_3.0.14.bbappend
new file mode 100644
index 00000000..eb973adf
--- /dev/null
+++ b/recipes-core/base-files/base-files_3.0.14.bbappend
@@ -0,0 +1,5 @@
1do_install_append() {
2 if echo "${DISTRO_FEATURES}" | grep -q 'xen'; then
3 echo "xenfs /proc/xen xenfs defaults 0 0" >> ${D}${sysconfdir}/fstab
4 fi
5}