summaryrefslogtreecommitdiffstats
path: root/recipes-containers
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-02-10 10:44:28 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-02-15 14:58:44 -0500
commit9f8e6b8550c215b99e689c8717098d4d7327594f (patch)
tree04144181f15cb2ffab7371fe60939eb79138b818 /recipes-containers
parentdebdd70e982ff432672e4b1e5cce1a7ea0492655 (diff)
downloadmeta-virtualization-9f8e6b8550c215b99e689c8717098d4d7327594f.tar.gz
runc: uprev to version required by docker 1.13.0
At the moment we only use runc in conjunction with docker. In order to allow docker to function correctly we need to use the version specified in docker's vendor.conf file. Uprev runc to this version. NOTE that the docker folks have actually forked runc and I have used this fork as the SRC_URI. I could have chosen instead to use the old SRC_URI along with the fork point commit as the SRCREV, and then applied the 2 commits the docker team have added beyond the fork. I opted instead to use the fork such that 'docker info' would not complain about a version mismatch. This also makes it easier to google for issues since the commit ID matches. NOTE when we eventually have more users of runc we will have to determine a strategy to either have them all use the same version or allow for multiple versions of runc on the system. This is also true for containerd. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-containers')
-rw-r--r--recipes-containers/runc/runc_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-containers/runc/runc_git.bb b/recipes-containers/runc/runc_git.bb
index 23c0094d..c5cf40be 100644
--- a/recipes-containers/runc/runc_git.bb
+++ b/recipes-containers/runc/runc_git.bb
@@ -4,9 +4,9 @@ DESCRIPTION = "runc is a CLI tool for spawning and running containers according
4 4
5# Note: this rev is before the required protocol field, update when all components 5# Note: this rev is before the required protocol field, update when all components
6# have been updated to match. 6# have been updated to match.
7SRCREV = "1cdaa709f151b61cee2bdaa09d8e5d2b58a8ba72" 7SRCREV = "2f7393a47307a16f8cee44a37b262e8b81021e3e"
8SRC_URI = "\ 8SRC_URI = "\
9 git://github.com/opencontainers/runc;branch=master \ 9 git://github.com/docker/runc.git;nobranch=1 \
10 " 10 "
11 11
12# Apache-2.0 for containerd 12# Apache-2.0 for containerd
@@ -15,7 +15,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=435b266b3899aa8a959f17d41c56def8"
15 15
16S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
17 17
18RUNC_VERSION = "1.0.0-rc1" 18RUNC_VERSION = "1.0.0-rc2"
19PV = "${RUNC_VERSION}+git${SRCREV}" 19PV = "${RUNC_VERSION}+git${SRCREV}"
20 20
21DEPENDS = "go-cross-${TARGET_ARCH} \ 21DEPENDS = "go-cross-${TARGET_ARCH} \