summaryrefslogtreecommitdiffstats
path: root/recipes-containers
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2017-03-22 17:19:59 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-03-22 17:20:11 -0400
commit7bf6863a5a7158a37dcf4a6734fdad8c0474956e (patch)
tree489ff1e028561543d16db8e836c8cd7a7c5e4fd0 /recipes-containers
parent7c73258abc385e4109a22252f947951d75839b61 (diff)
downloadmeta-virtualization-7bf6863a5a7158a37dcf4a6734fdad8c0474956e.tar.gz
docker: use oe-core go infrastructure
The docker recipe has some outdated go hacks. While this doesn't remove them all, it does use more of the oe-core go infrastructure .. and that results in more consistent builds. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-containers')
-rw-r--r--recipes-containers/docker/docker_git.bb31
1 files changed, 4 insertions, 27 deletions
diff --git a/recipes-containers/docker/docker_git.bb b/recipes-containers/docker/docker_git.bb
index 68586c81..6b73cf3d 100644
--- a/recipes-containers/docker/docker_git.bb
+++ b/recipes-containers/docker/docker_git.bb
@@ -70,33 +70,13 @@ RRECOMMENDS_${PN} = "kernel-module-dm-thin-pool kernel-module-nf-nat"
70RSUGGESTS_${PN} = "lxc rt-tests" 70RSUGGESTS_${PN} = "lxc rt-tests"
71DOCKER_PKG="github.com/docker/docker" 71DOCKER_PKG="github.com/docker/docker"
72 72
73inherit systemd update-rc.d
74inherit go
75inherit go-osarchmap
76
73do_configure[noexec] = "1" 77do_configure[noexec] = "1"
74 78
75do_compile() { 79do_compile() {
76 case "${TARGET_ARCH}" in
77 arm)
78 GOARCH=arm
79 case "${TUNE_PKGARCH}" in
80 cortexa*)
81 export GOARM=7
82 ;;
83 esac
84 ;;
85 aarch64)
86 GOARCH=arm64
87 ;;
88 i586|i686)
89 GOARCH=386
90 ;;
91 x86_64)
92 GOARCH=amd64
93 ;;
94 *)
95 GOARCH="${TARGET_ARCH}"
96 ;;
97 esac
98 export GOARCH
99
100 # Set GOPATH. See 'PACKAGERS.md'. Don't rely on 80 # Set GOPATH. See 'PACKAGERS.md'. Don't rely on
101 # docker to download its dependencies but rather 81 # docker to download its dependencies but rather
102 # use dependencies packaged independently. 82 # use dependencies packaged independently.
@@ -130,9 +110,6 @@ do_compile() {
130 go build -o ${S}/docker-proxy github.com/docker/libnetwork/cmd/proxy 110 go build -o ${S}/docker-proxy github.com/docker/libnetwork/cmd/proxy
131} 111}
132 112
133inherit systemd update-rc.d
134inherit go
135
136SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES','systemd','${PN}','',d)}" 113SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES','systemd','${PN}','',d)}"
137SYSTEMD_SERVICE_${PN} = "${@bb.utils.contains('DISTRO_FEATURES','systemd','docker.service','',d)}" 114SYSTEMD_SERVICE_${PN} = "${@bb.utils.contains('DISTRO_FEATURES','systemd','docker.service','',d)}"
138 115