summaryrefslogtreecommitdiffstats
path: root/recipes-containers
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2024-04-24 18:47:38 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2024-05-02 18:16:26 +0000
commit089cbaba3d3c4199ebc895fa8227ca93356b15ed (patch)
tree32f67f469f39a3e36ba07b157d679f8852b0858d /recipes-containers
parent829dc1f9b4035bd988c7c4d6905fcb43144d92c1 (diff)
downloadmeta-virtualization-089cbaba3d3c4199ebc895fa8227ca93356b15ed.tar.gz
containerd-opencontainers: fix wrong version display
* Update containerd to v2 to fix following containerd version: containerd github.com/containerd/containerd/v2 2.0.0-beta.0+unknown it should be like: containerd github.com/containerd/containerd/v2 v2.0.0-beta.2-204-gb1624c362.m b1624c3628954e769dd50783b63823040b2db38c.m * Remove CONTAINERD_PKG, it is not used * Update default PACKAGE in Makefile to v2 Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers')
-rw-r--r--recipes-containers/containerd/containerd-opencontainers/0001-Makefile-update-default-PACKAGE-to-v2.patch28
-rw-r--r--recipes-containers/containerd/containerd-opencontainers_git.bb7
2 files changed, 31 insertions, 4 deletions
diff --git a/recipes-containers/containerd/containerd-opencontainers/0001-Makefile-update-default-PACKAGE-to-v2.patch b/recipes-containers/containerd/containerd-opencontainers/0001-Makefile-update-default-PACKAGE-to-v2.patch
new file mode 100644
index 00000000..74e313b5
--- /dev/null
+++ b/recipes-containers/containerd/containerd-opencontainers/0001-Makefile-update-default-PACKAGE-to-v2.patch
@@ -0,0 +1,28 @@
1From eb39888898a9d196e3eb63724c6c07777f3b9402 Mon Sep 17 00:00:00 2001
2From: Changqing Li <changqing.li@windriver.com>
3Date: Wed, 24 Apr 2024 14:10:11 +0800
4Subject: [PATCH] Makefile: update default PACKAGE to v2
5
6Upstream-Status: Submitted [https://github.com/containerd/containerd/pull/10125]
7
8Signed-off-by: Changqing Li <changqing.li@windriver.com>
9---
10 Makefile | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/Makefile b/Makefile
14index a5b244191..cb9ff4172 100644
15--- a/Makefile
16+++ b/Makefile
17@@ -34,7 +34,7 @@ TEST_IMAGE_LIST ?=
18 # Used to populate variables in version package.
19 VERSION ?= $(shell git describe --match 'v[0-9]*' --dirty='.m' --always)
20 REVISION ?= $(shell git rev-parse HEAD)$(shell if ! git diff --no-ext-diff --quiet --exit-code; then echo .m; fi)
21-PACKAGE=github.com/containerd/containerd
22+PACKAGE=github.com/containerd/containerd/v2
23 SHIM_CGO_ENABLED ?= 0
24
25 ifneq "$(strip $(shell command -v $(GO) 2>/dev/null))" ""
26--
272.25.1
28
diff --git a/recipes-containers/containerd/containerd-opencontainers_git.bb b/recipes-containers/containerd/containerd-opencontainers_git.bb
index 10d1ce8b..ed73e398 100644
--- a/recipes-containers/containerd/containerd-opencontainers_git.bb
+++ b/recipes-containers/containerd/containerd-opencontainers_git.bb
@@ -6,9 +6,10 @@ DESCRIPTION = "containerd is a daemon to control runC, built for performance and
6 6
7 7
8SRCREV = "b1624c3628954e769dd50783b63823040b2db38c" 8SRCREV = "b1624c3628954e769dd50783b63823040b2db38c"
9SRC_URI = "git://github.com/containerd/containerd;branch=main;protocol=https;destsuffix=git/src/github.com/containerd/containerd \ 9SRC_URI = "git://github.com/containerd/containerd;branch=main;protocol=https;destsuffix=git/src/github.com/containerd/containerd/v2 \
10 file://0001-Makefile-allow-GO_BUILD_FLAGS-to-be-externally-speci.patch \ 10 file://0001-Makefile-allow-GO_BUILD_FLAGS-to-be-externally-speci.patch \
11 file://0001-build-don-t-use-gcflags-to-define-trimpath.patch \ 11 file://0001-build-don-t-use-gcflags-to-define-trimpath.patch \
12 file://0001-Makefile-update-default-PACKAGE-to-v2.patch \
12 " 13 "
13 14
14# Apache-2.0 for containerd 15# Apache-2.0 for containerd
@@ -23,7 +24,7 @@ CVE_VERSION = "v2.0.0-beta.0"
23PROVIDES += "virtual/containerd" 24PROVIDES += "virtual/containerd"
24RPROVIDES:${PN} = "virtual-containerd" 25RPROVIDES:${PN} = "virtual-containerd"
25 26
26S = "${WORKDIR}/git/src/github.com/containerd/containerd" 27S = "${WORKDIR}/git/src/github.com/containerd/containerd/v2"
27 28
28PV = "${CONTAINERD_VERSION}+git" 29PV = "${CONTAINERD_VERSION}+git"
29 30
@@ -32,8 +33,6 @@ inherit goarch
32 33
33GO_IMPORT = "import" 34GO_IMPORT = "import"
34 35
35CONTAINERD_PKG="github.com/containerd/containerd"
36
37INSANE_SKIP:${PN} += "ldflags" 36INSANE_SKIP:${PN} += "ldflags"
38 37
39do_configure[noexec] = "1" 38do_configure[noexec] = "1"