diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2023-03-29 23:32:41 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2023-04-05 16:03:55 -0400 |
commit | 27460610d66a1a71f9ab2d7e1d7925e53e3a3903 (patch) | |
tree | 322ace0b278aca702e9a534ca83d812216bc17fa /recipes-containers | |
parent | ee212a38bcac7a6bdc28a2d8af6deb40d3703842 (diff) | |
download | meta-virtualization-27460610d66a1a71f9ab2d7e1d7925e53e3a3903.tar.gz |
containerd: update to 1.7.0
Bumping containerd to version v1.7.0-11-g6ea9bc57f, which comprises the following commits:
d81fc15af update runc binary to v1.1.5
755efbe64 go.mod: github.com/opencontainers/runc v1.1.5
90591db47 Defer uid lookups on Darwin
b7d87b190 Add `WithReadonlyTempMount` to create readonly temporary mounts
1c1b6bcb2 CRI: Don't always close netConfMonitor channel
cf2e454bf Sandbox: Correct/add some fields to Status()
ce68e8e0d Sandbox: Cleanup shim on Start failure
e13a9165e Prepare release notes for v1.7.0
625217d5f RELEASES.md: describe the deprecated config properties
703e2ba4b docs: link docs/managed-opt.md to client.Install
f2bb9c9b0 Go 1.20.2
56354c7de Update ttrpc to v1.2.1
5144ba9c4 sandbox: create sandbox with network namespace path
dd3eedf3c labels: Add LabelDistributionSource
5c9c630c3 use uppercase letters for flag usage
0efc498d3 Prepare release notes for v1.7.0-rc.3
ff4acdc42 metadata: add comments about Image.CreatedAt
6d46bb410 go.mod: go.opentelemetry.io/otel/* v1.14.0
d26587c72 archive: disable looking up usernames and groupnames on the host
535ef5054 go.mod: github.com/stretchr/testify v1.8.2
2b4f830ed go.mod: github.com/opencontainers/selinux v1.11.0
6bfc82daf go.mod: github.com/opencontainers/runtime-spec v1.1.0-rc.1
7c70185ae go.mod: github.com/klauspost/compress v1.16.0
8e67b2731 go.mod: github.com/imdario/mergo v0.3.13
6afec5558 go.mod: github.com/emicklei/go-restful/v3 v3.10.1
c4f928f88 go.mod: github.com/containerd/ttrpc v1.2.0
5630d6a84 go.mod: github.com/containerd/fifo v1.1.0
6d9513231 go.mod: github.com/containerd/cgroups/v3 v3.0.1
da1ffdd75 go.mod: github.com/Microsoft/hcsshim v0.10.0-rc.7
60738e31d Update imgcrypt to v1.1.7
8a4d409b9 Add release notes for v1.7.0-rc.2
d602c9aec docs: fix typo of shim.RunManager's function comment
f70657650 feat: tag image using Transfer api
f7eb86ef3 Sandbox: Delete shim+shutdown sandbox on create failure
6b4b6956e Sandbox: Fix/enhance error messages for Create
8ce3e4e15 epoch: fix unit test when SOURCE_DATE_EPOCH is set
32ed559c8 Add Windows Sandbox Stats (sbserver)
08aa576a9 Add Windows Sandbox Stats
8137e41c4 Add ArgsEscaped support for CRI
5946c1051 *: fix code style issue
98cb6d7eb cri/sbserver: ignore the NOT_FOUND error in exec cleanup
01671e9fc cri: add config ut for invalid drain io timeout value
55e25f164 integration: add testcase to drain exec IO in time
ffebcb122 cri: disable drain-exec-IO if it is empty timeout
791f137a5 *: update drainExecSyncIO docs and validate the timeout
13bf5565e [transfer] update export to use image store references
e2283edef [transfer] update export API types
f6491b004 feat: export images using Transfer api
b9d7eae1a feat(api): add fields to ImageExportStream
3c18decea *: add DrainExecSyncIOTimeout config and disable as by default
a9cbddd65 *: fix typo and skip exec-io-drain-testcase in win
b91f42a14 ctr/tasks: support remapped UID/GID
2e96ba95e Create config struct to take user input
f25ec98d0 Fix linting error `sets.String is deprecated`
8145b15f0 Bump k8s.io deps
04dfd6275 pkg/cri/sbserver: add timeout to drain exec io
82c0f4ff8 pkg/cri/server: add timeout to drain exec io
43d36a254 Add experimental section to RELEASES.md
cd84f752c Prepare release notes for v1.7.0-rc.1
ae42f836f Update mailmap
4522ad886 Update CRI guide link
57fb2d30f Add max shim version environment variable
5c6e9f83d Fix streaming manager deadlock on collection
acf6e9411 Update README with location of security audits
30883d831 Increase CI workflow timeout on Windows.
af7477e43 docs: fix typos in historical/design/data-flow.md
6b589a89f releases: mark 1.5 as EOL
dba6f9db1 Add version to shim protocol
36ae2f6b9 bump go-cni to v1.1.9
cf46d3c6f Treat sandboxes as root gc resources and scan referenced objects
35d42b47f Add Linux arm64 arch to install-protobuf script
727f8530c Prepare release notes for v1.7.0-rc.0
2e9aaf094 docs: update instructions for enabling NRI.
310be5ce6 pkg/nri: update NRI configuration.
8a47c6910 Add a leading space after the comment sign
f53417921 Add unit test to getSupportedPlatform
a6ad9e04e Rewrite install-protobuf script
3769b4840 Rewrite install-protobuf script
47305392c Add configuration options to local transfer service
bd0a2a927 CRI: remove duplicated snapshotters code
49abbe4f2 fix failing TestCDIInjections
30e4a1409 update CDI version to v0.5.4
4728800ab runtime/v2: Get rid of last logrus.Fields usage
4278fbbc7 runtime/v2: Call onCloseWithShimLog for grpc shims
06e085c8b Add Fields type alias to log package
0ecdd341d docs: add more comment to logging.LoggerFunc
ea83632a8 docs: Show how to select GRPC for shims
369339897 Migrate from k8s.gcr.io to registry.k8s.io
a48dbefc1 Fix concurrent writes for UpdateContainerStats
dc27cc0a2 Add macOS build notes
56274749c sandbox: start sandbox with options
2716fd041 dependency: bump go.etcd.io/bbolt to v1.3.7
979a74412 runtime/v2: Log BootstrapParams
4baa1876b contrib/apparmor: remove code related to apparmor_parser version
0ced6ac64 Prepare release notes for v1.7.0-beta.4
90d004ae8 Go 1.20.1
281f89a9d go.mod: go 1.19
d8b68e3cc Stop using math/rand.Read and rand.Seed (deprecated in Go 1.20)
a9ac5f9cb lint: remove `//nolint:dupword` that are no longer needed
9b510e9a8 lint: silence "SA1019: tar.TypeRegA has been deprecated... (staticheck)"
8bf975b4f lint: silence "type `HostFileConfig` is unused (unused)"
4b9fd6ba5 golangci-lint v1.51.1
ac31c9a53 Clean up repeated package import
39bac0dbe error strings should not be capitalized
9a9cfe85e Go 1.19.6
0166783c7 cni: pass in the cgroupPath capability argument
d14758b60 go.mod: bump to go-cni main
e855a5998 cmd/ctr/commands/images: support usage subcommand
9c82e929f release: xx v1.2.1
844252164 Add fallback for windows platforms without osversion
081601f52 Update imagestore interface to support multiple references
646bc3a94 CRI: Create DefaultCRIAnnotations helper
5aab634e1 CRI: Pass sandbox annotations to _other platforms
2b24af8d1 Use options to pass PodSandboxConfig to shims
ebbcb57a4 pkg/cri/sbserver: experimental NRI integration for CRI.
8a1dca0f4 pkg/cri: split out NRI API from pkg/cri/server.
a8bb1ad2a loadConfig pre-inspection in advance
36e7dbdcb ctr version: add args check, prohibit incoming args
750d18ace Extract CRI instrument package
60d04b0b0 pkg: rename {blockio,rdt}_default.go -> nonlinux.go
b61988670 go.mod: github.com/containerd/typeurl/v2 v2.1.0
74b371b98 CRI: Mirror generic toml runtime config under server
8ef298d86 Add transport credentials GRPC opt
77fc0948c Use switch when creating TTRPC/GRPC client
a82e37a5a Add shim bootstrap params
fc2e761e2 Initial GRPC client support
9e5c207e4 Wire up client bridges
4b1ebef3c Add Sandbox service GRPC bridge
47cb5f64b Add Task Service GRPC bridge
51a8db233 Send container events with nil PodSandboxStatus
27c8f4085 Move PLEG event generation back to sbserver to avoid missing pod sandbox status
7cf556075 test: add hostNetwork tests for both windows and linux
d33a43cc2 pkg/apparmor: clarify Godoc
a3265102d Revert "Don't check for apparmor_parser to be present"
c990e3f2e contrib/apparmor: remove version-dependent rules
fe0116ec2 CI: skip some jobs when `repo != containerd/containerd`
3eda46af1 oci: fix additional GIDs
ef2560d16 oci: fix loop iterator aliasing
52f82acb7 btrfs: depend on kernel UAPI instead of libbtrfs
62df35df6 *: introduce wrapper pkgs for blockio and rdt
6cdc221f5 'go routine' should be 'goroutine'
b0e97c0f9 Use multierror for cleanup error
34314717b Remove sandox store and controller service type
a788f6c79 Move local sandbox controller under plugins package
2717685da Refactor sandbox controller interface
0b33a45fa cri: fix Mirrors deprecation comment
5bc3fea62 update fuzz function names in docs with golang naming convention
904a87d26 docs: fix function names in fuzzing test documentation
9e4acc028 importer: stream oci-layout and manifest.json
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers')
-rw-r--r-- | recipes-containers/containerd/containerd-opencontainers_git.bb | 8 |
1 files changed, 4 insertions, 4 deletions
diff --git a/recipes-containers/containerd/containerd-opencontainers_git.bb b/recipes-containers/containerd/containerd-opencontainers_git.bb index 2071fdc6..27406eff 100644 --- a/recipes-containers/containerd/containerd-opencontainers_git.bb +++ b/recipes-containers/containerd/containerd-opencontainers_git.bb | |||
@@ -5,8 +5,8 @@ DESCRIPTION = "containerd is a daemon to control runC, built for performance and | |||
5 | support as well as checkpoint and restore for cloning and live migration of containers." | 5 | support as well as checkpoint and restore for cloning and live migration of containers." |
6 | 6 | ||
7 | 7 | ||
8 | SRCREV = "fdfdc9bfc0f865a43c88171110615d1510fad3bc" | 8 | SRCREV = "6ea9bc57f97cd6bdd62afe8c8295706de36afd51" |
9 | SRC_URI = "git://github.com/containerd/containerd;branch=main;protocol=https;destsuffix=git/src/github.com/containerd/containerd \ | 9 | SRC_URI = "git://github.com/containerd/containerd;branch=release/1.7;protocol=https;destsuffix=git/src/github.com/containerd/containerd \ |
10 | file://0001-Makefile-allow-GO_BUILD_FLAGS-to-be-externally-speci.patch \ | 10 | file://0001-Makefile-allow-GO_BUILD_FLAGS-to-be-externally-speci.patch \ |
11 | file://0001-build-don-t-use-gcflags-to-define-trimpath.patch \ | 11 | file://0001-build-don-t-use-gcflags-to-define-trimpath.patch \ |
12 | " | 12 | " |
@@ -15,8 +15,8 @@ SRC_URI = "git://github.com/containerd/containerd;branch=main;protocol=https;des | |||
15 | LICENSE = "Apache-2.0" | 15 | LICENSE = "Apache-2.0" |
16 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1269f40c0d099c21a871163984590d89" | 16 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1269f40c0d099c21a871163984590d89" |
17 | 17 | ||
18 | CONTAINERD_VERSION = "v1.7.0-beta.3" | 18 | CONTAINERD_VERSION = "v1.7.0" |
19 | CVE_VERSION = "v1.7.0-beta.3" | 19 | CVE_VERSION = "v1.7.0" |
20 | 20 | ||
21 | # EXTRA_OEMAKE += "GODEBUG=1" | 21 | # EXTRA_OEMAKE += "GODEBUG=1" |
22 | 22 | ||