summaryrefslogtreecommitdiffstats
path: root/recipes-containers
diff options
context:
space:
mode:
authorDengke Du <dengke.du@windriver.com>2019-02-28 09:28:08 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-03-01 11:37:43 -0500
commit3e7593f3570f300822f183120de101b717d9ddf9 (patch)
tree242c4bca4d6c95d41bab8f8301ed752d29d38a7b /recipes-containers
parent832a0f1e10af43a8006eb84910ceee4472c5d3ab (diff)
downloadmeta-virtualization-3e7593f3570f300822f183120de101b717d9ddf9.tar.gz
criu: fix host gcc can't recognized option -fmacro-prefix-map
Generally, our host gcc version below 8.0, but cross toolchain in yocto above 8.0, now 8.3, the option "macro-prefix-map" coming from 8.0, so if the host gcc below 8.0, it can't unrecognized the option "macro-prefix-map". In criu source code, the HOSTCFLAGS coming from CFLAGS: https://github.com/checkpoint-restore/criu/blob/criu-dev/Makefile#L17 In yocto project, the CFLAGS coming from the cross toolchain, containing the "-fmacro-prefix-map" default, so we should use the BUILD_CFLAGS, it contains the flags that used for host building. Signed-off-by: Dengke Du <dengke.du@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers')
-rw-r--r--recipes-containers/criu/criu_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-containers/criu/criu_git.bb b/recipes-containers/criu/criu_git.bb
index 45195ea6..123f6a3d 100644
--- a/recipes-containers/criu/criu_git.bb
+++ b/recipes-containers/criu/criu_git.bb
@@ -54,6 +54,7 @@ export C_INCLUDE_PATH="${STAGING_INCDIR}/libnl3"
54 54
55export BUILD_SYS 55export BUILD_SYS
56export HOST_SYS 56export HOST_SYS
57export HOSTCFLAGS = "${BUILD_CFLAGS}"
57 58
58inherit setuptools 59inherit setuptools
59 60