diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2022-10-26 10:24:08 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2022-12-01 17:01:44 -0500 |
commit | 43396cb671f64971ff354d9903adbae8077a3d6c (patch) | |
tree | f47b9cccb2cf057ef3579ab5ea9d7091ab7c0546 /recipes-containers/podman/podman_git.bb | |
parent | cb5dfda6f6d862a575f029ee8ded0bc3db6bc766 (diff) | |
download | meta-virtualization-43396cb671f64971ff354d9903adbae8077a3d6c.tar.gz |
podman: update to 4.3
We add ${datadir}/user-tmpfiles.d/* to package some newly added systemd
files, but otherwise, the recipe is unchanged.
Bumping libpod to version v4.3.0-7-g9ce592fcb, which comprises the following commits:
83b02f8fd Update c/image from release-5.23 branch
14563ef13 system tests: fix broken bashisms
34ebb9af2 Release notes fixes
d5a0dfc1e Bump to v4.3.1-dev
ad42af949 Bump to v4.3.0
9496a3836 Final release notes for v4.3.0
ac7fa8437 libpod: Add support for 'podman top' on FreeBSD
f8a79409c libpod: Factor out jail name construction from stats_freebsd.go
e33306683 pkg/util: Add pid information descriptors for FreeBSD
3810a9dac [CI:BUILD] copr: podman rpm should depend on containers-common-extra
94499aa47 Podman image: Set default_sysctls to empty for rootless containers
8a28b896b Allow volume mount dups, iff source and dest dirs
295d0d1d9 libpod: Factor out the call to PidFdOpen from (*Container).WaitForExit
c9c683a58 markdown-preprocess: add generic include mechanism
42a221874 markdown-preprocess: almost complete OO rewrite
ca9eaec5e bump golangci-lint to v1.49.0
6972d47ff rootless: fix return value handling
5a214f6e5 generate systemd: set --stop-timeout for stopping containers
c6ad786ca Change to correct break statements
1a5506459 Add swagger install + allow version updates in CI
78d4af894 Cirrus: Fix windows clone race
fc43751e7 kill: wait for the container
9c01425ad hack/tree_status.sh: print diff at the end
682dd8e45 Man pages: refactor common options (misc)
b98f6b52f Man pages: Refactor common options: --detach-keys
c7e946482 Man pages: refactor common options: --attach
83b5fcf38 build(deps): bump github.com/fsnotify/fsnotify from 1.5.4 to 1.6.0
6d5d84a05 Man pages: refactor common options: --annotation (manifest)
7f88deff1 KillContainer: improve error message
b805a068c build(deps): bump github.com/containers/ocicrypt from 1.1.5 to 1.1.6
42b642509 docs: add missing options
f2a2ab557 build(deps): bump github.com/spf13/cobra from 1.5.0 to 1.6.0
095aa5c3a play kube: notifyproxy: listen before starting the pod
b7514ee40 build(deps): bump golang.org/x/text from 0.3.7 to 0.3.8
f7732ae52 Man pages: refactor common options: --os-version
298a2432e play kube: add support for configmap binaryData
2efdff528 build(deps): bump github.com/onsi/gomega from 1.20.2 to 1.22.1
802118ad1 Revert "Add checkpoint image tests"
dfa55ff6a Revert "cmd/podman: add support for checkpoint images"
eb43d175c system tests: health-on-failure: fix broken logic
ee5bd1e0c Man pages: Add mention of behavior due to XDG_CONFIG_HOME
c88dfbb98 Add and use libpod/Container.Terminal() helper
cbde35e32 Avoid unnecessary timeout of 250msec when waiting on container shutdown
d15b4af92 healthcheck: fix --on-failure=stop
81c645f2f libpod: Add support for 'podman pod' on FreeBSD
546e9445e libpod: Factor out cgroup validation from (*Runtime).NewPod
26df7d97c libpod: Move runtime_pod_linux.go to runtime_pod_common.go
70e0cb509 specgen/generate: Avoid a nil dereference in MakePod
f92360283 libpod: Factor out cgroups handling from (*Pod).refresh
b9d479b72 health checks: make on-failure action retry aware
ead78d8ba libpod: Remove 100msec delay during shutdown
640eac465 Clean up when stopping pods
d31a06ce8 Create full path to a directory when DirectoryOrCreate is used with play kube
9ce61988d Return error in podman system service if URI scheme is not unix/tcp
8041df3b6 Update vendor of containers/buildah v1.28.0
d13509f27 Man pages: refactor common options: --time
c16078f2d Release notes for all content before cherry-picks
3451aac35 Man pages: refactor common options: --pod
aaa9f4ea9 Prevent nil pointer deref in GetImage
f250560a8 Add pods created by kube play to a default network
26468c227 Man pages: refactor common options: --features
2f6c911d6 build(deps): bump github.com/opencontainers/image-spec
62bc8e3a1 Cirrus: Fix tag & branch go checks failing
eaa389262 Man pages: refactor common options: --variant
9bafd9c46 Man pages: refactor common options: --compression-format
eb7f54ef6 cleanup: always delete netns mount
a2581abbf Adds brew info podman to issue template.
73c8416c3 Update for https://github.com/klauspost/pgzip/pull/50
02b0f9fc3 container inspect: include image digest
fe3c91d58 Update vendor containers/(common,image)
f304a1757 Fix typo about e2e tests name
66747351f [CI:DOCS] Add quay-description update reminder
0660f5b7a Cirrus: Combine build and code consistency tasks
6c8a11b74 Cirrus: Combine pre-test checks into build task
0e7d166ee Cirrus: Minor YAML comment/whitespace fix
e7328cb97 Man pages: refactor common options: --network
fe2b4df38 podman kube play allow --network host
e4c0c8994 Man pages: Refactor common options: --sign-passphrase-file
309f4fb54 Man pages: refactor common options: --log-opt
6f821f03d `podman pod logs -l` no longer panics
f00ceaabd vendor: bump c/common to v0.49.2-0.20220929111928-2d1b45ae2423
3b5171d0e fix "podman system prune networks" flake
ebff193f8 Add test for podman run with checkpoint image
9c3d8bb49 cmd/podman: add support for checkpoint images
b17d8ff46 restore: make IsCheckpointImage reusable
e2fe9eaba Revert "remote: fix manifest add --annotation"
32f54a81e remote: fix manifest add --annotation
496d4c753 System tests: stop deep-checking log-level
ba70dd5ec build(deps): bump github.com/container-orchestrated-devices/container-device-interface
66517d86a fix: kube play liveness probe http path
f5fc0960e Default missing hostPort to containerPort is defined in kube.yaml
359e39744 libpod: Add volume support for FreeBSD
abe8dad34 libpod: Factor out usage of unix.MNT_DETACH from (*Volume).unmount
9de2a5ff7 libpod: Move volume_internal_linux.go to volume_internal_common.go
065474755 libpod: Move runtime_volume_linux.go to runtime_volume_common.go
95cb14aff fix: liveness check with http probe
3e8093152 System tests: light cleanup
0fb95f95d CI: only make install.tools when needed
2e4e1bb97 podman machine ssh handling
53d604182 Cirrus: Build pkginstaller in CI
c1ae7f193 Add SELinux information about boolean for using random devices
f32b02c7b Bump to v4.3.0-dev
f818eb4a5 Bump to v4.3.0-RC1
527fc409e Cirrus: Add golang code consistency check script
f6724116a Man pages: refactor common options: --env-file
7bc36602f auto-update: validate container image
fa18d35e8 Man pages: refactor common options: --env
911ceb823 Man pages: Refactor common options: --sig-proxy
fde4d21be man page xref: verify page title
8c627dfb5 Contrib: Add containerfile to create podman-remote binary image
9261a5469 Remove redundant log message
52656887e compat API: network inspect do not show isolate option
337f1f586 [CI:DOCS] man pages: fix incorrect title
f5e83f684 Fixup Buildah merge
54653ceeb Update vendor or containers/buildah
3a5b5d04b Fix machine starting state
69ac1e36c Cirrus: Catch use of deprecated io/ioutil package
8ff54cbe8 Fix libsubid detection
326d386ee [CI:BUILD] Copr: also define _user_tmpfilesdir for f35
2478e32ca fix restore API endpoint
6ee582315 Events for containers in pods now include the pod's ID
dc05d1212 Add --pretty to podman secret inspect
fc6dcd12b Add support for 'image' volume driver
5a2405ae1 Don't mount /dev/tty* inside privileged containers running systemd
d5f044ee7 System tests: reenable some skipped aarch64 tests
33c31112f cli: Add signature-policy flag to podman save
ba6f84666 Fix a few missed io/ioutil -> os updates
fb3d55006 Improve generate systemd format
9bb51e8e9 Add labels to secrets
7cfe0328f Add support to sig-proxy for podman-remote
377773ab5 Fix podman-remote run --attach stdin to show container ID
d968f3fe0 Replace deprecated ioutil
bb160be12 libpod: Implement 'podman cp' for FreeBSD
88f82ceab libpod: Move jointMountAndExec to container_copy_linux.go
75d6e7bae libpod: Move part of (*Container).stat to container_stat_linux.go
0b02d4cee libpod: Move container_copy_linux.go to container_copy_common.go
24d129071 libpod: Move container_stat_linux.go to container_stat_common.go
6790deb1b man pages: document some --format options
23195646d pkginstaller: use path_helper to add podman and helpers to path
dc8fdb46c label.Relabel third option is shared not recurse
049b10884 podman container clone env patch
903f551ae build(deps): bump github.com/coreos/go-systemd/v22 from 22.3.2 to 22.4.0
4a053a821 notifyproxy: don't set a read deadline
1071098ee kube play: sdnotify proxy: use a wait group
21841dc38 Default to --dns-option to match Docker and Buildah
d63e49a26 remote: checkpoint --export prints a rawInput or an error on remote
cfbc4aaeb Cleanup: fix problems reported by shell lint
e2573b734 Fix broken titles on readthedocs
62d1c487d Man pages: Refactor common options: --dns
7d1f688ff [CI:DOCS] man pages: document some --format options
884fd4575 Revert "generate systemd: drop ExecStop"
3508bd22f Add support for podman context as alias to podman system connection
9ba034293 Man pages: refactor common options: 2 stats opts
c20abf12c generate systemd: drop ExecStop
45d09e65b libpod: Make getContainerInspectData work on FreeBSD
2e4db139a libpod: Factor out platform-specfic code from generateInspectContainerHostConfig
60ef4ad1c stats: cap memory limit to the available memory
cf2118eab stats: map MaxUsage to the correct value
3f8591c2f Man pages: refactor common options: --shm-size
f76390d5e Man pages: refactor common options: --user
e19e0de5f Introduce graph-based pod container removal
51a8635c7 Cirrus: Fix win_installer task clone failure
cb6ad7631 Cirrus: Only run unit-testing on Fedora.
815655b9d Cirrus: Move gitlab test to cirrus-cron "main"
88879d588 System tests: cleanup in --format test
d4a62ff93 System tests: fix three races
14e5d1c15 libpod: fix lookup for subpath in volumes
92dc61d5e libpod: rename function
42937cd9a Ensure that a broken OCI spec does not break inspect
b6c75a3cc Man pages: refactor common options: --preserve-fds, -it
dd53ee599 fix ci: update systemd generate unit test
4df460836 Man pages: refactor common options: --ip6
47fff4b00 improve slirp4netns allow_host_loopback docs
0aedddd3b [systemd] Ensure that podCreateArgs appear last in ExecStartPre=
b47ce9a6e libpod: Add support for 'podman stats' on FreeBSD
b3e978e43 libpod: Split out the common code from GetContainerStats
47bd9e811 libpod: Move stats.go to stats_linux.go for consistency
1e6da1115 pkg/rctl: Add a simple FreeBSD RCTL library
75740be39 all: stop using deprecated GenerateNonCryptoID
76eb06330 Man pages: refactor common options: --tls-verify
fe04c86a2 generate systemd: fix pod dependencies
d4a000312 Man pages: Refactor common options: --publish
9d41b95d7 rework --format system test
dacd59424 Man pages: refactor common options: --publish-all
885bc4742 Enable github labeler, use for api-change
74e0511c9 Man pages: refactor common options: --os (pull)
f30d4852e Man pages: refactor common options: --ip
0ea5080c9 generate systemd: warn on --restart without --new
c8c2aab50 health checks: restart timers
908458d06 enable podman pod inspect --format test
7f8e99ded podman version: use report.Formatter over Template
0c21dcf70 podman machine info: use report.Formatter over Template
e5389e98f podman info: use report.Formatter over Template
1acebdda3 tests for 15673
43f7bdf82 podman inspect return exit code > 0 on print error
00240a0e2 podman inspect: use report.Formatter over Template
377599f1f podman secret inspect: use report.Formatter over Template
f5e13ded9 podman secret ls: use report.Formatter over Template
1463898b0 podman network ls: use report.Formatter over Template
90634d5ee podman volume ls: use report.Formatter over Template
20eccfc9d podman machine inspect: use report.Formatter over Template
a687949db podman machine ls: use report.Formatter over Template
65e78d92c podman auto-update: use report.Formatter over Template
70e6b19d4 events: Fix spelling of newNullEventer
9457549ff build(deps): bump github.com/vbauerster/mpb/v7 from 7.5.2 to 7.5.3
09ba2e0b9 Man pages: refactor common options: --rootfs
07a8eb829 Ensure that the DF endpoint updated volume refcount
e24c2f009 system tests: periodic cleanup and fixes
a63a40c3e podman events --format: fix duplicated newline
2ae4ce799 fix race where podman events exits to early
b3212a680 set default EventsLogFilePath on first run
12a1483e7 Improve --tmpdir and --events-backend docs
72e715a11 Use new secret store API
cd32b929e libpod: runtime newEventer() cleanup
76980a222 event backend journald: fix problem with empty journal
138b09c7e event backend none: return an error when reading events
c5bdb6afe fix hang with podman events file logger
56c880a7e libpod: Move ocicniPortsToNetTypesPorts and compareOCICNIPorts to networking_common.go
221c4d5f0 libpod: Move NetworkDisconnect and NetworkConnect to networking_common.go
f939f3fdf libpod: Move resultToBasicNetworkConfig to networking_common.go
c9de84080 libpod: Add support for getContainerNetworkInfo on FreeBSD
51c70e588 libpod: Move getContainerNetworkInfo to networking_common.go
d014dca81 libpod: Move isBridgeNetMode and reloadContainerNetwork to networking_common.go
1dd0eb467 libpod: Move teardownNetwork and teardownCNI to networking_common.go
2bf050f1d libpod: Move setUpNetwork and getCNIPodName to networking_common.go
3d7f9f67a libpod: Move convertPortMappings and getNetworkOptions to networking_common.go
d1414adbb libpod: Add FreeBSD implementation of container networking
c5f64d9f5 libpod: Re-work the container's network state to help code sharing
36cfd05a7 libpod: Move platform-specific bind mounts to a per-platform method
369d86040 libpod: Avoid a nil dereference when generating resolv.conf on FreeBSD
a1fa9faa4 Buildah treadmill script: various fixes
43da39d31 Man pages: refactor common options: --volumes-from
050ae6181 [CI:DOCS] --volume: consistent wording
d935e9799 update c/storage to latest
6091ff42d Include more environment variables in conmon env.
118546c6a refactor: use `os.ReadDir` for lightweight directory reading
2c63b8439 Fix stutters
b8108d06b Fix CPU usage limitation in play kube for non integer values
8466c4a19 Cirrus: Don't run win_installer in multiarch cron
6210c6723 TEMPORARY: instrumenting for 15488
3a9a7dcdc Man pages: refactor common options: --volume
a82672047 build(deps): bump github.com/docker/docker
6bf8670b6 stop: fix error handling
aad29e759 health check: add on-failure actions
8e1aa7af3 Fixes for vendoring Buildah
eb28a1c08 update buildah and c/common to latest
c7411af9e Ignore cpu realtime options on cgroups V2 systems
27be5eaaf Fix swagger documentation
9a286f712 generate, kube: plug HostUsers
1994f3823 Add --config for Docker compatibility
ad63aa20d kube: plug HostUsers in the pod spec
626ee118c e2e: fix run_staticip_test in proxy environment
d10e77e1b fix podman pod inspect to support multiple pods
911e4a138 specgen/generate: Factor out setting resource limits from CompleteSpec
db33f06a9 fixes data race in system.Events and nil error logging
f75c3181b podman: skip /sys/fs/cgroup/systemd if not present
3f0b5cd40 Man pages: refactor common options: --userns (pod)
8d40bf3f1 proper --debug/-D flag support
4fbc4b8f7 Man pages: refactor common options: --privileged
f85fa9806 libpod: Filter out ENOTCONN errors when trying to close unix domain sockets
6668ac93b libpod: Factor out capabilites code from prepareProcessExec
f6e3cfa53 system tests: fix systemd tests in proxy environment
744878a71 Add win-installer build/verify workflows to CI
ecb9f99b8 Add new windows installer and build
d759576ab emit container labels also for container exited and exec died events
9585147e1 fix Pod removal after OS hard shutdown
e0d5b4e3f Change pipe wait to 20 seconds
63c779a85 Fix manpage headers
4675103c2 Man pages: refactor common options: --sysctl
eb39d56df Bump github.com/docker/go-units from 0.4.0 to 0.5.0
f4c39df25 Add win-sshproxy.exe to windows client zips
40cd1c0ff Man pages: refactor common options: --device
4462305fe Update the displayed warning in documentation regarding the system reset
092690297 build(deps): bump github.com/container-orchestrated-devices/container-device-interface
77ab6125f remove SkipIfNotFedora() from events test
d22aeeec2 fix podman events with custom format
a9a411f8a Add generate systemd -e/--env option
274d34a25 kube play: support auto updates and rollbacks
04f0ac2aa system tests: fix some tests in proxy environment
6a3c28968 Drop stale config value resulting in asymmetric config
c2c910736 CI: Cirrus setup: retry failed curls
fb38838fe Man pages: refactor common options: --memory*
0df291d3b Update system reset warning message to warn against deletion of all volumes
bdfc4df1f pkg/autoupdate: allow updating multiple tasks per unit
cbaa78cd8 Fix list of default capabilities
a3aecf0f2 libpod: Factor out setting volume atime to container_internal_linux.go
7a1abd03c libpod: Move miscellaneous file handlling to container_internal_common.go
d162285f3 libpod: Don't mount /dev/shm in containers on FreeBSD
212b11c34 libpod: Factor out handling of slirp4netns and net=none
eab4291d9 libpod: Move functions related to /etc bind mounts to container_internal_common.go
b3989be76 libpod: Move getRootNetNsDepCtr to container_internal_common.go
a148c1622 libpod: Use (*Container).addNetworkNamespace to restore checkpoint network
7518a9136 libpod: Move functions related to checkpoints to container_internal_common.go
be5d1261b libpod: Move mountNotifySocket to container_internal_common.go
71e2074e8 libpod: Move getUserOverrides, lookupHostUser to container_internal_common.go
232eea5a0 libpod: Move isWorkDirSymlink, resolveWorkDir to container_internal_common.go
a5ee3cb79 pkg/util: Add no-op implementation of AddPrivilegedDevices on FreeBSD
0889215d8 libpod: Use platform-specific mount type for volume mounts
c1a86a8c4 libpod: Factor out platform-specific sections from generateSpec
e101f4350 libpod: Move getOverlayUpperAndWorkDir and generateSpec to container_internal_common.go
6e4b5b007 libpod: Add FreeBSD implementation of container internals
8ade76e79 libpod: Move networkDisable to container_linux.go
71978b0a0 Fix #15243 Set AutomountServiceAccountToken to false
b9df3a6a9 Man pages: refactor common options: --label
d82a41687 Add container GID to additional groups
3e1dde10b [CI:BUILD] Copr: Define _user_tmpfilesdir for rhel
875fd4858 Fix swagger documentation
070dfa3b3 Man pages: refactor common options: --digestfile
3e744e52b System tests for podman-update
c05b6e5d3 Update test per comment in #15555
3d09d47a2 Man pages: refactor common options: --device-X-Y
050f3291b implement podman update
c63830166 Man pages: refactor common options: --name
4a1acccf9 Fix bind-mount-option annotation in gen/play kube
64eb07941 CI: disable flaking test on ubuntu
b667d7340 libpod: Ensure that generated container names are random
5faf4eff1 Cirrus: pick UIDs/GIDs starting at 1500, not 1000
b25d62a4d [CI:BUILD] Packit: Disable until proved in other repos
84352a81c Set enableServiceLinks to false in generated yaml
fed4ce0ea Inhibit SIGTERM during Conmon startup
70a599b57 Man pages: refactor common options: --signal
da57065ab specgen: Use platform-specific mount type for volume mounts
0300271bf libpod/define: Make TypeBind a platform-specific constant
1ed9a4740 Man pages: refactor common options: --restart
98169c20d Add emptyDir volume support to kube play
8637548a3 docs: move userns options to separate file
e015c9e3f podman: add uid and gid options to keep-id
cd6260604 infra: remove dead code
62d87aa9b Man pages: refactor common options: --subXidname
08a2851ba Allow to override default username via command line
4781bc7fe specgen/generate: Add support for FreeBSD
68f4dcf00 specgen/generate: Move specConfigNamespaces to namespace_linux.go and add stubs
39880670c specgen/generate: Move SpecGenToOCI, WeightDevices to oci_linux.go and add stubs.
a240146a2 e2e tests: try to deflake 5000
08af95f63 updated apiv2 tests to reflect hash compat fix
c1480b39a Improved Windows compatibility for machine command
4e18c8100 Man pages: refactor common options: --http-proxy
0166feef2 specgen/generate: Move security.go to security_linux.go and add stubs
a7d791202 libpod: Make sure writeConmonPipeData is called on FreeBSD
d19438fa6 Man pages: refactor common options: --dns-*
dcb4d4357 [makefile] disable security labeling instead of using --privileged
78aec2130 Fix #15499 already connected network
b4f5a246a remove github.com/docker/libnetwork dependency
0ee9a3129 podman rmi: emit untag events
0b3184a5a pkg/domain: Add terminal support for FreeBSD
11de12097 Fix example sections to follow the same format
e4f816fdb [CI:DOCS] Cirrus: Update meta-task for EC2 image
e448122fe service: make move to sub-cgroup non fatal
167b026e7 [CI:BUILD] Packit: Re-introduce packit with fix-spec-file action
61d842a18 Fix template name inconsistency
39d809d3c Bump github.com/vbauerster/mpb/v7 from 7.4.2 to 7.5.2
e00272cd9 remote: fix implementation of build with --userns=auto for API
15aeccb83 libpod: UpdateContainerStatus: do not wait for container
61fc1870a cmd/podman: Enable --syslog on FreeBSD
cfdca8293 Mark some of the option fields as ignored in pkg/bindings
c7fda06f6 Compat API image remove events now have 'delete' status
9553f3baf Run codespell
b27bfbc71 [CI:DOCS] Automatically set podman version in pkginstaller
e634470fa APIv2 test cleanup, part 2 of 2
42fdc72aa Man pages: refactor common options: --systemd
a5a5c6b3f Temporarily Revert "Packit: Enable scratch build testing for Fedora 36, 37 and Rawhide"
10b460512 Remove duplicate annotations in generated service yaml
61fe95bb4 Preserve all unknown PolicyRequirement fields on (podman image trust set)
ad0c785f8 Reorganize the types in policy.go a bit
a7e88c8da Add support for showing keyPaths in (podman image trust show)
752eceaec Support (image trust show) for sigstoreSigned entries
b36a1d1b7 BREAKING CHANGE: Change how (podman image trust show) represents multiple requirements
bba306788 Reorganize descriptionsOfPolicyRequirements a bit
2f6c145e8 Use the full descriptionsOfPolicyRequirements for the default scope
b15afce55 Rename haveMatchRegistry to registriesDConfigurationForScope
1a97c4d9f Rename tempTrustShowOutput to entry
51064acc4 Split descriptionsOfPolicyRequirements out of getPolicyShowOutput
d4c521728 Recognize the new lookaside names for simple signing sigstore
4df1e2524 Add a unit test for trust.PolicyDescription
4b2bd1036 Make the output of (podman image trust show) deterministic
35fa8c16a Make most of pkg/trust package-private
7723a1ea6 Move most of ImageEngine.ShowTrust into pkg/trust.PolicyDescription
ff3f574fc Add support for sigstoreSigned in (podman image trust set)
9828bc445 Create new policy entries together with validating input
e2d1bdd1d Improve validation of data in ImageEngine.SetTrust
cbdbb025a Move most of imageEngine.SetTrust to pkg/trust.AddPolicyEntries
0ff0fde49 Man pages: refactor common options: log-related options
4f6807530 Add a variable for scope
4c5366ee0 Make trust.CreateTempFile private
5be00f227 Reorganize pkg/trust
1d2def8d0 Remove an unused trust.ShowOutput type
df1d8d0e9 Remove commented out code
010d495a3 APIv2 test cleanup
a933269ba System test cleanup
35b4f26c7 test: use private instead of slave for the mount
2fed2a282 Man pages: refactor common options: --pid
ea67d84f5 test: fix comment
19a617eaa Allow colons in windows file paths
1788b26c4 Fixes isRootfull check using qemu machine on Windows
88e4e4c82 vendor containers/psgo@v1.7.3
33ab7e846 Man pages: refactor common options: --ipc
ef6285a6f Man pages: refactor common options: --gidmap
c64a6ba07 Man pages: Refactor common options: --workdir
b0700aa48 libpod: Enable 'podman info' for FreeBSD
ff20c74e9 libpod: Move getCPUUtilization to info_linux.go
694cbaca3 libpod: Read kernel version and uptime using buildah/pkg/util
877e67399 libpod: Split out platform-specific code from hostInfo
e1c206d98 e2e: Add run --memory-swap test
c3dc92a50 Fix rpm packaging error
b4584ea85 run,create: add support for --env-merge for preprocessing vars
b47c54ab6 Install podman-docker.conf on user-tmpfiles.d too
0e6a421ca Use tmpfiles.d specifiers instead of fixed path
9dca68bdd Man pages: refactor common options: --ignore
d45a5d4aa Packit: Enable scratch build testing for Fedora 36, 37 and Rawhide
8b1e88bf8 Fix documentation of use of tcp connections
0f7393556 Add support for containers.conf volume timeouts
7d7aead51 Man pages: refactor common options: --device-cgroup-rule
65efcdf70 Allow podman to run in an environment with keys containing spaces
2c03681b2 Man pages: refactor common options: --disable-content-trust
8f797ab66 libpod: Add definition of containerPlatformState for FreeBSD
5c9bac141 Man pages: refactor common options: --cpus
5f719b533 podman kube play/down --read from URL
5b06b2e77 Document restrictions on transport in FROM
70e103c04 inspect, image: alias .Config.HealthCheck to .HealthCheck for compatibility
f87f6d2fc Improved Windows compatibility
64339d47c Warning messages are printed and ignored if we use an unsupported option
716ac1c86 Refactor: About the RawInput process
74388fe75 Man pages: refactor common options: --pod-id-file
0f768cef3 [CI:DOCS] Update Troubleshooting.md
c6488fe4a Man pages: fix sloppiness
53369aaa1 pass environment variables to container clone
46f31361f Man pages: refactor common options: --cidfile
bd90818b0 Man pages: refactor common options: --creds
fbe2bd87b [CI:DOCS] elaborate on image lookups of foreign platforms
eee0ec97e Add quiet/q flag to podman secret ls
d5f83135b version bump to 4.3.0-dev
be1455ead Update "CONTRIBUTING" file with Debian/Ubuntu dependencies"
f8e73eadd [CI:DOCS] Update how to enable resource limit delegation
a0560eefa Man pages: refactor common options: cert-dir
8ffeb626c events: Add freebsd support for libpod/event
8aa29fd54 cmd/podman: Enable ABI and Tunnel mode for freebsd
1f76ad40a fix CI: remove hardcodeded alpine version
3bf52aa33 Add ProgressWriter to PullOptions
ec9508ea1 Pass io.Writer when pushing images/manifests from command line
e48681e60 Use request Context() in API handlers
b9fb60c68 Simplify ImagesPull for when Quiet flag is on
09ef6fc66 podman generate kube - add actual tests
976ce76eb podman save: update --compress validation
054d64710 libpod: Build oci_conmon_common.go and oci_conmon_attach_common on FreeBSD
cb4158889 libpod: Move openUnixSocket to oci_conmon_attach_linux.go
d43fac20f libpod: Move moveConmonToCgroupAndSignal and GetLimits to oci_conmon_linux.go
93bad9048 libpod: Move socket label handling from oci_conmon_common.go to oci_conmon_linux.go
6791cdbdf libpod: Move rootless handling from oci_conmon_common.go to oci_conmon_linux.go
68b2450d3 libpod: Move oci_conmon_exec_linux.go to oci_conmon_exec_common.go
8d229c6cd libpod: Move oci_conmon_attach_linux.go to oci_conmon_attach_common.go
bebf55c0f libpod: Move oci_conmon_linux.go to oci_conmon_common.go
20ad12274 runtime: use FindCommon from c/common
86f665a1d vendor: update containers/common
0dd2fcf71 Add podman manifest create -a. Alias for --amend:Docker compatibility
aa197a65f sort hc.Binds returned from compat api
546bb3548 Add podman stats --no-trunc option
f6e7b0b59 Add podman secret inspect -f alias for --format: Docker compatibility
d50ff4f51 Add podman secret create -d as alias for --driver for Docker compatibility
6411f57e7 api: return imageID instead of imageName, for "Image" when Podman API is queried
2a6daa1e3 Cirrus: add podman_machine_aarch64
1572420c3 libpod: Move uses of unix.O_PATH to container_internal_linux.go
5d7778411 libpod: Move rootless network setup details to container_internal_linux.go
1b88927c2 libpod: Add stubs for non-linux builds
7e7a79b07 podman manifest create: accept --amend and --insecure flags
5f09d9b60 Fix podman kube generate --help to show correct help message
06b3a4c1c system tests: fix broken runc test
f0e864075 Man pages: refactor common options: authfile
a78b67a47 Man pages: refactor common options: --annotation
a68e6ddbb utils: Add missing symbols for FreeBSD
a6af67ca9 Cirrus: Update podman-machine comment
22f3dd4c2 Man pages: refactor common options: arch
f14bf91c4 podman images and friends can take one image as argument
7e490e195 [CI:DOCS] Add .DS_Store to gitignore
ab72a371b Don't warn on '/' not being shared while in a container
2d30b4dee Add compatibility support for --debug -D flag from docker
bfae6bca9 build(deps): bump github.com/mattn/go-isatty from 0.0.14 to 0.0.16
b9c094a5d Add Docker compatibility for --dns-option to --dns-opt
1393038c8 pkg/domain: Add stubs for non-linux builds
65641ba8d pkg/specgen: Add stubs for non-linux builds
056917c22 Reword --exit-policy option
d7f6d355b podman-kube@.service.in: Remove Restart=never option with typo
bd0a8c146 added docs for installing certficate authority
5ee3522f5 pkg: Build pkg/machine on FreeBSD
b806e9f36 pkg: Build pkg/util on FreeBSD
6df0ceb9a Add default value for $RM
bc56ee158 Update cmd/podman/containers/restart.go
f26a5246e Fix updated link to install instructions
0dbbb1cb3 Add restart --cidfile, --filter
d856fb43e Add "podman kube generate" command
e2a3f9592 docs: specify git protocol is not supported for github hosted repo
2935c38fd Update release notes for v4.2.0
a4efd401c remote manifest push: show copy progress
79e21b5b1 kube play: sd-notify integration
3fc126e15 libpod: allow the notify socket to be passed programatically
67a2e7351 add `pkg/systemd/notifyproxy`
245be9b39 Document behavior of --timestamp when only FROM is used
e3f029cb8 build(deps): bump github.com/container-orchestrated-devices/container-device-interface
658960c97 build(deps) bump CDI dependency from 0.4.0 to 0.5.0
2bcee9f62 Man pages: refactor common options
25f6fc9c6 I believe that these tests will now run with crun.
a561b7dac check memory test based on range
280f5d8cb podman ssh work, using new c/common interface
d2d7898b8 Cirrus: Improve CI VM image updates for EC2
d7f134d68 Refactor common man page options, phase 2
3738221c5 test: update apply-podman-deltas for new tests
59cb410fe build: implement --cache-to,--cache-from and --cache-ttl
7bd886480 Bump to Buildah v1.27.0
1045647a4 Add interface for apple hypervisor
62e889e2b fix LogConfig type for libpod API
2e3a192bb cmd: refuse --userns if a mapping is specified
696ea7905 specgen: use sandbox id instead of name for annotation
771a35e4b pkginstaller: use correct GOARCH value in case of arm build
b1d1248a1 pkg/bindings: Support writing image push progress to specified io.Writer
f4c53a41c docs: update the podman logo
7ebaabb93 [CI:COPR] podman.spec.rpkg: add python3 dependency for el8
d4c6e056d Fixes #15154 Change order when config and connections are written
83bd7a5c2 e2e: Add rootless mount cleanup test
cc8e4d5fe remove image podman no prune
842c6c7c6 podman generate spec
4cea8adb9 Cirrus: Run Cross builds in [CI:DOCS] mode
3102194f0 podman rmi: improve error message for build containers
5ea4ebb16 markdown-preprocess: force extra newline on comments
9964366f6 start filter flag changes
e67e60226 podman info: hide `--debug`
623b0c57f pkginstaller: use correct GOARCH while building podman binaries
bcfbee986 ISSUE TEMPLATE: remove `--debug` from `podman info`
81a1ea18c pkg/autoupdate: "image" policy: add deprecation comment
43cca5d97 pkg/autoupdate: decompose the update logic
0df51bb6b pkg/autoupdate: move status into `task`
af3ce7084 pkg/autoupdate: document fields of `updater`
3fdd3b1ae pkg/autoupdate: remove image map from updater
82d18a86f pkg/autoupdate: use policy consts were possible
1cc933c6b pkg/autoupdate: introduce status constants
42c4c17c0 pkg/autoupdate: move authfile into `tasks`
3f1928d76 pkg/autoupdate: move more logic under `task`
cfa089c36 pkg/autoupdate: s/updateImage/pullImage/
13a8ebd09 pkg/autoupdate: repull image if other containers failed
2c999f1ec pkg/autoupdate: update unit-by-unit
f8b6a81ae test/system/255-auto-update.bats: add an SELinux comment
87c0c760e pkg/autoupdate: introduce the notion of a `task`
033cc059f pkg/autoupdate: remove redundant branch
328c8ba7b pkg/autoupdate: move policy map into updater
d47609773 pkg/autoupdate: introduce `updater` for shared state
79b10a7c6 readthedocs(sphinx): run the markdown preprocessor
65fb90165 hack/markdown-preprocess: allow to be executed from any dir
031b7dec7 fix hack/markdown-preprocess to support older python versions
7df8d8050 add omitempty to Secret in k8s VolumeSource
328eb2b4c Cirrus: Remove disused env. var.
1e4a141d8 Cirrus: Support EC2 instances in hack/get_ci_vm.sh
44212b90b pkginstaller: makefile improvements to avoid redownloading
e6670cd29 pkginstaller: add makefile target to notarize the built pkg
c5029d2ee pkginstaller: sign qemu-system-* binary for the pkg
56039cffd Refactor common options in man pages
50981cb84 skip pod resource limits test on aarch64
1dbd61653 Cirrus: Fix e2e tests for "mount_rootless_test"
3a7a275c3 Cirrus: use dnf instead of rpm to install packages
1249cbb75 add "podman kube down" command
c5150a571 Add support, and default to rootless w/WSL prompt
bce16a58d Disable F36 service that is incompat with WSL kern
69d7407af switch from "kube/play" endpoint to "play/kube" endpoint.
2685c8dc4 Output messages display rawInput
4dfef202c podman generate systemd --new: allow -h hostname
5ab98f2c0 test: verify manifest inspect must contain OCI annotations
3a05ddfb7 fix e2e sign tests
6c69a2ea1 podman-volume-import: Reword "precendence"
c21306f06 man podman-volume-import: Clarify that merge happens
d462da676 Add support for creating sigstore signatures, and providing passphrases
7075e2e1d Hide podman manifest push --sign-by on remote
68cf11611 Use signByFlagName instead of copy&pasting the string
02f570e4b Remove libpod/common
63d77da5b Update c/common to an unreleased version
5a5624f81 Update the registry server we test against from 2.6 to 2.8
7599fde73 Use existing REGISTRY_IMAGE variables in more places
24a599fe1 Add flag "--compression-format" to "podman manifest push" both in local/remote mode.
53ec47968 Add rm --filter option
68463278e Use httpasswd from the surrouding OS instead of the registry image
49bcb7eaa Bump google.golang.org/protobuf from 1.28.0 to 1.28.1
7a909a3e2 Use 8k buffer to help clients w/ broken parsing
a53a0fca9 Cirrus: Minor YAML cleanup
a24cc463a Remove bats installation script and make target
6764fe03d CI: new check for leftover skips/fixmes
17e3680fb Bump golang.org/x/tools from 0.1.11 to 0.1.12 in /test/tools
379bf1080 Bump github.com/containernetworking/cni from 1.1.1 to 1.1.2
de04d9d75 docs: resolve typo in create,run manpages
de13dea86 With --rm option remove container if podman run fails
da98c8877 Cirrus: enable Fedora 36 aarch64 tasks on EC2
389a4a6cc syncContainer: transition from `stopping` to `exited`
7fab449e3 [CI:DOCS] socket_activation.md: Add start/stop sections
8628c01f5 Fix: manifest push --rm removes a correct manifest list
e4992fb81 Fix: Restore a container which name is equal to a image name
75419c5d8 When removing objects specifying --force,podman should exit with 0
56578c413 Cirrus: Use the latest imgts container
c35ae7640 Add support for building macOS pkg installer
8e56a5605 machine: Fix check which is always true
1b099eec8 [CI:DOCS] podman-generate-systemd.1.md: document --sdnotify
52a4642ed Set TLSVerify=true by default for API endpoints
94e0a364a Semiperiodoc cleanup of obsolete FIXMEs
27679d80b pod create --share none should not create infra
4d18a98ec benchmarks: fix create test
4724a0000 prune filter handling
6a9338ad6 podman generate systemd: handle --sdnotify correctly
ad8940cec fix container create/run throttle devices
290116bf8 integration test: fix network backend option with remote
5a80770e8 API: libpod/create use correct default umask
35035d281 container wait: improve error message
cbdda4e56 docs: remove CNI word where it is not applicable
0a160fed7 Bump VMs, to Ubuntu 2204 with cgroups v1
c00ea686f resource limits for pods
bc6a48eeb [CI:DOCS] Cirrus: Add prominent gitlab warning
88b57dd9f fix broken machine test
19f4a463e pkg/machine/e2e: do not import from cmd/podman
604920dd1 fix some pkg/machine/e2e test to read stderr
ee35ce86d enable linter for pkg/machine/e2e
dd2b79406 libpod: create /etc/passwd if missing
b79ac0aca remote push: show copy progress
afbfbe18a compose test: remove cni config copy
56093a3b4 compat api: always turn on network isolation for networks
80ad0cfd0 compat api: allow default bridge name for networks
3a016c6e4 e2e: show command and output when a timeout happens
138d185cc Bump github.com/BurntSushi/toml from 1.1.0 to 1.2.0
ab4c58bd3 Compat API: unify pull/push and add missing progress info
c1f04a024 podman-remote pull: fix duplicate progress outputs
af118f7c6 libpod: do not lock all containers on pod rm
139d65be8 Fix machine test
438fef1ca kube secret handling for podman play kube
8d190fc48 vendor: remove unused deps
013300a7c Makefile: remove building pages for man5
19495b9fc makefile: remove processing of pkg/docs
f64985135 rpkg: remove usage of pkg/hooks
ffe5da20a pkg,libpod: remove pkg/hooks and use hooks from c/common
da33f1005 Update init ctr default for play kube
4e72aa586 fix goroutine leaks in events and logs backend
9b152ef20 Add pause/unpause --latest, --cidfile, --filter
a65265942 Fix potential leak on mid-stream read error
10d6586cb Makefile: use order-only prereq for podman-remote
0a2ddc9bd [CI:DOCS] Fix typo in manifest manpage
26ae055a2 Remove return error from "containers.pause"
eef39b69e "pod pause/unpause/stop" append "report.Errs" to "reports"
aa1711e3d Cirrus: comment out f35 for podman4
1f0116817 system tests: new system-service bats file
fdba0d790 Vendor in latests containers/storage and opencontainers/runtime-tools
82b1d85eb Print rootfs download as a specific version on Win
576321729 document isolate option for network create
1aafb01a9 buildah vendor treadmill
f67ab1eb2 Vendor in containers/(storage,image, common, buildah)
5f848d89e Run codespell
18c0c19aa Add --host and -H as equivalent options to --url
c9722c0b1 [CI:DOCS] socket_activation.md: fix typo and layout
5f04f9961 Machine init: create .ssh dir if not exist
56cfdffe4 [CI:DOCS] Tutorials.rst: add socket activation
b513dc4c1 Clean up cached machine images
d95e79ebe GHA: Fix dumb error check
d385914cd Cirrus: Trigger podman-machine task by label
a2f6cc74e Podman stop --filter flag
90607a6d0 Podman pull --all-tags shorthand option
3b5034e91 fix tests for "podman kube play"
8e2add770 [CI:DOCS] Update docs/tutorials/socket_activation.md
2270bc5f9 [CI:DOCS] Add socket activation tutorial
ad7c54e13 man page checker: enforce stricter options format
66cb856f9 Switch to `github.com/blang/semver/v4`
0f53abd09 Fixes #14698 Use prepared image for WSL2 machine init
cc2cfe060 Add podman events -f to be alias for --filter
e08a77ce6 Add "podman kube play" cmd
1392922d4 [CI:DOCS] man pages: replace -c with --cpu-shares
e3419c032 abi: create new cgroup when running in a container
7b4afbf62 podman: always call into SetupRootless
16b8d77f9 utils: call MaybeMoveToSubCgroup once
4b547a72a podman: move MaybeMoveToSubCgroup to utils/
445089421 Fix last machine test
bb8ff86bf Use SafeChown rather then chown for volumes on NFS
c9a82d72a Docker uses "-c" to mean "--cpu-shares" in create and run
e83ff8e5e [CI:DOCS] podman-create.md: replace -c with --cpu-shares
da8c6a8ea CI: sanity check for desired runtime
b8a7e275d [CI:DOCS] rootless_tutorial: Remove incorrect advice regarding volumes and mount points
f6ed7a8c9 [CI:DOCS] man pages: remove non-existent option builtin-volume
27e12aa07 test,manifest-run: declare TARGETPLATFORM before using it
ffbc2adf7 fix wrong log message on Trace level
377057b40 [CI:DOCS] Improve language. Fix spelling and typos.
3ed323e1b logformatter: link by *task ID*, not build ID
3ce0709f3 podman machine: do not commit proxies into config file
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers/podman/podman_git.bb')
-rw-r--r-- | recipes-containers/podman/podman_git.bb | 7 |
1 files changed, 4 insertions, 3 deletions
diff --git a/recipes-containers/podman/podman_git.bb b/recipes-containers/podman/podman_git.bb index e3bc908f..5dd8c831 100644 --- a/recipes-containers/podman/podman_git.bb +++ b/recipes-containers/podman/podman_git.bb | |||
@@ -17,9 +17,9 @@ DEPENDS = " \ | |||
17 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ | 17 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ |
18 | " | 18 | " |
19 | 19 | ||
20 | SRCREV = "754ec89a8a185d308ca5ed08afaf34d6cbda08da" | 20 | SRCREV = "9ce592fcb9c8dd067eaa4321626d0e77820ea39e" |
21 | SRC_URI = " \ | 21 | SRC_URI = " \ |
22 | git://github.com/containers/libpod.git;branch=v4.2;protocol=https \ | 22 | git://github.com/containers/libpod.git;branch=v4.3;protocol=https \ |
23 | ${@bb.utils.contains('PACKAGECONFIG', 'rootless', 'file://50-podman-rootless.conf', '', d)} \ | 23 | ${@bb.utils.contains('PACKAGECONFIG', 'rootless', 'file://50-podman-rootless.conf', '', d)} \ |
24 | file://run-ptest \ | 24 | file://run-ptest \ |
25 | " | 25 | " |
@@ -31,7 +31,7 @@ GO_IMPORT = "import" | |||
31 | 31 | ||
32 | S = "${WORKDIR}/git" | 32 | S = "${WORKDIR}/git" |
33 | 33 | ||
34 | PV = "4.2.0+git${SRCPV}" | 34 | PV = "4.3.0+git${SRCPV}" |
35 | 35 | ||
36 | PACKAGES =+ "${PN}-contrib" | 36 | PACKAGES =+ "${PN}-contrib" |
37 | 37 | ||
@@ -126,6 +126,7 @@ FILES:${PN} += " \ | |||
126 | ${systemd_unitdir}/system/* \ | 126 | ${systemd_unitdir}/system/* \ |
127 | ${systemd_unitdir}/user/* \ | 127 | ${systemd_unitdir}/user/* \ |
128 | ${nonarch_libdir}/tmpfiles.d/* \ | 128 | ${nonarch_libdir}/tmpfiles.d/* \ |
129 | ${datadir}/user-tmpfiles.d/* \ | ||
129 | ${sysconfdir}/cni \ | 130 | ${sysconfdir}/cni \ |
130 | " | 131 | " |
131 | 132 | ||