summaryrefslogtreecommitdiffstats
path: root/recipes-containers/oci-runtime-tools
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2022-06-12 01:00:06 -0700
committerBruce Ashfield <bruce.ashfield@gmail.com>2022-06-20 12:09:46 -0400
commit08d50052bef68686c71b5021ff53dbc41af1f945 (patch)
tree11f3b25d838fbbf239c0e1a9eae2a20c019322c5 /recipes-containers/oci-runtime-tools
parent7808674c4cd92d719507ecec345c105f4740467d (diff)
downloadmeta-virtualization-08d50052bef68686c71b5021ff53dbc41af1f945.tar.gz
oci-runtime-tools: adjust GOROOT, CGO_CFLAGS and CGO_LDFALGS
Adjust the GOROOT setting as directory specified by the original one does not exist. The CGO_CFLAGS and CGO_LDFLAGS should use target flags instead of the nativesdk ones. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers/oci-runtime-tools')
-rw-r--r--recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb b/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
index 838d24b3..0a4c9090 100644
--- a/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
+++ b/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
@@ -18,7 +18,7 @@ inherit go
18 18
19do_compile() { 19do_compile() {
20 export GOARCH="${TARGET_GOARCH}" 20 export GOARCH="${TARGET_GOARCH}"
21 export GOROOT="${STAGING_LIBDIR_NATIVE}/${TARGET_SYS}/go" 21 export GOROOT="${STAGING_LIBDIR}/go"
22 export GOPATH="${S}/src/import:${S}/src/import/vendor" 22 export GOPATH="${S}/src/import:${S}/src/import/vendor"
23 23
24 # Pass the needed cflags/ldflags so that cgo 24 # Pass the needed cflags/ldflags so that cgo
@@ -26,8 +26,8 @@ do_compile() {
26 export CGO_ENABLED="1" 26 export CGO_ENABLED="1"
27 export CFLAGS="" 27 export CFLAGS=""
28 export LDFLAGS="" 28 export LDFLAGS=""
29 export CGO_CFLAGS="${BUILDSDK_CFLAGS} --sysroot=${STAGING_DIR_TARGET}" 29 export CGO_CFLAGS="${TARGET_CFLAGS}"
30 export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}" 30 export CGO_LDFLAGS="${TARGET_LDFLAGS}"
31 export GO111MODULE=off 31 export GO111MODULE=off
32 32
33 # fixes: 33 # fixes: