summaryrefslogtreecommitdiffstats
path: root/recipes-containers/kubernetes
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2021-09-26 17:41:15 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-09-30 22:25:49 -0400
commit17365d3afaa70763d84fca6e45c25214963769b2 (patch)
tree463fb037479c4333669cbc1398b3f019cf07e5a8 /recipes-containers/kubernetes
parent0aa16595a1df0d370aac7698830e4fe944ae0c65 (diff)
downloadmeta-virtualization-17365d3afaa70763d84fca6e45c25214963769b2.tar.gz
kubernetes: update sed expression
It misses a backslash in sed expression and causes warning when run do_compile: | sed: -e expression #1, char 35: Unmatched ) or \) Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers/kubernetes')
-rw-r--r--recipes-containers/kubernetes/kubernetes_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-containers/kubernetes/kubernetes_git.bb b/recipes-containers/kubernetes/kubernetes_git.bb
index e165ebe5..1ba52b65 100644
--- a/recipes-containers/kubernetes/kubernetes_git.bb
+++ b/recipes-containers/kubernetes/kubernetes_git.bb
@@ -50,7 +50,7 @@ do_compile() {
50 export CGO_CFLAGS="${BUILD_CFLAGS}" 50 export CGO_CFLAGS="${BUILD_CFLAGS}"
51 # as of go 1.15.5, there are some flags the CGO doesn't like. Rather than 51 # as of go 1.15.5, there are some flags the CGO doesn't like. Rather than
52 # clearing them all, we sed away the ones we don't want. 52 # clearing them all, we sed away the ones we don't want.
53 export CGO_LDFLAGS="$(echo ${BUILD_LDFLAGS} | sed 's/-Wl,-O1//g' | sed 's/-Wl,--dynamic-linker.*?( \|$\)//g')" 53 export CGO_LDFLAGS="$(echo ${BUILD_LDFLAGS} | sed 's/-Wl,-O1//g' | sed 's/-Wl,--dynamic-linker.*?\( \|$\)//g')"
54 export CC="${BUILD_CC}" 54 export CC="${BUILD_CC}"
55 export LD="${BUILD_LD}" 55 export LD="${BUILD_LD}"
56 56