summaryrefslogtreecommitdiffstats
path: root/recipes-containers/kubernetes/kubernetes_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2022-09-15 13:59:39 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2022-09-15 14:00:46 -0400
commitd9af46db9aa9060c1ec10118b2cccabfc8264904 (patch)
tree72ab5c5c8f00d64b6f8ef0e1f0a65ed36e985874 /recipes-containers/kubernetes/kubernetes_git.bb
parenta61f6ea090891356bdddd3b63fa2fee228fd38af (diff)
downloadmeta-virtualization-d9af46db9aa9060c1ec10118b2cccabfc8264904.tar.gz
kubernetes: fix more TMPDIR references
Changing the clone location of kubernetes allows us to remove the vendor symlink "fix". This reduces the number of TMPDIR references in the binaries. kubernetes takes care of most of the rest via using asmflags and gcflags interally which specify -trimpath, but unfortunately these flags are being recorded into the binaries and leave us with 4 references to the TMDIR: -asmflags=all=-trimpath=/opt/poky/build/tmp/work/core2-64-poky-linux/kubernetes/1_v1.24.0+git8b1b4db3834ddf7cf1b97137180f413cb9e2186f-r0/git/src/github.com/kubernetes/kubernetes/_output/local/go/src/k8s.io/kubernetes -gcflags="all=-trimpath=/opt/poky/build/tmp/work/core2-64-poky-linux/kubernetes/1_v1.24.0+git8b1b4db3834ddf7cf1b97137180f413cb9e2186f-r0/git/src/github.com/kubernetes/kubernetes/_output/local/go/src/k8s.io/kubernetes -asmflags=all=-trimpath=/opt/poky/build/tmp/work/core2-64-poky-linux/kubernetes/1_v1.24.0+git8b1b4db3834ddf7cf1b97137180f413cb9e2186f-r0/git/src/github.com/kubernetes/kubernetes/_output/local/go/src/k8s.io/kubernetes -gcflags="all=-trimpath=/opt/poky/build/tmp/work/core2-64-poky-linux/kubernetes/1_v1.24.0+git8b1b4db3834ddf7cf1b97137180f413cb9e2186f-r0/git/src/github.com/kubernetes/kubernetes/_output/local/go/src/k8s.io/kubernetes We leave these for now, as attempts to remove them have broken the build, and kubernetes uses 'go install' versus 'go build' to construct the binaries .. making our normal solutions non functional. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers/kubernetes/kubernetes_git.bb')
-rw-r--r--recipes-containers/kubernetes/kubernetes_git.bb17
1 files changed, 7 insertions, 10 deletions
diff --git a/recipes-containers/kubernetes/kubernetes_git.bb b/recipes-containers/kubernetes/kubernetes_git.bb
index e9460d46..3289a641 100644
--- a/recipes-containers/kubernetes/kubernetes_git.bb
+++ b/recipes-containers/kubernetes/kubernetes_git.bb
@@ -11,7 +11,7 @@ SRCREV_kubernetes-release = "7c1aa83dac555de6f05500911467b70aca4949f0"
11PE = "1" 11PE = "1"
12 12
13BBCLASSEXTEND = "devupstream:target" 13BBCLASSEXTEND = "devupstream:target"
14LIC_FILES_CHKSUM:class-devupstream = "file://src/import/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" 14LIC_FILES_CHKSUM:class-devupstream = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
15DEFAULT_PREFERENCE:class-devupstream = "-1" 15DEFAULT_PREFERENCE:class-devupstream = "-1"
16SRC_URI:classedevupstream = "git://github.com/kubernetes/kubernetes.git;branch=master;name=kubernetes;protocol=https \ 16SRC_URI:classedevupstream = "git://github.com/kubernetes/kubernetes.git;branch=master;name=kubernetes;protocol=https \
17 git://github.com/kubernetes/release;branch=master;name=kubernetes-release;destsuffix=git/release;protocol=https \ 17 git://github.com/kubernetes/release;branch=master;name=kubernetes-release;destsuffix=git/release;protocol=https \
@@ -22,7 +22,7 @@ PV:class-devupstream = "v1.23-alpha+git${SRCPV}"
22 22
23SRCREV_FORMAT ?= "kubernetes_release" 23SRCREV_FORMAT ?= "kubernetes_release"
24 24
25SRC_URI = "git://github.com/kubernetes/kubernetes.git;branch=release-1.24;name=kubernetes;protocol=https \ 25SRC_URI = "git://github.com/kubernetes/kubernetes.git;branch=release-1.24;name=kubernetes;protocol=https;destsuffix=git/src/github.com/kubernetes/kubernetes \
26 git://github.com/kubernetes/release;branch=master;name=kubernetes-release;destsuffix=git/release;protocol=https" 26 git://github.com/kubernetes/release;branch=master;name=kubernetes-release;destsuffix=git/release;protocol=https"
27 27
28SRC_URI:append = " \ 28SRC_URI:append = " \
@@ -40,9 +40,10 @@ DEPENDS += "rsync-native \
40 " 40 "
41 41
42LICENSE = "Apache-2.0" 42LICENSE = "Apache-2.0"
43LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" 43LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
44 44
45GO_IMPORT = "import" 45GO_IMPORT = "import"
46S = "${WORKDIR}/git/src/github.com/kubernetes/kubernetes"
46 47
47inherit systemd 48inherit systemd
48inherit go 49inherit go
@@ -52,12 +53,8 @@ inherit cni_networking
52COMPATIBLE_HOST = '(x86_64.*|arm.*|aarch64.*)-linux' 53COMPATIBLE_HOST = '(x86_64.*|arm.*|aarch64.*)-linux'
53 54
54do_compile() { 55do_compile() {
55 # link fixups for compilation 56 export GOPATH="${S}/src/import/.gopath:${S}/src/import/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go:${WORKDIR}/git/"
56 rm -f ${S}/src/import/vendor/src 57 cd ${S}
57 ln -sf ./ ${S}/src/import/vendor/src
58
59 export GOPATH="${S}/src/import/.gopath:${S}/src/import/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go"
60 cd ${S}/src/import
61 58
62 # Build the host tools first, using the host compiler 59 # Build the host tools first, using the host compiler
63 export GOARCH="${BUILD_GOARCH}" 60 export GOARCH="${BUILD_GOARCH}"
@@ -97,7 +94,7 @@ do_install() {
97 94
98 install -d ${D}${sysconfdir}/kubernetes/manifests/ 95 install -d ${D}${sysconfdir}/kubernetes/manifests/
99 96
100 install -m 755 -D ${S}/src/import/_output/local/bin/${TARGET_GOOS}/${TARGET_GOARCH}/* ${D}/${bindir} 97 install -m 755 -D ${S}/_output/local/bin/${TARGET_GOOS}/${TARGET_GOARCH}/* ${D}/${bindir}
101 98
102 install -m 0644 ${WORKDIR}/git/release/cmd/kubepkg/templates/latest/deb/kubelet/lib/systemd/system/kubelet.service ${D}${systemd_unitdir}/system/ 99 install -m 0644 ${WORKDIR}/git/release/cmd/kubepkg/templates/latest/deb/kubelet/lib/systemd/system/kubelet.service ${D}${systemd_unitdir}/system/
103 install -m 0644 ${WORKDIR}/git/release/cmd/kubepkg/templates/latest/deb/kubeadm/10-kubeadm.conf ${D}${systemd_unitdir}/system/kubelet.service.d/ 100 install -m 0644 ${WORKDIR}/git/release/cmd/kubepkg/templates/latest/deb/kubeadm/10-kubeadm.conf ${D}${systemd_unitdir}/system/kubelet.service.d/