summaryrefslogtreecommitdiffstats
path: root/recipes-containers/kubernetes/kubernetes_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2024-05-28 13:17:03 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2024-05-29 13:16:56 +0000
commit2aa6da625d493f92000a8f786496d19823a01a28 (patch)
tree030e7ccec73bedf177c370c94cbd55fd9e4f99bc /recipes-containers/kubernetes/kubernetes_git.bb
parent01a6b4771f1d4def1fb8f5efe8433e54faf4b422 (diff)
downloadmeta-virtualization-2aa6da625d493f92000a8f786496d19823a01a28.tar.gz
kubernetes: convert remaining WORKDIR references to UNPACKDIR
While the WORKDIR references seem to work, they may not continue to work. We switch to using UNPACKDIR which is where the SRC_URI referenced elements / files will be placed by the fetcher. The remaining WORDIR references are to a secondary git repository with artifacts and should be safe. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers/kubernetes/kubernetes_git.bb')
-rw-r--r--recipes-containers/kubernetes/kubernetes_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-containers/kubernetes/kubernetes_git.bb b/recipes-containers/kubernetes/kubernetes_git.bb
index 044175eb..a742486c 100644
--- a/recipes-containers/kubernetes/kubernetes_git.bb
+++ b/recipes-containers/kubernetes/kubernetes_git.bb
@@ -112,14 +112,14 @@ do_install() {
112 112
113 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then 113 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
114 install -d "${D}${BIN_PREFIX}${base_bindir}" 114 install -d "${D}${BIN_PREFIX}${base_bindir}"
115 install -m 755 "${WORKDIR}/k8s-init" "${D}${BIN_PREFIX}${base_bindir}" 115 install -m 755 "${UNPACKDIR}/k8s-init" "${D}${BIN_PREFIX}${base_bindir}"
116 116
117 install -d ${D}${sysconfdir}/sysctl.d 117 install -d ${D}${sysconfdir}/sysctl.d
118 install -m 0644 "${WORKDIR}/99-kubernetes.conf" "${D}${sysconfdir}/sysctl.d" 118 install -m 0644 "${UNPACKDIR}/99-kubernetes.conf" "${D}${sysconfdir}/sysctl.d"
119 fi 119 fi
120} 120}
121 121
122CNI_NETWORKING_FILES ?= "${WORKDIR}/cni-containerd-net.conflist" 122CNI_NETWORKING_FILES ?= "${UNPACKDIR}/cni-containerd-net.conflist"
123 123
124PACKAGES =+ "kubeadm kubectl kubelet kube-proxy ${PN}-misc ${PN}-host" 124PACKAGES =+ "kubeadm kubectl kubelet kube-proxy ${PN}-misc ${PN}-host"
125 125