diff options
author | Ricardo Salveti <ricardo@foundries.io> | 2020-02-18 19:59:13 -0300 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2020-02-20 12:43:17 -0500 |
commit | b19fe49b67c3835ba88131bf79c2f7f07c8b24e9 (patch) | |
tree | 6dbe4e878fade35b259241d3dd22b31fb5ff3430 /recipes-containers/docker | |
parent | b1b4fca4f04ba878d7c70c18817deb42eab3b712 (diff) | |
download | meta-virtualization-b19fe49b67c3835ba88131bf79c2f7f07c8b24e9.tar.gz |
docker-ce: allow custom build tags via packageconfig
As done by the docker-moby recipe, move the definition of the default
build tags outside do_compile and let the docker build tags be
customized via the packageconfig options set by the recipe.
This is required for enabling seccomp support during build time.
Signed-off-by: Ricardo Salveti <ricardo@foundries.io>
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers/docker')
-rw-r--r-- | recipes-containers/docker/docker-ce_git.bb | 5 |
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes-containers/docker/docker-ce_git.bb b/recipes-containers/docker/docker-ce_git.bb index ef840697..3c8a339f 100644 --- a/recipes-containers/docker/docker-ce_git.bb +++ b/recipes-containers/docker/docker-ce_git.bb | |||
@@ -44,6 +44,8 @@ PV = "${DOCKER_VERSION}+git${SRCREV_docker}" | |||
44 | PACKAGES =+ "${PN}-contrib" | 44 | PACKAGES =+ "${PN}-contrib" |
45 | 45 | ||
46 | DOCKER_PKG="github.com/docker/docker" | 46 | DOCKER_PKG="github.com/docker/docker" |
47 | # in order to exclude devicemapper and btrfs - https://github.com/docker/docker/issues/14056 | ||
48 | BUILD_TAGS = "exclude_graphdriver_btrfs exclude_graphdriver_devicemapper" | ||
47 | 49 | ||
48 | inherit go | 50 | inherit go |
49 | inherit goarch | 51 | inherit goarch |
@@ -71,8 +73,7 @@ do_compile() { | |||
71 | export CGO_ENABLED="1" | 73 | export CGO_ENABLED="1" |
72 | export CGO_CFLAGS="${CFLAGS} --sysroot=${STAGING_DIR_TARGET}" | 74 | export CGO_CFLAGS="${CFLAGS} --sysroot=${STAGING_DIR_TARGET}" |
73 | export CGO_LDFLAGS="${LDFLAGS} --sysroot=${STAGING_DIR_TARGET}" | 75 | export CGO_LDFLAGS="${LDFLAGS} --sysroot=${STAGING_DIR_TARGET}" |
74 | # in order to exclude devicemapper and btrfs - https://github.com/docker/docker/issues/14056 | 76 | export DOCKER_BUILDTAGS='${BUILD_TAGS} ${PACKAGECONFIG_CONFARGS}' |
75 | export DOCKER_BUILDTAGS='exclude_graphdriver_btrfs exclude_graphdriver_devicemapper' | ||
76 | 77 | ||
77 | export DISABLE_WARN_OUTSIDE_CONTAINER=1 | 78 | export DISABLE_WARN_OUTSIDE_CONTAINER=1 |
78 | 79 | ||