summaryrefslogtreecommitdiffstats
path: root/recipes-containers/docker
diff options
context:
space:
mode:
authorJason Wessel <jason.wessel@windriver.com>2017-09-13 12:39:46 -0700
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-09-14 09:49:00 -0400
commit01a8d4537012ad93dc8510e9b762acdc8c4536c7 (patch)
tree8b22ba0333f7a8c83193bee31b33a3b307f1164a /recipes-containers/docker
parent718592922bd64da4d609c96e831f6aba05e44a8d (diff)
downloadmeta-virtualization-01a8d4537012ad93dc8510e9b762acdc8c4536c7.tar.gz
nets, docker, runc, oci-*tools: go.bbclass compile fixes
Recently in the oe-core the go.bbclass changed and requires the defition of the GO_IMPORT variable. This was intended to simplify how the compilation works with go packages and it is still a work in progress. This patch set makes the recipes compatible to generate the same end result as before using the new go.bbclass from oe-core. Any patches that were included in the recipes had to have the paths adjusted because the new go.bbclass manipulates the notion of S to be S + "src" + "$GO_IMPORT" internally for the purpose of unpack, patch and compile. Signed-off-by: Jason Wessel <jason.wessel@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'recipes-containers/docker')
-rw-r--r--recipes-containers/docker/docker_git.bb29
-rw-r--r--recipes-containers/docker/files/context-use-golang.org-x-net-pkg-until-we-move-to-go.patch20
2 files changed, 25 insertions, 24 deletions
diff --git a/recipes-containers/docker/docker_git.bb b/recipes-containers/docker/docker_git.bb
index 1ced8f47..4d6c17c9 100644
--- a/recipes-containers/docker/docker_git.bb
+++ b/recipes-containers/docker/docker_git.bb
@@ -32,7 +32,9 @@ SRC_URI = "\
32 32
33# Apache-2.0 for docker 33# Apache-2.0 for docker
34LICENSE = "Apache-2.0" 34LICENSE = "Apache-2.0"
35LIC_FILES_CHKSUM = "file://LICENSE;md5=9740d093a080530b5c5c6573df9af45a" 35LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=9740d093a080530b5c5c6573df9af45a"
36
37GO_IMPORT = "import"
36 38
37S = "${WORKDIR}/git" 39S = "${WORKDIR}/git"
38 40
@@ -81,18 +83,17 @@ do_compile() {
81 # Set GOPATH. See 'PACKAGERS.md'. Don't rely on 83 # Set GOPATH. See 'PACKAGERS.md'. Don't rely on
82 # docker to download its dependencies but rather 84 # docker to download its dependencies but rather
83 # use dependencies packaged independently. 85 # use dependencies packaged independently.
84 cd ${S} 86 cd ${S}/src/import
85 rm -rf .gopath 87 rm -rf .gopath
86 mkdir -p .gopath/src/"$(dirname "${DOCKER_PKG}")" 88 mkdir -p .gopath/src/"$(dirname "${DOCKER_PKG}")"
87 ln -sf ../../../.. .gopath/src/"${DOCKER_PKG}" 89 ln -sf ../../../.. .gopath/src/"${DOCKER_PKG}"
88 90
89 mkdir -p .gopath/src/github.com/docker 91 mkdir -p .gopath/src/github.com/docker
90 ln -sf ../../../../../libnetwork .gopath/src/github.com/docker/libnetwork 92 ln -sf ${WORKDIR}/libnetwork .gopath/src/github.com/docker/libnetwork
91 ln -sf ../../../../../cli .gopath/src/github.com/docker/cli 93 ln -sf ${WORKDIR}/cli .gopath/src/github.com/docker/cli
92 94
93 export GOPATH="${S}/.gopath:${S}/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go" 95 export GOPATH="${S}/src/import/.gopath:${S}/src/import/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go"
94 export GOROOT="${STAGING_DIR_NATIVE}/${nonarch_libdir}/${HOST_SYS}/go" 96 export GOROOT="${STAGING_DIR_NATIVE}/${nonarch_libdir}/${HOST_SYS}/go"
95 cd -
96 97
97 # Pass the needed cflags/ldflags so that cgo 98 # Pass the needed cflags/ldflags so that cgo
98 # can find the needed headers files and libraries 99 # can find the needed headers files and libraries
@@ -109,10 +110,10 @@ do_compile() {
109 ./hack/make.sh dynbinary 110 ./hack/make.sh dynbinary
110 111
111 # build the proxy 112 # build the proxy
112 go build -o ${S}/docker-proxy github.com/docker/libnetwork/cmd/proxy 113 go build -o ${S}/src/import/docker-proxy github.com/docker/libnetwork/cmd/proxy
113 114
114 # build the cli 115 # build the cli
115 go build -o ${S}/bundles/latest/dynbinary-client/docker github.com/docker/cli/cmd/docker 116 go build -o ${S}/src/import/bundles/latest/dynbinary-client/docker github.com/docker/cli/cmd/docker
116} 117}
117 118
118SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES','systemd','${PN}','',d)}" 119SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES','systemd','${PN}','',d)}"
@@ -126,15 +127,15 @@ INITSCRIPT_PARAMS_${PN} = "defaults"
126 127
127do_install() { 128do_install() {
128 mkdir -p ${D}/${bindir} 129 mkdir -p ${D}/${bindir}
129 cp ${S}/bundles/latest/dynbinary-client/docker ${D}/${bindir}/docker 130 cp ${S}/src/import/bundles/latest/dynbinary-client/docker ${D}/${bindir}/docker
130 cp ${S}/bundles/latest/dynbinary-daemon/dockerd ${D}/${bindir}/dockerd 131 cp ${S}/src/import/bundles/latest/dynbinary-daemon/dockerd ${D}/${bindir}/dockerd
131 cp ${S}/docker-proxy ${D}/${bindir}/docker-proxy 132 cp ${S}/src/import/docker-proxy ${D}/${bindir}/docker-proxy
132 133
133 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then 134 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
134 install -d ${D}${systemd_unitdir}/system 135 install -d ${D}${systemd_unitdir}/system
135 install -m 644 ${S}/contrib/init/systemd/docker.* ${D}/${systemd_unitdir}/system 136 install -m 644 ${S}/src/import/contrib/init/systemd/docker.* ${D}/${systemd_unitdir}/system
136 # replaces one copied from above with one that uses the local registry for a mirror 137 # replaces one copied from above with one that uses the local registry for a mirror
137 install -m 644 ${S}/contrib/init/systemd/docker.service ${D}/${systemd_unitdir}/system 138 install -m 644 ${S}/src/import/contrib/init/systemd/docker.service ${D}/${systemd_unitdir}/system
138 else 139 else
139 install -d ${D}${sysconfdir}/init.d 140 install -d ${D}${sysconfdir}/init.d
140 install -m 0755 ${WORKDIR}/docker.init ${D}${sysconfdir}/init.d/docker.init 141 install -m 0755 ${WORKDIR}/docker.init ${D}${sysconfdir}/init.d/docker.init
@@ -142,7 +143,7 @@ do_install() {
142 143
143 mkdir -p ${D}${datadir}/docker/ 144 mkdir -p ${D}${datadir}/docker/
144 cp ${WORKDIR}/hi.Dockerfile ${D}${datadir}/docker/ 145 cp ${WORKDIR}/hi.Dockerfile ${D}${datadir}/docker/
145 install -m 0755 ${S}/contrib/check-config.sh ${D}${datadir}/docker/ 146 install -m 0755 ${S}/src/import/contrib/check-config.sh ${D}${datadir}/docker/
146} 147}
147 148
148inherit useradd 149inherit useradd
diff --git a/recipes-containers/docker/files/context-use-golang.org-x-net-pkg-until-we-move-to-go.patch b/recipes-containers/docker/files/context-use-golang.org-x-net-pkg-until-we-move-to-go.patch
index c43a7e74..7ed606ff 100644
--- a/recipes-containers/docker/files/context-use-golang.org-x-net-pkg-until-we-move-to-go.patch
+++ b/recipes-containers/docker/files/context-use-golang.org-x-net-pkg-until-we-move-to-go.patch
@@ -18,8 +18,8 @@ Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
18 integration-cli/docker_cli_save_load_unix_test.go | 2 +- 18 integration-cli/docker_cli_save_load_unix_test.go | 2 +-
19 5 files changed, 5 insertions(+), 5 deletions(-) 19 5 files changed, 5 insertions(+), 5 deletions(-)
20 20
21--- a/client/README.md 21--- a/src/import/client/README.md
22+++ b/client/README.md 22+++ b/src/import/client/README.md
23@@ -8,7 +8,7 @@ For example, to list running containers 23@@ -8,7 +8,7 @@ For example, to list running containers
24 package main 24 package main
25 25
@@ -29,8 +29,8 @@ Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
29 "fmt" 29 "fmt"
30 30
31 "github.com/docker/docker/api/types" 31 "github.com/docker/docker/api/types"
32--- a/client/client.go 32--- a/src/import/client/client.go
33+++ b/client/client.go 33+++ b/src/import/client/client.go
34@@ -19,7 +19,7 @@ For example, to list running containers 34@@ -19,7 +19,7 @@ For example, to list running containers
35 package main 35 package main
36 36
@@ -40,8 +40,8 @@ Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
40 "fmt" 40 "fmt"
41 41
42 "github.com/docker/docker/api/types" 42 "github.com/docker/docker/api/types"
43--- a/daemon/info_unix.go 43--- a/src/import/daemon/info_unix.go
44+++ b/daemon/info_unix.go 44+++ b/src/import/daemon/info_unix.go
45@@ -3,7 +3,7 @@ 45@@ -3,7 +3,7 @@
46 package daemon 46 package daemon
47 47
@@ -51,8 +51,8 @@ Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
51 "os/exec" 51 "os/exec"
52 "strings" 52 "strings"
53 53
54--- a/integration-cli/docker_api_attach_test.go 54--- a/src/import/integration-cli/docker_api_attach_test.go
55+++ b/integration-cli/docker_api_attach_test.go 55+++ b/src/import/integration-cli/docker_api_attach_test.go
56@@ -3,7 +3,7 @@ package main 56@@ -3,7 +3,7 @@ package main
57 import ( 57 import (
58 "bufio" 58 "bufio"
@@ -62,8 +62,8 @@ Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
62 "io" 62 "io"
63 "net" 63 "net"
64 "net/http" 64 "net/http"
65--- a/integration-cli/docker_cli_save_load_unix_test.go 65--- a/src/import/integration-cli/docker_cli_save_load_unix_test.go
66+++ b/integration-cli/docker_cli_save_load_unix_test.go 66+++ b/src/import/integration-cli/docker_cli_save_load_unix_test.go
67@@ -3,7 +3,7 @@ 67@@ -3,7 +3,7 @@
68 package main 68 package main
69 69