summaryrefslogtreecommitdiffstats
path: root/recipes-containers/crun
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2023-04-02 00:10:27 +0200
committerBruce Ashfield <bruce.ashfield@gmail.com>2023-04-12 13:10:11 -0400
commit31e8dc838bc5642d204a40c9bc4f4a896e885325 (patch)
treeb2f5035f5cd6ae71b6a28d6cfc326d887f40e4fe /recipes-containers/crun
parentf964138a214566945a7e902ca2b063ed5c4eec7b (diff)
downloadmeta-virtualization-31e8dc838bc5642d204a40c9bc4f4a896e885325.tar.gz
crun: fix REQUIRED_DISTRO_FEATURES
* features_check was inherit twice and REQUIRED_DISTRO_FEATURES was set twice as well but both with ?= so the 2nd one was ignored * seccomp was added in: commit b8f2edd39af6b7ac4461158b0d0382e88e93d6f1 Author: Bruce Ashfield <bruce.ashfield@gmail.com> Date: Wed Jun 30 11:22:42 2021 -0400 Subject: crun: add seccomp distro features check but there was already systemd from: commit 144d1ae8973e8c67709d7b544dc53b80bf924754 Author: Bruce Ashfield <bruce.ashfield@gmail.com> Date: Fri Apr 23 10:32:24 2021 -0400 Subject: crun: use REQUIRED_DISTRO_FEATURES to indicate systemd dependency Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers/crun')
-rw-r--r--recipes-containers/crun/crun_git.bb4
1 files changed, 1 insertions, 3 deletions
diff --git a/recipes-containers/crun/crun_git.bb b/recipes-containers/crun/crun_git.bb
index 40789dc0..39de588b 100644
--- a/recipes-containers/crun/crun_git.bb
+++ b/recipes-containers/crun/crun_git.bb
@@ -20,14 +20,12 @@ SRC_URI = "git://github.com/containers/crun.git;branch=main;name=crun;protocol=h
20PV = "1.8.3+git${SRCREV_crun}" 20PV = "1.8.3+git${SRCREV_crun}"
21S = "${WORKDIR}/git" 21S = "${WORKDIR}/git"
22 22
23REQUIRED_DISTRO_FEATURES ?= "systemd" 23REQUIRED_DISTRO_FEATURES ?= "systemd seccomp"
24 24
25inherit autotools-brokensep pkgconfig features_check 25inherit autotools-brokensep pkgconfig features_check
26 26
27PACKAGECONFIG ??= "" 27PACKAGECONFIG ??= ""
28 28
29inherit features_check
30REQUIRED_DISTRO_FEATURES ?= "seccomp"
31 29
32DEPENDS = "yajl libcap go-md2man-native m4-native" 30DEPENDS = "yajl libcap go-md2man-native m4-native"
33# TODO: is there a packageconfig to turn this off ? 31# TODO: is there a packageconfig to turn this off ?