summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/raspberrypi
diff options
context:
space:
mode:
authorChristopher Clark <christopher.w.clark@gmail.com>2020-08-07 00:05:03 -0700
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-08-11 15:58:37 -0400
commitdc08df210c16bc7d2a06065a3c43ef9078f986c9 (patch)
tree3a982c08086e7aaa70309e1327d9d15d298a880e /dynamic-layers/raspberrypi
parent066225be3ac4f3067739de4df9f51aec0f5b03c5 (diff)
downloadmeta-virtualization-dc08df210c16bc7d2a06065a3c43ef9078f986c9.tar.gz
xen, raspi4, linux-yocto-dev: Enable Xen on Raspberry Pi 4
Enable linux-yocto-dev as the Linux kernel for Xen on the Raspberry Pi 4, with the bcm-2xxx-rpi4 KMACHINE and KBRANCH. Set a Raspberry Pi SD card variable to increase the size of the boot partition to accommodate both the kernel and the Xen hypervisor. Signed-off-by: Christopher Clark <christopher.w.clark@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'dynamic-layers/raspberrypi')
-rw-r--r--dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto-dev.bbappend10
1 files changed, 10 insertions, 0 deletions
diff --git a/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto-dev.bbappend b/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto-dev.bbappend
new file mode 100644
index 00000000..85d6febe
--- /dev/null
+++ b/dynamic-layers/raspberrypi/recipes-kernel/linux/linux-yocto-dev.bbappend
@@ -0,0 +1,10 @@
1# For a Xen-enabled distro on the Raspberry Pi, override the contents of cmdline.txt
2# with Xen-on-ARM-specific command line options
3
4DEFAULT_CMDLINE := "${CMDLINE}"
5XEN_LINUX_CMDLINE ?= "console=hvc0 clk_ignore_unused earlycon=xenboot debug root=/dev/mmcblk0p2 rootwait"
6CMDLINE = "${@bb.utils.contains('DISTRO_FEATURES', 'xen', '${XEN_LINUX_CMDLINE}', '${DEFAULT_CMDLINE}', d)}"
7
8KBRANCH_raspberrypi4-64 = "standard/bcm-2xxx-rpi"
9KMACHINE_raspberrypi4-64 = "bcm-2xxx-rpi4"
10COMPATIBLE_MACHINE_raspberrypi4-64 = "(raspberrypi4-64)"