summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2018-09-06 09:38:58 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-09-06 12:45:17 -0400
commitf857b21163744bf936bd5e5f27ff7185603e7905 (patch)
treee5e9a4e501370f66e67d68698730bed7b119a7ab
parent61a90af1629412bbdabfed45d4b998264ae7e4ad (diff)
downloadmeta-virtualization-f857b21163744bf936bd5e5f27ff7185603e7905.tar.gz
nagios-plugins: add recipe with latest stable version 2.2.1
Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-extended/nagios/nagios-plugins_2.2.1.bb73
1 files changed, 73 insertions, 0 deletions
diff --git a/recipes-extended/nagios/nagios-plugins_2.2.1.bb b/recipes-extended/nagios/nagios-plugins_2.2.1.bb
new file mode 100644
index 00000000..07933654
--- /dev/null
+++ b/recipes-extended/nagios/nagios-plugins_2.2.1.bb
@@ -0,0 +1,73 @@
1require nagios-common.inc
2
3DESCRIPTION = "A host/service/network monitoring and management system plugins"
4HOMEPAGE = "http://www.nagios-plugins.org"
5SECTION = "console/network"
6PRIORITY = "optional"
7LICENSE = "GPLv3"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
10
11SRC_URI = "https://www.nagios-plugins.org/download/${BPN}-${PV}.tar.gz \
12"
13
14SRC_URI[md5sum] = "fb521d5c05897f165b0b1862c1e5cb27"
15SRC_URI[sha256sum] = "647c0ba4583d891c965fc29b77c4ccfeccc21f409fdf259cb8af52cb39c21e18"
16
17S = "${WORKDIR}/${BPN}-${PV}"
18
19inherit autotools gettext
20
21EXTRA_OECONF += "--with-sysroot=${STAGING_DIR_HOST} \
22 --with-nagios-user=${NAGIOS_USER} \
23 --with-nagios-group=${NAGIOS_GROUP} \
24 --without-apt-get-command \
25 --with-trusted-path=/bin:/sbin:/usr/bin:/usr/sbin \
26 ac_cv_path_PERL=${bindir}/perl \
27"
28
29# IPv6
30PACKAGECONFIG[ipv6] = "--with-ipv6,--without-ipv6,,"
31
32# Enable check_ldaps, check_http --ssl, check_tcp --ssl
33PACKAGECONFIG[ssl] = "--with-openssl=${STAGING_DIR_HOST},--without-openssl,openssl,libssl"
34
35# Enable check_ldaps
36PACKAGECONFIG[ldap] = "--with-ldap,--without-ldap,openldap"
37
38# Enable check_smtp --starttls
39PACKAGECONFIG[gnutls] = "--with-gnutls=${STAGING_DIR_HOST},--without-gnutls,gnutls,gnutls"
40
41# Enable check_pgsql
42PACKAGECONFIG[pgsql] = "--with-pgsql=${STAGING_DIR_HOST},--without-pgsql,postgresql,libpq"
43
44# Enable check_mysql, check_mysql_query
45PACKAGECONFIG[mysql] = "--with-mysql=${STAGING_DIR_HOST},--without-mysql,mysql5,libmysqlclient"
46
47# Enable check_snmp
48PACKAGECONFIG[snmp] = "\
49 --with-snmpget-command=${bindir}/snmpget --with-snmpgetnext-command=${bindir}/snmpgetnext, \
50 --without-snmpget-command --without-snmpgetnext-command, \
51 , net-snmp-utils \
52"
53
54PACKAGECONFIG ??= "ssl gnutls"
55
56do_configure() {
57 oe_runconf || die "make failed"
58}
59
60do_install_append() {
61 sed -i '1s,#! /usr/bin/perl -w.*,#! ${bindir}/env perl,' ${D}${libdir}/nagios/plugins/*
62}
63
64RDEPENDS_${PN} += "\
65 iputils \
66 nagios-base \
67 perl \
68 bash \
69"
70
71FILES_${PN} += "${datadir} \
72 ${NAGIOS_PLUGIN_DIR} \
73"