summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo Salveti <ricardo@opensourcefoundries.com>2017-10-17 00:10:40 -0200
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-10-17 13:18:01 -0400
commit9c4cefcb712522bb2b85dc04f7c814fc4d7083f7 (patch)
treec0cff068fcf81e480a640756994639128b543ef6
parent9d288d62c260b138f94764bac994ee3e43a126b1 (diff)
downloadmeta-virtualization-9c4cefcb712522bb2b85dc04f7c814fc4d7083f7.tar.gz
python3-docker: add missing RDEPENDS
Add python3-docker-pycreds, python3-requests and python3-websocket-client to RDEPENDS for a functional python docker module (otherwise even import docker fails). Signed-off-by: Ricardo Salveti <ricardo@opensourcefoundries.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-devtools/python/python3-docker_2.5.1.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes-devtools/python/python3-docker_2.5.1.bb b/recipes-devtools/python/python3-docker_2.5.1.bb
index ff8f89ee..341d95ce 100644
--- a/recipes-devtools/python/python3-docker_2.5.1.bb
+++ b/recipes-devtools/python/python3-docker_2.5.1.bb
@@ -9,3 +9,9 @@ SRC_URI[md5sum] = "7d917152976df075e6e90ee853df641f"
9SRC_URI[sha256sum] = "b876e6909d8d2360e0540364c3a952a62847137f4674f2439320ede16d6db880" 9SRC_URI[sha256sum] = "b876e6909d8d2360e0540364c3a952a62847137f4674f2439320ede16d6db880"
10 10
11DEPENDS += "${PYTHON_PN}-pip-native" 11DEPENDS += "${PYTHON_PN}-pip-native"
12
13RDEPENDS_${PN} += " \
14 python3-docker-pycreds \
15 python3-requests \
16 python3-websocket-client \
17"