summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2018-11-01 11:30:03 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-11-02 21:21:27 -0400
commit3724664413254247a0c126fcfdb3aecfd5b2d821 (patch)
tree27da64adb34e9e7fbcdb3b1fe268658c134fc7b9
parent2a46d2df067fd25c5c90cc5727f82e63383fd18f (diff)
downloadmeta-virtualization-3724664413254247a0c126fcfdb3aecfd5b2d821.tar.gz
cni: update to latest plugins, and skip windows bridge build
Updating the cni plugins to match k8s and cri-o. We also filter out the windows plugins, since they use a different build infrastructure than the other variants .. and are not currently needed. This can be revisted in the future as needed. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-networking/cni/cni_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-networking/cni/cni_git.bb b/recipes-networking/cni/cni_git.bb
index b9708480..f7a7597b 100644
--- a/recipes-networking/cni/cni_git.bb
+++ b/recipes-networking/cni/cni_git.bb
@@ -9,8 +9,8 @@ Because of this focus, CNI has a wide range of support and the specification \
9is simple to implement. \ 9is simple to implement. \
10" 10"
11 11
12SRCREV_cni = "96343561e0363c7dcc5f94bef655a8ddbb0b3e5c" 12SRCREV_cni = "cc562d1b44b3d00b8c341250d49a8a0823a1c085"
13SRCREV_plugins = "b2fc336833674c5c42550fd2df94c1b5ca0755ba" 13SRCREV_plugins = "9abd20edd6c83385ff6c2a6e6ff265158059e723"
14SRC_URI = "\ 14SRC_URI = "\
15 git://github.com/containernetworking/cni.git;nobranch=1;name=cni \ 15 git://github.com/containernetworking/cni.git;nobranch=1;name=cni \
16 git://github.com/containernetworking/plugins.git;nobranch=1;destsuffix=plugins;name=plugins \ 16 git://github.com/containernetworking/plugins.git;nobranch=1;destsuffix=plugins;name=plugins \
@@ -71,7 +71,7 @@ do_compile() {
71 go build 71 go build
72 72
73 cd ${S}/src/import/vendor/github.com/containernetworking/plugins/ 73 cd ${S}/src/import/vendor/github.com/containernetworking/plugins/
74 PLUGINS="plugins/meta/* plugins/main/*" 74 PLUGINS="$(ls -d plugins/meta/*; ls -d plugins/main/* | grep -v windows)"
75 mkdir -p ${WORKDIR}/plugins/bin/ 75 mkdir -p ${WORKDIR}/plugins/bin/
76 for p in $PLUGINS; do 76 for p in $PLUGINS; do
77 plugin="$(basename "$p")" 77 plugin="$(basename "$p")"