summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-11-14 12:55:06 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-11-15 16:00:18 -0500
commit34dee81d0c5a0e2e1b1633ad4293171163c3bb62 (patch)
tree5fc66467b4c5b5c0e949e6b7f8cefc0e3ca2ab91
parent62823d7de00b42728cf5ca67cccc8e7c579eb8dc (diff)
downloadmeta-virtualization-34dee81d0c5a0e2e1b1633ad4293171163c3bb62.tar.gz
python-*: switch remaining pypi recipes to use the pypi class
Cleanup the various python-* recipes which download from pypi. The biggest change is to "inherit pypi" which should result in us always using current pypi best practices. This will for example ensure we are using https and not http which is apparently going to be disabled soon. Where the default behavior in the pypi class wasn't sufficient we make use of the PYPI_* variables to overwrite the defaults. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-devtools/python/python-gevent_1.0.1.bb7
-rw-r--r--recipes-devtools/python/python-m2crypto_0.22.3.bb11
-rw-r--r--recipes-devtools/python/python-sphinx_1.4.1.bb9
3 files changed, 8 insertions, 19 deletions
diff --git a/recipes-devtools/python/python-gevent_1.0.1.bb b/recipes-devtools/python/python-gevent_1.0.1.bb
index 47f1267a..7f1d2622 100644
--- a/recipes-devtools/python/python-gevent_1.0.1.bb
+++ b/recipes-devtools/python/python-gevent_1.0.1.bb
@@ -11,15 +11,10 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=2dbb33d00e1fd31c7041460a81ac0bd2"
11DEPENDS += "python-greenlet libevent" 11DEPENDS += "python-greenlet libevent"
12RDEPENDS_${PN} += "python-greenlet python-mime python-pprint python-re" 12RDEPENDS_${PN} += "python-greenlet python-mime python-pprint python-re"
13 13
14SRCNAME = "gevent"
15
16SRC_URI = "http://pypi.python.org/packages/source/g/gevent/${SRCNAME}-${PV}.tar.gz"
17SRC_URI[md5sum] = "7b952591d1a0174d6eb6ac47bd975ab6" 14SRC_URI[md5sum] = "7b952591d1a0174d6eb6ac47bd975ab6"
18SRC_URI[sha256sum] = "4627e215d058f71d95e6b26d9e7be4c263788a4756bd2858a93775f6c072df43" 15SRC_URI[sha256sum] = "4627e215d058f71d95e6b26d9e7be4c263788a4756bd2858a93775f6c072df43"
19 16
20S = "${WORKDIR}/${SRCNAME}-${PV}" 17inherit setuptools pypi
21
22inherit setuptools
23 18
24FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" 19FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
25SRC_URI += "file://libev-conf.patch" 20SRC_URI += "file://libev-conf.patch"
diff --git a/recipes-devtools/python/python-m2crypto_0.22.3.bb b/recipes-devtools/python/python-m2crypto_0.22.3.bb
index 95d6eecf..2c2625d3 100644
--- a/recipes-devtools/python/python-m2crypto_0.22.3.bb
+++ b/recipes-devtools/python/python-m2crypto_0.22.3.bb
@@ -13,23 +13,22 @@ DESCRIPTION = "\
13LICENSE = "BSD" 13LICENSE = "BSD"
14LIC_FILES_CHKSUM = "file://PKG-INFO;md5=0ccca7097c1d29fa42e75e9c15c6ff2e" 14LIC_FILES_CHKSUM = "file://PKG-INFO;md5=0ccca7097c1d29fa42e75e9c15c6ff2e"
15 15
16SRCNAME = "M2Crypto" 16PYPI_PACKAGE = "M2Crypto"
17SRC_URI = "http://pypi.python.org/packages/source/M/M2Crypto/${SRCNAME}-${PV}.tar.gz \ 17
18SRC_URI += " \
18 file://m2crypto-Fix-build-with-SWIG-3.0.5.patch \ 19 file://m2crypto-Fix-build-with-SWIG-3.0.5.patch \
19" 20"
20 21
21SRC_URI[md5sum] = "573f21aaac7d5c9549798e72ffcefedd" 22SRC_URI[md5sum] = "573f21aaac7d5c9549798e72ffcefedd"
22SRC_URI[sha256sum] = "6071bfc817d94723e9b458a010d565365104f84aa73f7fe11919871f7562ff72" 23SRC_URI[sha256sum] = "6071bfc817d94723e9b458a010d565365104f84aa73f7fe11919871f7562ff72"
23 24
24S = "${WORKDIR}/${SRCNAME}-${PV}" 25inherit setuptools pypi
25
26inherit setuptools
27 26
28DEPENDS += "openssl swig-native" 27DEPENDS += "openssl swig-native"
29 28
30DISTUTILS_BUILD_ARGS += "build_ext -I${STAGING_INCDIR}" 29DISTUTILS_BUILD_ARGS += "build_ext -I${STAGING_INCDIR}"
31 30
32inherit setuptools 31inherit setuptools pypi
33 32
34SWIG_FEATURES_x86-64 = "-D__x86_64__" 33SWIG_FEATURES_x86-64 = "-D__x86_64__"
35SWIG_FEATURES ?= "" 34SWIG_FEATURES ?= ""
diff --git a/recipes-devtools/python/python-sphinx_1.4.1.bb b/recipes-devtools/python/python-sphinx_1.4.1.bb
index 835b369d..476ff977 100644
--- a/recipes-devtools/python/python-sphinx_1.4.1.bb
+++ b/recipes-devtools/python/python-sphinx_1.4.1.bb
@@ -4,14 +4,9 @@ SECTION = "devel/python"
4LICENSE = "BSD" 4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=72f034adc6f7b05b09bc00d1a05bb065" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=72f034adc6f7b05b09bc00d1a05bb065"
6 6
7PR = "r0" 7PYPI_PACKAGE = "Sphinx"
8SRCNAME = "Sphinx"
9
10SRC_URI = "http://pypi.python.org/packages/source/S/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11 8
12SRC_URI[md5sum] = "4c4988e0306a04cef8dccc384281e585" 9SRC_URI[md5sum] = "4c4988e0306a04cef8dccc384281e585"
13SRC_URI[sha256sum] = "c6871a784d24aba9270b6b28541537a57e2fcf4d7c799410eba18236bc76d6bc" 10SRC_URI[sha256sum] = "c6871a784d24aba9270b6b28541537a57e2fcf4d7c799410eba18236bc76d6bc"
14 11
15S = "${WORKDIR}/${SRCNAME}-${PV}" 12inherit setuptools pypi
16
17inherit setuptools