summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2018-10-10 14:59:13 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-10-11 14:38:18 -0400
commit2a9bdedc3b952fb06934c980a13451c421f6723a (patch)
treec1d97c570b9c50475bacfd582d18df9e8deb31e6
parentf2446873e7b0201b1df9c710dddbfc5475e998fb (diff)
downloadmeta-virtualization-2a9bdedc3b952fb06934c980a13451c421f6723a.tar.gz
oci-image-tools: fix do package qa warning
1. After security flag PIE is enabled by default, we might met below QA warning on some arch, like aarch64, fix it by skip textrel QA check refer commit b689c72a of oe-core oci-image-tools-0.2.0-dev+gitAUTOINC+4abe1a166f-r0 do_package_qa: QA Issue: ELF binary 'work/aarch64-poky-linux/oci-image-tools/ 0.2.0-dev+gitAUTOINC+4abe1a166f-r0/packages-split/oci-image-tools/ usr/sbin/oci-image-tool' has relocations in .text [textrel] 2. This problem is caused since security_flags.inc is used by default. so alternative work around is: SECURITY_CFLAGS_pn-oci-image-tools = "${SECURITY_NOPIE_CFLAGS}" SECURITY_LDFLAGS_pn-oci-image-tools = "" Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-containers/oci-image-tools/oci-image-tools_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-containers/oci-image-tools/oci-image-tools_git.bb b/recipes-containers/oci-image-tools/oci-image-tools_git.bb
index 807ee26c..8c41b6e0 100644
--- a/recipes-containers/oci-image-tools/oci-image-tools_git.bb
+++ b/recipes-containers/oci-image-tools/oci-image-tools_git.bb
@@ -61,4 +61,4 @@ do_install() {
61 install ${S}/src/import/oci-image-tool ${D}/${sbindir}/ 61 install ${S}/src/import/oci-image-tool ${D}/${sbindir}/
62} 62}
63 63
64INSANE_SKIP_${PN} += "ldflags" 64INSANE_SKIP_${PN} += "ldflags textrel"