summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2019-04-11 22:20:04 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-04-12 10:51:17 -0400
commitdfceafea9fa1291de4a9f3fb748e7be5b423d370 (patch)
tree8f5b895141fbc0afa19a7c93b9e1a539d8a1e7d4
parent69288b17c099e7949527f29aeb4d7fce749e1ab8 (diff)
downloadmeta-virtualization-dfceafea9fa1291de4a9f3fb748e7be5b423d370.tar.gz
cri-o: fixup build
After oe-core commits 5f48939e2640 [goarch.bbclass: use MACHINEOVERRIDES and simplify go_map_arm()] 6300c4a83f7c [go.bbclass:Export more GO* environment variables] we see a build failure with cri-o: | go build runtime/cgo: attempting to install package runtime/cgo into read-only GOROOT | Makefile:112: recipe for target 'conmon/config.h' failed | make: *** [conmon/config.h] Error 1 to avoid this we should not overwrite the GO* environment being setup by the go.bbclass, so we drop most of our GO* exports here. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-containers/cri-o/cri-o_git.bb19
1 files changed, 0 insertions, 19 deletions
diff --git a/recipes-containers/cri-o/cri-o_git.bb b/recipes-containers/cri-o/cri-o_git.bb
index 2af3c125..cac55368 100644
--- a/recipes-containers/cri-o/cri-o_git.bb
+++ b/recipes-containers/cri-o/cri-o_git.bb
@@ -53,18 +53,8 @@ inherit pkgconfig
53EXTRA_OEMAKE="BUILDTAGS=''" 53EXTRA_OEMAKE="BUILDTAGS=''"
54 54
55do_compile() { 55do_compile() {
56 export GOARCH="${TARGET_GOARCH}"
57 export GOROOT="${STAGING_LIBDIR_NATIVE}/${TARGET_SYS}/go"
58 export GOPATH="${S}/src/import:${S}/src/import/vendor" 56 export GOPATH="${S}/src/import:${S}/src/import/vendor"
59 57
60 # Pass the needed cflags/ldflags so that cgo
61 # can find the needed headers files and libraries
62 export CGO_ENABLED="1"
63 export CFLAGS=""
64 export LDFLAGS=""
65 export CGO_CFLAGS="${BUILDSDK_CFLAGS} --sysroot=${STAGING_DIR_TARGET}"
66 export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}"
67
68 # link fixups for compilation 58 # link fixups for compilation
69 rm -f ${S}/src/import/vendor/src 59 rm -f ${S}/src/import/vendor/src
70 ln -sf ./ ${S}/src/import/vendor/src 60 ln -sf ./ ${S}/src/import/vendor/src
@@ -82,15 +72,6 @@ do_compile() {
82 ln -sf ../../../../version ${S}/src/import/vendor/github.com/kubernetes-sigs/cri-o/version 72 ln -sf ../../../../version ${S}/src/import/vendor/github.com/kubernetes-sigs/cri-o/version
83 ln -sf ../../../../lib ${S}/src/import/vendor/github.com/kubernetes-sigs/cri-o/lib 73 ln -sf ../../../../lib ${S}/src/import/vendor/github.com/kubernetes-sigs/cri-o/lib
84 74
85 export GOPATH="${S}/src/import/.gopath:${S}/src/import/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go"
86 export GOROOT="${STAGING_DIR_NATIVE}/${nonarch_libdir}/${HOST_SYS}/go"
87
88 # Pass the needed cflags/ldflags so that cgo
89 # can find the needed headers files and libraries
90 export CGO_ENABLED="1"
91 export CGO_CFLAGS="${CFLAGS} --sysroot=${STAGING_DIR_TARGET}"
92 export CGO_LDFLAGS="${LDFLAGS} --sysroot=${STAGING_DIR_TARGET}"
93
94 cd ${S}/src/import 75 cd ${S}/src/import
95 76
96 oe_runmake binaries 77 oe_runmake binaries