summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Barker <pbarker@toganlabs.com>2018-05-08 20:14:11 +0000
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-05-09 10:49:17 -0400
commitbc88053cab85bde494cbcf5678bf0abece466758 (patch)
tree6245fc1bb94b3cb3b97ef882b15e9d0d36fcee3f
parentfda48193e60b22471dd962682faab33e4e721d72 (diff)
downloadmeta-virtualization-bc88053cab85bde494cbcf5678bf0abece466758.tar.gz
runc-opencontainers: Drop obsolete patch
The upstream Makefile now calls `$(GO)` instead of just `go` so this patch isn't needed anymore. Signed-off-by: Paul Barker <pbarker@toganlabs.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-containers/runc/runc-opencontainers/0001-Use-correct-go-cross-compiler.patch85
-rw-r--r--recipes-containers/runc/runc-opencontainers_git.bb1
2 files changed, 0 insertions, 86 deletions
diff --git a/recipes-containers/runc/runc-opencontainers/0001-Use-correct-go-cross-compiler.patch b/recipes-containers/runc/runc-opencontainers/0001-Use-correct-go-cross-compiler.patch
deleted file mode 100644
index 67d70148..00000000
--- a/recipes-containers/runc/runc-opencontainers/0001-Use-correct-go-cross-compiler.patch
+++ /dev/null
@@ -1,85 +0,0 @@
1From 621e5e9a196daaaf5eb430a413fe51218cf42c89 Mon Sep 17 00:00:00 2001
2From: Paul Barker <pbarker@toganlabs.com>
3Date: Wed, 4 Oct 2017 15:45:27 +0000
4Subject: [PATCH] Use correct go cross-compiler
5
6We need to use '${GO}' as set by OpenEmbedded instead of just 'go'. Just using
7'go' will invoke go-native.
8
9Signed-off-by: Paul Barker <pbarker@toganlabs.com>
10Upstream-status: Inappropriate
11---
12 Makefile | 20 ++++++++++----------
13 1 file changed, 10 insertions(+), 10 deletions(-)
14
15diff --git a/Makefile b/Makefile
16index 6781ac7..74e551d 100644
17--- a/src/import/Makefile
18+++ b/src/import/Makefile
19@@ -27,18 +27,18 @@ SHELL := $(shell command -v bash 2>/dev/null)
20 .DEFAULT: runc
21
22 runc: $(SOURCES)
23- go build -i $(EXTRA_FLAGS) -ldflags "-X main.gitCommit=${COMMIT} -X main.version=${VERSION} $(EXTRA_LDFLAGS)" -tags "$(BUILDTAGS)" -o runc .
24+ $(GO) build -i $(EXTRA_FLAGS) -ldflags "-X main.gitCommit=${COMMIT} -X main.version=${VERSION} $(EXTRA_LDFLAGS)" -tags "$(BUILDTAGS)" -o runc .
25
26 all: runc recvtty
27
28 recvtty: contrib/cmd/recvtty/recvtty
29
30 contrib/cmd/recvtty/recvtty: $(SOURCES)
31- go build -i $(EXTRA_FLAGS) -ldflags "-X main.gitCommit=${COMMIT} -X main.version=${VERSION} $(EXTRA_LDFLAGS)" -tags "$(BUILDTAGS)" -o contrib/cmd/recvtty/recvtty ./contrib/cmd/recvtty
32+ $(GO) build -i $(EXTRA_FLAGS) -ldflags "-X main.gitCommit=${COMMIT} -X main.version=${VERSION} $(EXTRA_LDFLAGS)" -tags "$(BUILDTAGS)" -o contrib/cmd/recvtty/recvtty ./contrib/cmd/recvtty
33
34 static: $(SOURCES)
35- CGO_ENABLED=1 go build -i $(EXTRA_FLAGS) -tags "$(BUILDTAGS) cgo static_build" -ldflags "-w -extldflags -static -X main.gitCommit=${COMMIT} -X main.version=${VERSION} $(EXTRA_LDFLAGS)" -o runc .
36- CGO_ENABLED=1 go build -i $(EXTRA_FLAGS) -tags "$(BUILDTAGS) cgo static_build" -ldflags "-w -extldflags -static -X main.gitCommit=${COMMIT} -X main.version=${VERSION} $(EXTRA_LDFLAGS)" -o contrib/cmd/recvtty/recvtty ./contrib/cmd/recvtty
37+ CGO_ENABLED=1 $(GO) build -i $(EXTRA_FLAGS) -tags "$(BUILDTAGS) cgo static_build" -ldflags "-w -extldflags -static -X main.gitCommit=${COMMIT} -X main.version=${VERSION} $(EXTRA_LDFLAGS)" -o runc .
38+ CGO_ENABLED=1 $(GO) build -i $(EXTRA_FLAGS) -tags "$(BUILDTAGS) cgo static_build" -ldflags "-w -extldflags -static -X main.gitCommit=${COMMIT} -X main.version=${VERSION} $(EXTRA_LDFLAGS)" -o contrib/cmd/recvtty/recvtty ./contrib/cmd/recvtty
39
40 release:
41 @flag_list=(seccomp selinux apparmor static); \
42@@ -62,15 +62,15 @@ release:
43 CGO_ENABLED=1; \
44 }; \
45 echo "Building target: $$output"; \
46- go build -i $(EXTRA_FLAGS) -ldflags "$$ldflags $(EXTRA_LDFLAGS)" -tags "$$tags" -o "$$output" .; \
47+ $(GO) build -i $(EXTRA_FLAGS) -ldflags "$$ldflags $(EXTRA_LDFLAGS)" -tags "$$tags" -o "$$output" .; \
48 done
49
50 dbuild: runcimage
51 docker run --rm -v $(CURDIR):/go/src/$(PROJECT) --privileged $(RUNC_IMAGE) make clean all
52
53 lint:
54- go vet $(allpackages)
55- go fmt $(allpackages)
56+ $(GO) vet $(allpackages)
57+ $(GO) fmt $(allpackages)
58
59 man:
60 man/md2man-all.sh
61@@ -88,7 +88,7 @@ unittest: runcimage
62 docker run -e TESTFLAGS -t --privileged --rm -v $(CURDIR):/go/src/$(PROJECT) $(RUNC_IMAGE) make localunittest
63
64 localunittest: all
65- go test -timeout 3m -tags "$(BUILDTAGS)" ${TESTFLAGS} -v $(allpackages)
66+ $(GO) test -timeout 3m -tags "$(BUILDTAGS)" ${TESTFLAGS} -v $(allpackages)
67
68 integration: runcimage
69 docker run -e TESTFLAGS -t --privileged --rm -v $(CURDIR):/go/src/$(PROJECT) $(RUNC_IMAGE) make localintegration
70@@ -133,10 +133,10 @@ clean:
71
72 validate:
73 script/validate-gofmt
74- go vet $(allpackages)
75+ $(GO) vet $(allpackages)
76
77 ci: validate localtest
78
79 # memoize allpackages, so that it's executed only once and only if used
80-_allpackages = $(shell go list ./... | grep -v vendor)
81+_allpackages = $(shell $(GO) list ./... | grep -v vendor)
82 allpackages = $(if $(__allpackages),,$(eval __allpackages := $$(_allpackages)))$(__allpackages)
83--
842.7.4
85
diff --git a/recipes-containers/runc/runc-opencontainers_git.bb b/recipes-containers/runc/runc-opencontainers_git.bb
index 73ef4f00..ed48abf6 100644
--- a/recipes-containers/runc/runc-opencontainers_git.bb
+++ b/recipes-containers/runc/runc-opencontainers_git.bb
@@ -3,6 +3,5 @@ include runc.inc
3SRCREV = "58415b4b12650291f435db8770cea48207b78afe" 3SRCREV = "58415b4b12650291f435db8770cea48207b78afe"
4SRC_URI = " \ 4SRC_URI = " \
5 git://github.com/opencontainers/runc;branch=master \ 5 git://github.com/opencontainers/runc;branch=master \
6 file://0001-Use-correct-go-cross-compiler.patch \
7 " 6 "
8RUNC_VERSION = "1.0.0-rc5" 7RUNC_VERSION = "1.0.0-rc5"