summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2015-03-23 13:29:39 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-03-24 14:22:00 -0400
commit40dcc06946b0ef46286ae8982565cfa72c972d07 (patch)
tree2b314fc4fc7b611cc3ffad0353a575e42fc7bda2
parent718987175a2e407e5d2c695f2dc28e9519de232e (diff)
downloadmeta-virtualization-40dcc06946b0ef46286ae8982565cfa72c972d07.tar.gz
libvirt: do_compile fails 'src/cpu/cpu_map.xml': No such file or directory'
In some circumstances where the build tree differs from the source, libvirt's compile will try to create the symlink for cpu_map.xml before creating the directory $(abs_builddir)/cpu. Add a test to create this directory if it hasn't already been created. Signed-off-by: Amy Fong <amy.fong@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-extended/libvirt/libvirt/libvirt-Fix-cannot-symlink-cpu_map.xml-error.patch34
-rw-r--r--recipes-extended/libvirt/libvirt_1.2.12.bb1
2 files changed, 35 insertions, 0 deletions
diff --git a/recipes-extended/libvirt/libvirt/libvirt-Fix-cannot-symlink-cpu_map.xml-error.patch b/recipes-extended/libvirt/libvirt/libvirt-Fix-cannot-symlink-cpu_map.xml-error.patch
new file mode 100644
index 00000000..090bc6ea
--- /dev/null
+++ b/recipes-extended/libvirt/libvirt/libvirt-Fix-cannot-symlink-cpu_map.xml-error.patch
@@ -0,0 +1,34 @@
1libvirt: do_compile fails 'src/cpu/cpu_map.xml': No such file or directory'
2
3In some very rare circumstances, libvirt's compile will try to create the
4symlink for cpu_map.xml before creating the directory $(abs_builddir)/cpu.
5
6Add a test to create this directory if it hasn't already been created.
7
8Signed-off-by: Amy Fong <amy.fong@windriver.com>
9
10---
11 src/Makefile.am | 1 +
12 src/Makefile.in | 1 +
13 2 files changed, 2 insertions(+)
14
15--- a/src/Makefile.am
16+++ b/src/Makefile.am
17@@ -1053,6 +1053,7 @@
18 libvirt_cpu_la_DEPENDENCIES = $(abs_builddir)/cpu/cpu_map.xml
19
20 $(abs_builddir)/cpu/cpu_map.xml:
21+ if [ ! -d $(abs_builddir)/cpu ]; then $(MKDIR_P) $(abs_builddir)/cpu/; fi
22 $(AM_V_GEN)ln -s $(abs_srcdir)/cpu/cpu_map.xml $@
23
24 if WITH_VMX
25--- a/src/Makefile.in
26+++ b/src/Makefile.in
27@@ -10338,6 +10338,7 @@
28 $(srcdir)/lxc/lxc_controller_dispatch.h
29
30 $(abs_builddir)/cpu/cpu_map.xml:
31+ if [ ! -d $(abs_builddir)/cpu ]; then $(MKDIR_P) $(abs_builddir)/cpu/; fi
32 $(AM_V_GEN)ln -s $(abs_srcdir)/cpu/cpu_map.xml $@
33
34 %protocol.c: %protocol.x %protocol.h $(srcdir)/rpc/genprotocol.pl
diff --git a/recipes-extended/libvirt/libvirt_1.2.12.bb b/recipes-extended/libvirt/libvirt_1.2.12.bb
index ef46e229..dca2d1b2 100644
--- a/recipes-extended/libvirt/libvirt_1.2.12.bb
+++ b/recipes-extended/libvirt/libvirt_1.2.12.bb
@@ -30,6 +30,7 @@ SRC_URI = "http://libvirt.org/sources/libvirt-${PV}.tar.gz;name=libvirt \
30 file://runptest.patch \ 30 file://runptest.patch \
31 file://run-ptest \ 31 file://run-ptest \
32 file://tests-allow-separated-src-and-build-dirs.patch \ 32 file://tests-allow-separated-src-and-build-dirs.patch \
33 file://libvirt-Fix-cannot-symlink-cpu_map.xml-error.patch \
33 " 34 "
34 35
35SRC_URI[libvirt.md5sum] = "2ae99535265ce4687d8718d744024c27" 36SRC_URI[libvirt.md5sum] = "2ae99535265ce4687d8718d744024c27"