summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-11-06 15:26:44 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-11-07 15:14:46 -0500
commit25fa17b0bb6c201ed85af7bb0451500af9df5b63 (patch)
tree4f9ff65a05328208f6e9b010056145fd711fdd9e
parent8cc50eae10a10f5aeaa681132889b2a6db8809bd (diff)
downloadmeta-virtualization-25fa17b0bb6c201ed85af7bb0451500af9df5b63.tar.gz
python-webob: uprev to v1.7.3
The only user in meta-virtualization is python-bugsnag and there is no version dependency. This new version is however required by the latest openstack. Switched to using the "common" pypi.bbclass while we are at it. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-devtools/python/python-webob_1.6.0.bb23
-rw-r--r--recipes-devtools/python/python-webob_1.7.3.bb18
2 files changed, 18 insertions, 23 deletions
diff --git a/recipes-devtools/python/python-webob_1.6.0.bb b/recipes-devtools/python/python-webob_1.6.0.bb
deleted file mode 100644
index 71c74ffd..00000000
--- a/recipes-devtools/python/python-webob_1.6.0.bb
+++ /dev/null
@@ -1,23 +0,0 @@
1DESCRIPTION = "WSGI request and response object"
2HOMEPAGE = "http://webob.org/"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://docs/license.txt;md5=8ed3584bcc78c16da363747ccabc5af5"
6
7PR = "r0"
8SRCNAME = "WebOb"
9
10SRC_URI = "http://pypi.python.org/packages/source/W/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "089d7fc6745f175737800237c7287802"
13SRC_URI[sha256sum] = "63d262d8f61b516321f786879c9277fa2209f7f57eb47b537eeecfea383d55b7"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19RDEPENDS_${PN} += " \
20 python-sphinx \
21 python-nose \
22 "
23
diff --git a/recipes-devtools/python/python-webob_1.7.3.bb b/recipes-devtools/python/python-webob_1.7.3.bb
new file mode 100644
index 00000000..a2448bef
--- /dev/null
+++ b/recipes-devtools/python/python-webob_1.7.3.bb
@@ -0,0 +1,18 @@
1DESCRIPTION = "WSGI request and response object"
2HOMEPAGE = "http://webob.org/"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://docs/license.txt;md5=8ed3584bcc78c16da363747ccabc5af5"
6
7PYPI_PACKAGE = "WebOb"
8
9SRC_URI[md5sum] = "350028baffc508e3d23c078118e35316"
10SRC_URI[sha256sum] = "e65ca14b9f5ae5b031988ffc93f8b7f305ddfcf17a4c774ae0db47bcb3b87283"
11
12inherit setuptools pypi
13
14RDEPENDS_${PN} += " \
15 python-sphinx \
16 python-nose \
17 "
18