diff options
author | Zqiang <qiang.zhang@windriver.com> | 2021-03-11 16:50:50 +0800 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2021-03-11 22:33:29 -0500 |
commit | 415fd5eb2c5556a3ff21993c7857e11bcec3f237 (patch) | |
tree | 2625c68823a43da2f7abd18e4d0d2c81167ec81b | |
parent | 69c9ed9a1d505c50cdaa9f91303f8053d0a6e391 (diff) | |
download | meta-virtualization-415fd5eb2c5556a3ff21993c7857e11bcec3f237.tar.gz |
openvswitch: uprev from 2.13 to 2.15
- OVSDB:
* Changed format in which ovsdb transactions are stored in database files.
Now each transaction contains diff of data instead of the whole new
value of a column.
New ovsdb-server process will be able to read old database format, but
old processes will *fail* to read database created by the new one.
For cluster and active-backup service models follow upgrade instructions
in 'Upgrading from version 2.14 and earlier to 2.15 and later' section
of ovsdb(7).
* New unixctl command 'ovsdb-server/get-db-storage-status' to show the
status of the storage that's backing a database.
* New unixctl command 'ovsdb-server/memory-trim-on-compaction on|off'.
If turned on, ovsdb-server will try to reclaim all the unused memory
after every DB compaction back to OS. Disabled by default.
* Maximum backlog on RAFT connections limited to 500 messages or 4GB.
Once threshold reached, connection is dropped (and re-established).
Use the 'cluster/set-backlog-threshold' command to change limits.
- DPDK:
* Removed support for vhost-user dequeue zero-copy.
* Add support for DPDK 20.11.
- Userspace datapath:
* Add the 'pmd' option to "ovs-appctl dpctl/dump-flows", which
restricts a flow dump to a single PMD thread if set.
* New 'options:dpdk-vf-mac' field for DPDK interface of VF ports,
that allows configuring the MAC address of a VF representor.
* Add generic IP protocol support to conntrack. With this change, all
none UDP, TCP, and ICMP traffic will be treated as general L3
traffic, i.e. using 3 tupples.
* Add parameters 'pmd-auto-lb-load-threshold' and
'pmd-auto-lb-improvement-threshold' to configure PMD auto load balance
behaviour.
- The environment variable OVS_UNBOUND_CONF, if set, is now used
as the DNS resolver's (unbound) configuration file.
- Linux datapath:
* Support for kernel versions up to 5.8.x.
- Terminology:
* The terms "master" and "slave" have been replaced by "primary" and
"secondary", respectively, for OpenFlow connection roles.
* The term "slave" has been replaced by "member", for bonds, LACP, and
OpenFlow bundle actions.
- Support for GitHub Actions based continuous integration builds has been
added.
- Bareudp Tunnel
* Bareudp device support is present in linux kernel from version 5.7
* Kernel bareudp device is not backported to ovs tree.
* Userspace datapath support is not added
- ovs-dpctl and 'ovs-appctl dpctl/':
* New commands '{add,mod,del}-flows' where added, which allow adding,
deleting, or modifying flows based on information read from a file.
- IPsec:
* Add option '--no-cleanup' to allow ovs-monitor-ipsec to stop without
tearing down IPsec tunnels.
* Add option '--no-restart-ike-daemon' to allow ovs-monitor-ipsec to start
without restarting ipsec daemon.
- Building the Linux kernel module from the OVS source tree is deprecated
* Support for the Linux kernel is capped at version 5.8
* Only bug fixes for the Linux OOT kernel module will be accepted.
* The Linux kernel module will be fully removed from the OVS source tree
in OVS branch 2.18
fix some do_patch error about local patch.
Signed-off-by: Zqiang <qiang.zhang@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
4 files changed, 42 insertions, 35 deletions
diff --git a/recipes-networking/openvswitch/files/0001-ovs-use-run-instead-of-var-run-for-in-systemd-units.patch b/recipes-networking/openvswitch/files/0001-ovs-use-run-instead-of-var-run-for-in-systemd-units.patch index 244a216d..f7ec3fa0 100644 --- a/recipes-networking/openvswitch/files/0001-ovs-use-run-instead-of-var-run-for-in-systemd-units.patch +++ b/recipes-networking/openvswitch/files/0001-ovs-use-run-instead-of-var-run-for-in-systemd-units.patch | |||
@@ -1,6 +1,6 @@ | |||
1 | From ea98129777784b0e750a20078f01093dbdbe7b9b Mon Sep 17 00:00:00 2001 | 1 | From ae55fa8168b4b9692ad757c54255a89f935c587e Mon Sep 17 00:00:00 2001 |
2 | From: Chen Qi <Qi.Chen@windriver.com> | 2 | From: Chen Qi <Qi.Chen@windriver.com> |
3 | Date: Tue, 20 Oct 2020 14:14:06 +0800 | 3 | Date: Thu, 11 Mar 2021 11:35:24 +0800 |
4 | Subject: [PATCH] ovs: use /run instead of /var/run for in systemd units | 4 | Subject: [PATCH] ovs: use /run instead of /var/run for in systemd units |
5 | 5 | ||
6 | Upstream-Status: Pending | 6 | Upstream-Status: Pending |
@@ -78,10 +78,10 @@ index f88b57cae..82748bf2d 100644 | |||
78 | EnvironmentFile=-/etc/sysconfig/openvswitch | 78 | EnvironmentFile=-/etc/sysconfig/openvswitch |
79 | EnvironmentFile=-/run/openvswitch.useropts | 79 | EnvironmentFile=-/run/openvswitch.useropts |
80 | diff --git a/rhel/usr_lib_systemd_system_ovsdb-server.service b/rhel/usr_lib_systemd_system_ovsdb-server.service | 80 | diff --git a/rhel/usr_lib_systemd_system_ovsdb-server.service b/rhel/usr_lib_systemd_system_ovsdb-server.service |
81 | index 69b0bf61a..5f83f281f 100644 | 81 | index 74e5acb7f..39698f238 100644 |
82 | --- a/rhel/usr_lib_systemd_system_ovsdb-server.service | 82 | --- a/rhel/usr_lib_systemd_system_ovsdb-server.service |
83 | +++ b/rhel/usr_lib_systemd_system_ovsdb-server.service | 83 | +++ b/rhel/usr_lib_systemd_system_ovsdb-server.service |
84 | @@ -7,12 +7,12 @@ PartOf=openvswitch.service | 84 | @@ -7,7 +7,7 @@ PartOf=openvswitch.service |
85 | 85 | ||
86 | [Service] | 86 | [Service] |
87 | Type=forking | 87 | Type=forking |
@@ -90,13 +90,17 @@ index 69b0bf61a..5f83f281f 100644 | |||
90 | Restart=on-failure | 90 | Restart=on-failure |
91 | EnvironmentFile=/etc/openvswitch/default.conf | 91 | EnvironmentFile=/etc/openvswitch/default.conf |
92 | EnvironmentFile=-/etc/sysconfig/openvswitch | 92 | EnvironmentFile=-/etc/sysconfig/openvswitch |
93 | @@ -17,8 +17,8 @@ EnvironmentFile=-/run/openvswitch.useropts | ||
94 | # remove openvswitch.useropts first to reload a fresh | ||
95 | # OVS_USER_ID from default.conf or sysconfig. | ||
96 | ExecStartPre=/bin/rm -f /run/openvswitch.useropts | ||
93 | -ExecStartPre=-/bin/mkdir /var/run/openvswitch /var/log/openvswitch | 97 | -ExecStartPre=-/bin/mkdir /var/run/openvswitch /var/log/openvswitch |
94 | -ExecStartPre=-/bin/chown ${OVS_USER_ID} /var/run/openvswitch /var/log/openvswitch | 98 | -ExecStartPre=-/bin/chown ${OVS_USER_ID} /var/run/openvswitch /var/log/openvswitch |
95 | +ExecStartPre=-/bin/mkdir /run/openvswitch /var/log/openvswitch | 99 | +ExecStartPre=-/bin/mkdir /run/openvswitch /var/log/openvswitch |
96 | +ExecStartPre=-/bin/chown ${OVS_USER_ID} /run/openvswitch /var/log/openvswitch | 100 | +ExecStartPre=-/bin/chown ${OVS_USER_ID} /run/openvswitch /var/log/openvswitch |
97 | ExecStartPre=/bin/sh -c 'rm -f /run/openvswitch.useropts; /bin/echo "OVS_USER_ID=${OVS_USER_ID}" > /run/openvswitch.useropts' | 101 | ExecStartPre=/bin/sh -c '/bin/echo "OVS_USER_ID=${OVS_USER_ID}" > /run/openvswitch.useropts' |
98 | ExecStartPre=/bin/sh -c 'if [ "$${OVS_USER_ID/:*/}" != "root" ]; then /bin/echo "OVS_USER_OPT=--ovs-user=${OVS_USER_ID}" >> /run/openvswitch.useropts; fi' | 102 | ExecStartPre=/bin/sh -c 'if [ "$${OVS_USER_ID/:*/}" != "root" ]; then /bin/echo "OVS_USER_OPT=--ovs-user=${OVS_USER_ID}" >> /run/openvswitch.useropts; fi' |
99 | EnvironmentFile=-/run/openvswitch.useropts | 103 | ExecStart=/usr/share/openvswitch/scripts/ovs-ctl \ |
100 | -- | 104 | -- |
101 | 2.17.1 | 105 | 2.17.1 |
102 | 106 | ||
diff --git a/recipes-networking/openvswitch/openvswitch-git/systemd-create-runtime-dirs.patch b/recipes-networking/openvswitch/openvswitch-git/systemd-create-runtime-dirs.patch index 0438cf88..12b9e17a 100644 --- a/recipes-networking/openvswitch/openvswitch-git/systemd-create-runtime-dirs.patch +++ b/recipes-networking/openvswitch/openvswitch-git/systemd-create-runtime-dirs.patch | |||
@@ -1,6 +1,6 @@ | |||
1 | From 6876e0c155b7f83e1f8545446e2dd69c2b7989f2 Mon Sep 17 00:00:00 2001 | 1 | From fc540d0dee7d1f801c781905735f0f4619aba511 Mon Sep 17 00:00:00 2001 |
2 | From: Mark Asselstine <mark.asselstine@windriver.com> | 2 | From: Mark Asselstine <mark.asselstine@windriver.com> |
3 | Date: Tue, 4 Sep 2018 15:38:59 -0400 | 3 | Date: Thu, 11 Mar 2021 11:26:58 +0800 |
4 | Subject: [PATCH] systemd: create runtime dirs | 4 | Subject: [PATCH] systemd: create runtime dirs |
5 | 5 | ||
6 | The recommendation would be to make use of "RuntimeDirectory=" and | 6 | The recommendation would be to make use of "RuntimeDirectory=" and |
@@ -11,21 +11,22 @@ directories won't exist. | |||
11 | 11 | ||
12 | Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> | 12 | Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> |
13 | --- | 13 | --- |
14 | rhel/usr_lib_systemd_system_ovsdb-server.service | 1 + | 14 | rhel/usr_lib_systemd_system_ovsdb-server.service | 2 +- |
15 | 1 file changed, 1 insertion(+) | 15 | 1 file changed, 1 insertion(+), 1 deletion(-) |
16 | 16 | ||
17 | diff --git a/rhel/usr_lib_systemd_system_ovsdb-server.service b/rhel/usr_lib_systemd_system_ovsdb-server.service | 17 | diff --git a/rhel/usr_lib_systemd_system_ovsdb-server.service b/rhel/usr_lib_systemd_system_ovsdb-server.service |
18 | index aad557f..69b0bf6 100644 | 18 | index 5002ddf10..74e5acb7f 100644 |
19 | --- a/rhel/usr_lib_systemd_system_ovsdb-server.service | 19 | --- a/rhel/usr_lib_systemd_system_ovsdb-server.service |
20 | +++ b/rhel/usr_lib_systemd_system_ovsdb-server.service | 20 | +++ b/rhel/usr_lib_systemd_system_ovsdb-server.service |
21 | @@ -11,6 +11,7 @@ PIDFile=/var/run/openvswitch/ovsdb-server.pid | 21 | @@ -17,7 +17,7 @@ EnvironmentFile=-/run/openvswitch.useropts |
22 | Restart=on-failure | 22 | # remove openvswitch.useropts first to reload a fresh |
23 | EnvironmentFile=/etc/openvswitch/default.conf | 23 | # OVS_USER_ID from default.conf or sysconfig. |
24 | EnvironmentFile=-/etc/sysconfig/openvswitch | 24 | ExecStartPre=/bin/rm -f /run/openvswitch.useropts |
25 | - | ||
25 | +ExecStartPre=-/bin/mkdir /var/run/openvswitch /var/log/openvswitch | 26 | +ExecStartPre=-/bin/mkdir /var/run/openvswitch /var/log/openvswitch |
26 | ExecStartPre=-/bin/chown ${OVS_USER_ID} /var/run/openvswitch /var/log/openvswitch | 27 | ExecStartPre=-/bin/chown ${OVS_USER_ID} /var/run/openvswitch /var/log/openvswitch |
27 | ExecStartPre=/bin/sh -c 'rm -f /run/openvswitch.useropts; /bin/echo "OVS_USER_ID=${OVS_USER_ID}" > /run/openvswitch.useropts' | 28 | ExecStartPre=/bin/sh -c '/bin/echo "OVS_USER_ID=${OVS_USER_ID}" > /run/openvswitch.useropts' |
28 | ExecStartPre=/bin/sh -c 'if [ "$${OVS_USER_ID/:*/}" != "root" ]; then /bin/echo "OVS_USER_OPT=--ovs-user=${OVS_USER_ID}" >> /run/openvswitch.useropts; fi' | 29 | ExecStartPre=/bin/sh -c 'if [ "$${OVS_USER_ID/:*/}" != "root" ]; then /bin/echo "OVS_USER_OPT=--ovs-user=${OVS_USER_ID}" >> /run/openvswitch.useropts; fi' |
29 | -- | 30 | -- |
30 | 2.7.4 | 31 | 2.17.1 |
31 | 32 | ||
diff --git a/recipes-networking/openvswitch/openvswitch-git/systemd-update-tool-paths.patch b/recipes-networking/openvswitch/openvswitch-git/systemd-update-tool-paths.patch index aae44fe7..be6fa5d9 100644 --- a/recipes-networking/openvswitch/openvswitch-git/systemd-update-tool-paths.patch +++ b/recipes-networking/openvswitch/openvswitch-git/systemd-update-tool-paths.patch | |||
@@ -1,6 +1,6 @@ | |||
1 | From efd6b8f03ef7278d2477833f84bb8488bd0c346d Mon Sep 17 00:00:00 2001 | 1 | From a79bf6caf915d2a00a52a73033b1c903f2df894f Mon Sep 17 00:00:00 2001 |
2 | From: Mark Asselstine <mark.asselstine@windriver.com> | 2 | From: Mark Asselstine <mark.asselstine@windriver.com> |
3 | Date: Tue, 29 May 2018 18:57:46 +0000 | 3 | Date: Wed, 10 Mar 2021 11:17:37 +0800 |
4 | Subject: [PATCH 1/2] systemd: update tool paths | 4 | Subject: [PATCH 1/2] systemd: update tool paths |
5 | 5 | ||
6 | We are using the rhel files but we install our tools in a slightly | 6 | We are using the rhel files but we install our tools in a slightly |
@@ -9,11 +9,11 @@ different path, update accordingly. | |||
9 | Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> | 9 | Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> |
10 | --- | 10 | --- |
11 | rhel/usr_lib_systemd_system_ovs-vswitchd.service.in | 4 ++-- | 11 | rhel/usr_lib_systemd_system_ovs-vswitchd.service.in | 4 ++-- |
12 | rhel/usr_lib_systemd_system_ovsdb-server.service | 6 +++--- | 12 | rhel/usr_lib_systemd_system_ovsdb-server.service | 8 ++++---- |
13 | 2 files changed, 5 insertions(+), 5 deletions(-) | 13 | 2 files changed, 6 insertions(+), 6 deletions(-) |
14 | 14 | ||
15 | diff --git a/rhel/usr_lib_systemd_system_ovs-vswitchd.service.in b/rhel/usr_lib_systemd_system_ovs-vswitchd.service.in | 15 | diff --git a/rhel/usr_lib_systemd_system_ovs-vswitchd.service.in b/rhel/usr_lib_systemd_system_ovs-vswitchd.service.in |
16 | index ff43dae..f88b57c 100644 | 16 | index ff43dae96..f88b57cae 100644 |
17 | --- a/rhel/usr_lib_systemd_system_ovs-vswitchd.service.in | 17 | --- a/rhel/usr_lib_systemd_system_ovs-vswitchd.service.in |
18 | +++ b/rhel/usr_lib_systemd_system_ovs-vswitchd.service.in | 18 | +++ b/rhel/usr_lib_systemd_system_ovs-vswitchd.service.in |
19 | @@ -17,8 +17,8 @@ EnvironmentFile=-/etc/sysconfig/openvswitch | 19 | @@ -17,8 +17,8 @@ EnvironmentFile=-/etc/sysconfig/openvswitch |
@@ -28,22 +28,25 @@ index ff43dae..f88b57c 100644 | |||
28 | ExecStart=/usr/share/openvswitch/scripts/ovs-ctl \ | 28 | ExecStart=/usr/share/openvswitch/scripts/ovs-ctl \ |
29 | --no-ovsdb-server --no-monitor --system-id=random \ | 29 | --no-ovsdb-server --no-monitor --system-id=random \ |
30 | diff --git a/rhel/usr_lib_systemd_system_ovsdb-server.service b/rhel/usr_lib_systemd_system_ovsdb-server.service | 30 | diff --git a/rhel/usr_lib_systemd_system_ovsdb-server.service b/rhel/usr_lib_systemd_system_ovsdb-server.service |
31 | index 4c170c0..aad557f 100644 | 31 | index 98338b9df..5002ddf10 100644 |
32 | --- a/rhel/usr_lib_systemd_system_ovsdb-server.service | 32 | --- a/rhel/usr_lib_systemd_system_ovsdb-server.service |
33 | +++ b/rhel/usr_lib_systemd_system_ovsdb-server.service | 33 | +++ b/rhel/usr_lib_systemd_system_ovsdb-server.service |
34 | @@ -11,9 +11,9 @@ PIDFile=/var/run/openvswitch/ovsdb-server.pid | 34 | @@ -16,11 +16,11 @@ EnvironmentFile=-/run/openvswitch.useropts |
35 | Restart=on-failure | 35 | # Environment is reloaded for each Exec*, make sure to |
36 | EnvironmentFile=/etc/openvswitch/default.conf | 36 | # remove openvswitch.useropts first to reload a fresh |
37 | EnvironmentFile=-/etc/sysconfig/openvswitch | 37 | # OVS_USER_ID from default.conf or sysconfig. |
38 | -ExecStartPre=/usr/bin/rm -f /run/openvswitch.useropts | ||
39 | +ExecStartPre=/bin/rm -f /run/openvswitch.useropts | ||
40 | |||
38 | -ExecStartPre=-/usr/bin/chown ${OVS_USER_ID} /var/run/openvswitch /var/log/openvswitch | 41 | -ExecStartPre=-/usr/bin/chown ${OVS_USER_ID} /var/run/openvswitch /var/log/openvswitch |
39 | -ExecStartPre=/bin/sh -c 'rm -f /run/openvswitch.useropts; /usr/bin/echo "OVS_USER_ID=${OVS_USER_ID}" > /run/openvswitch.useropts' | 42 | -ExecStartPre=/bin/sh -c '/usr/bin/echo "OVS_USER_ID=${OVS_USER_ID}" > /run/openvswitch.useropts' |
40 | -ExecStartPre=/bin/sh -c 'if [ "$${OVS_USER_ID/:*/}" != "root" ]; then /usr/bin/echo "OVS_USER_OPT=--ovs-user=${OVS_USER_ID}" >> /run/openvswitch.useropts; fi' | 43 | -ExecStartPre=/bin/sh -c 'if [ "$${OVS_USER_ID/:*/}" != "root" ]; then /usr/bin/echo "OVS_USER_OPT=--ovs-user=${OVS_USER_ID}" >> /run/openvswitch.useropts; fi' |
41 | +ExecStartPre=-/bin/chown ${OVS_USER_ID} /var/run/openvswitch /var/log/openvswitch | 44 | +ExecStartPre=-/bin/chown ${OVS_USER_ID} /var/run/openvswitch /var/log/openvswitch |
42 | +ExecStartPre=/bin/sh -c 'rm -f /run/openvswitch.useropts; /bin/echo "OVS_USER_ID=${OVS_USER_ID}" > /run/openvswitch.useropts' | 45 | +ExecStartPre=/bin/sh -c '/bin/echo "OVS_USER_ID=${OVS_USER_ID}" > /run/openvswitch.useropts' |
43 | +ExecStartPre=/bin/sh -c 'if [ "$${OVS_USER_ID/:*/}" != "root" ]; then /bin/echo "OVS_USER_OPT=--ovs-user=${OVS_USER_ID}" >> /run/openvswitch.useropts; fi' | 46 | +ExecStartPre=/bin/sh -c 'if [ "$${OVS_USER_ID/:*/}" != "root" ]; then /bin/echo "OVS_USER_OPT=--ovs-user=${OVS_USER_ID}" >> /run/openvswitch.useropts; fi' |
44 | EnvironmentFile=-/run/openvswitch.useropts | ||
45 | ExecStart=/usr/share/openvswitch/scripts/ovs-ctl \ | 47 | ExecStart=/usr/share/openvswitch/scripts/ovs-ctl \ |
46 | --no-ovs-vswitchd --no-monitor --system-id=random \ | 48 | --no-ovs-vswitchd --no-monitor --system-id=random \ |
49 | ${OVS_USER_OPT} \ | ||
47 | -- | 50 | -- |
48 | 2.7.4 | 51 | 2.17.1 |
49 | 52 | ||
diff --git a/recipes-networking/openvswitch/openvswitch_git.bb b/recipes-networking/openvswitch/openvswitch_git.bb index 60aaf496..bda9ab05 100644 --- a/recipes-networking/openvswitch/openvswitch_git.bb +++ b/recipes-networking/openvswitch/openvswitch_git.bb | |||
@@ -14,22 +14,21 @@ RDEPENDS_${PN}-ptest += "\ | |||
14 | " | 14 | " |
15 | 15 | ||
16 | S = "${WORKDIR}/git" | 16 | S = "${WORKDIR}/git" |
17 | PV = "2.13+${SRCPV}" | 17 | PV = "2.15+${SRCPV}" |
18 | CVE_VERSION = "2.13.0" | 18 | CVE_VERSION = "2.13.0" |
19 | 19 | ||
20 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}-git:" | 20 | FILESEXTRAPATHS_append := "${THISDIR}/${PN}-git:" |
21 | 21 | ||
22 | SRCREV = "71d553b995d0bd527d3ab1e9fbaf5a2ae34de2f3" | 22 | SRCREV = "8dc1733eaea866dce033b3c44853e1b09bf59fc7" |
23 | SRC_URI = "file://openvswitch-switch \ | 23 | SRC_URI = "file://openvswitch-switch \ |
24 | file://openvswitch-switch-setup \ | 24 | file://openvswitch-switch-setup \ |
25 | file://openvswitch-testcontroller \ | 25 | file://openvswitch-testcontroller \ |
26 | file://openvswitch-testcontroller-setup \ | 26 | file://openvswitch-testcontroller-setup \ |
27 | git://github.com/openvswitch/ovs.git;protocol=git;branch=branch-2.13 \ | 27 | git://github.com/openvswitch/ovs.git;protocol=git;branch=branch-2.15 \ |
28 | file://openvswitch-add-ptest-71d553b995d0bd527d3ab1e9fbaf5a2ae34de2f3.patch \ | 28 | file://openvswitch-add-ptest-71d553b995d0bd527d3ab1e9fbaf5a2ae34de2f3.patch \ |
29 | file://run-ptest \ | 29 | file://run-ptest \ |
30 | file://disable_m4_check.patch \ | 30 | file://disable_m4_check.patch \ |
31 | file://kernel_module.patch \ | 31 | file://kernel_module.patch \ |
32 | file://python-switch-remaining-scripts-to-use-python3.patch \ | ||
33 | file://systemd-update-tool-paths.patch \ | 32 | file://systemd-update-tool-paths.patch \ |
34 | file://systemd-create-runtime-dirs.patch \ | 33 | file://systemd-create-runtime-dirs.patch \ |
35 | file://0001-ovs-use-run-instead-of-var-run-for-in-systemd-units.patch \ | 34 | file://0001-ovs-use-run-instead-of-var-run-for-in-systemd-units.patch \ |