summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-04-03 21:51:29 +0200
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-04-06 20:34:26 -0400
commit32267ea487cb82b19378ee58adbcd105ed4f8648 (patch)
tree89f3cfe5a92caf42dbf6a6ba3fa4403988ecd144
parent4ea3d7682103a19496f257a4425a4ee150c21722 (diff)
downloadmeta-virtualization-32267ea487cb82b19378ee58adbcd105ed4f8648.tar.gz
nagios-*: add conditional PNBLACKLIST, because of the dependency on meta-webserver
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-extended/nagios/nagios-core_4.4.6.bb2
-rw-r--r--recipes-extended/nagios/nagios-nrpe_4.0.2.bb2
-rw-r--r--recipes-extended/nagios/nagios-nsca_2.9.2.bb2
-rw-r--r--recipes-extended/nagios/nagios-plugins_2.2.1.bb2
4 files changed, 8 insertions, 0 deletions
diff --git a/recipes-extended/nagios/nagios-core_4.4.6.bb b/recipes-extended/nagios/nagios-core_4.4.6.bb
index 8bcd6c0a..fc3d2c5a 100644
--- a/recipes-extended/nagios/nagios-core_4.4.6.bb
+++ b/recipes-extended/nagios/nagios-core_4.4.6.bb
@@ -38,6 +38,8 @@ RDEPENDS_${PN} += "\
38 nagios-base \ 38 nagios-base \
39" 39"
40 40
41PNBLACKLIST[nagios-core] ?= "${@bb.utils.contains('BBFILE_COLLECTIONS', 'webserver', '', 'Depends on apache2 from meta-webserver which is not included', d)}"
42
41acpaths = "-I ${S}/autoconf-macros" 43acpaths = "-I ${S}/autoconf-macros"
42 44
43# Set default password for the hardcoded Nagios admin user "nagiosadmin". 45# Set default password for the hardcoded Nagios admin user "nagiosadmin".
diff --git a/recipes-extended/nagios/nagios-nrpe_4.0.2.bb b/recipes-extended/nagios/nagios-nrpe_4.0.2.bb
index d9c7b159..7f81172e 100644
--- a/recipes-extended/nagios/nagios-nrpe_4.0.2.bb
+++ b/recipes-extended/nagios/nagios-nrpe_4.0.2.bb
@@ -26,6 +26,8 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
26 26
27inherit autotools-brokensep update-rc.d systemd update-alternatives 27inherit autotools-brokensep update-rc.d systemd update-alternatives
28 28
29PNBLACKLIST[nagios-nrpe] ?= "${@bb.utils.contains('BBFILE_COLLECTIONS', 'webserver', '', 'Depends on nagios-core which depends on apache2 from meta-webserver which is not included', d)}"
30
29# IP address of server which proxy should connect to 31# IP address of server which proxy should connect to
30MONITORING_PROXY_SERVER_IP ??= "192.168.7.2" 32MONITORING_PROXY_SERVER_IP ??= "192.168.7.2"
31 33
diff --git a/recipes-extended/nagios/nagios-nsca_2.9.2.bb b/recipes-extended/nagios/nagios-nsca_2.9.2.bb
index 66f8da56..1fce1983 100644
--- a/recipes-extended/nagios/nagios-nsca_2.9.2.bb
+++ b/recipes-extended/nagios/nagios-nsca_2.9.2.bb
@@ -22,6 +22,8 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
22 22
23inherit update-rc.d autotools-brokensep systemd dos2unix 23inherit update-rc.d autotools-brokensep systemd dos2unix
24 24
25PNBLACKLIST[nagios-nsca] ?= "${@bb.utils.contains('BBFILE_COLLECTIONS', 'webserver', '', 'Rdepends on nagios-base provided by nagios-core which depends on apache2 from meta-webserver which is not included', d)}"
26
25DEPENDS = "libmcrypt" 27DEPENDS = "libmcrypt"
26 28
27EXTRA_OECONF += "--with-nsca-user=${NAGIOS_USER} \ 29EXTRA_OECONF += "--with-nsca-user=${NAGIOS_USER} \
diff --git a/recipes-extended/nagios/nagios-plugins_2.2.1.bb b/recipes-extended/nagios/nagios-plugins_2.2.1.bb
index 07933654..b97d80cb 100644
--- a/recipes-extended/nagios/nagios-plugins_2.2.1.bb
+++ b/recipes-extended/nagios/nagios-plugins_2.2.1.bb
@@ -18,6 +18,8 @@ S = "${WORKDIR}/${BPN}-${PV}"
18 18
19inherit autotools gettext 19inherit autotools gettext
20 20
21PNBLACKLIST[nagios-plugins] ?= "${@bb.utils.contains('BBFILE_COLLECTIONS', 'webserver', '', 'Depends on nagios-core which depends on apache2 from meta-webserver which is not included', d)}"
22
21EXTRA_OECONF += "--with-sysroot=${STAGING_DIR_HOST} \ 23EXTRA_OECONF += "--with-sysroot=${STAGING_DIR_HOST} \
22 --with-nagios-user=${NAGIOS_USER} \ 24 --with-nagios-user=${NAGIOS_USER} \
23 --with-nagios-group=${NAGIOS_GROUP} \ 25 --with-nagios-group=${NAGIOS_GROUP} \