diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2021-07-29 11:49:16 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2021-08-02 17:18:08 -0400 |
commit | 1b6e39e426ead27ad440e62c8ce692684c8b9ad3 (patch) | |
tree | bc4646f8146ffdc57e0d1b815cdafc8031846a26 | |
parent | d876cfc5bfafa516dee55d04b50b319a22165640 (diff) | |
download | meta-virtualization-1b6e39e426ead27ad440e62c8ce692684c8b9ad3.tar.gz |
global: overrides conversion pass 2
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | classes/qemuboot-xen-defaults.bbclass | 10 | ||||
-rw-r--r-- | conf/distro/include/meta-virt-xen.inc | 2 | ||||
-rw-r--r-- | recipes-extended/images/xen-image-minimal.bb | 4 | ||||
-rw-r--r-- | recipes-kernel/dtc/python3-dtc_1.6.1.bb | 2 | ||||
-rw-r--r-- | recipes-kernel/lopper/lopper.bb | 2 |
5 files changed, 10 insertions, 10 deletions
diff --git a/classes/qemuboot-xen-defaults.bbclass b/classes/qemuboot-xen-defaults.bbclass index 67751d3a..c7e74c3e 100644 --- a/classes/qemuboot-xen-defaults.bbclass +++ b/classes/qemuboot-xen-defaults.bbclass | |||
@@ -12,13 +12,13 @@ QB_XEN_DOMAIN_MODULES ??= "${DOM0_KERNEL}:${DOM0_KERNEL_LOAD_ADDR}:multiboot,ker | |||
12 | 12 | ||
13 | # Qemuboot for 64-bit Arm uses the QB_DEFAULT_KERNEL method to load Xen | 13 | # Qemuboot for 64-bit Arm uses the QB_DEFAULT_KERNEL method to load Xen |
14 | # and the device loader option for the dom0 kernel: | 14 | # and the device loader option for the dom0 kernel: |
15 | QB_OPT_APPEND_append_aarch64 = " \ | 15 | QB_OPT_APPEND:append:aarch64 = " \ |
16 | -device loader,file=${DOM0_KERNEL},addr=${DOM0_KERNEL_LOAD_ADDR} \ | 16 | -device loader,file=${DOM0_KERNEL},addr=${DOM0_KERNEL_LOAD_ADDR} \ |
17 | " | 17 | " |
18 | QB_DEFAULT_KERNEL_aarch64 = "xen-${MACHINE}" | 18 | QB_DEFAULT_KERNEL:aarch64 = "xen-${MACHINE}" |
19 | 19 | ||
20 | # 64-bit Arm: gic version 3 | 20 | # 64-bit Arm: gic version 3 |
21 | QB_MACHINE_aarch64 = "-machine virt,gic-version=3 -machine virtualization=true" | 21 | QB_MACHINE:aarch64 = "-machine virt,gic-version=3 -machine virtualization=true" |
22 | 22 | ||
23 | # Increase the default qemu memory allocation to allow for the hypervisor. | 23 | # Increase the default qemu memory allocation to allow for the hypervisor. |
24 | # Use a weak assignment to allow for change of default and override elsewhere. | 24 | # Use a weak assignment to allow for change of default and override elsewhere. |
@@ -26,5 +26,5 @@ QB_MEM_VALUE ??= "512" | |||
26 | QB_MEM = "-m ${QB_MEM_VALUE}" | 26 | QB_MEM = "-m ${QB_MEM_VALUE}" |
27 | 27 | ||
28 | # 64-bit Arm: qemuboot with a device tree binary | 28 | # 64-bit Arm: qemuboot with a device tree binary |
29 | QB_DTB_aarch64 = "${IMAGE_NAME}.qemuboot.dtb" | 29 | QB_DTB:aarch64 = "${IMAGE_NAME}.qemuboot.dtb" |
30 | QB_DTB_LINK_aarch64 = "${IMAGE_LINK_NAME}.qemuboot.dtb" | 30 | QB_DTB_LINK:aarch64 = "${IMAGE_LINK_NAME}.qemuboot.dtb" |
diff --git a/conf/distro/include/meta-virt-xen.inc b/conf/distro/include/meta-virt-xen.inc index dca9b040..5fbb57f8 100644 --- a/conf/distro/include/meta-virt-xen.inc +++ b/conf/distro/include/meta-virt-xen.inc | |||
@@ -12,4 +12,4 @@ include ${@bb.utils.contains('MACHINE', 'raspberrypi4-64', \ | |||
12 | '${XEN_RPI4_64_CONFIG_PATH}', '', d)} | 12 | '${XEN_RPI4_64_CONFIG_PATH}', '', d)} |
13 | 13 | ||
14 | # Set serial for working qemuboot console | 14 | # Set serial for working qemuboot console |
15 | SERIAL_CONSOLES_qemuarm64 ?= "115200;ttyAMA0" | 15 | SERIAL_CONSOLES:qemuarm64 ?= "115200;ttyAMA0" |
diff --git a/recipes-extended/images/xen-image-minimal.bb b/recipes-extended/images/xen-image-minimal.bb index 2a44e3c4..b4ddda2f 100644 --- a/recipes-extended/images/xen-image-minimal.bb +++ b/recipes-extended/images/xen-image-minimal.bb | |||
@@ -73,11 +73,11 @@ build_syslinux_cfg () { | |||
73 | } | 73 | } |
74 | 74 | ||
75 | # Enable runqemu. eg: runqemu xen-image-minimal nographic slirp | 75 | # Enable runqemu. eg: runqemu xen-image-minimal nographic slirp |
76 | WKS_FILE_x86-64 = "directdisk-xen.wks" | 76 | WKS_FILE:x86-64 = "directdisk-xen.wks" |
77 | QB_MEM ?= "-m 400" | 77 | QB_MEM ?= "-m 400" |
78 | QB_DEFAULT_KERNEL ?= "none" | 78 | QB_DEFAULT_KERNEL ?= "none" |
79 | QB_DEFAULT_FSTYPE ?= "wic" | 79 | QB_DEFAULT_FSTYPE ?= "wic" |
80 | QB_DEFAULT_FSTYPE_qemux86-64 = "wic" | 80 | QB_DEFAULT_FSTYPE:qemux86-64 = "wic" |
81 | QB_FSINFO ?= "wic:kernel-in-fs" | 81 | QB_FSINFO ?= "wic:kernel-in-fs" |
82 | QB_SERIAL_OPT = "-serial mon:stdio" | 82 | QB_SERIAL_OPT = "-serial mon:stdio" |
83 | # qemux86-64 machine does not include 'wic' in IMAGE_FSTYPES, which is needed | 83 | # qemux86-64 machine does not include 'wic' in IMAGE_FSTYPES, which is needed |
diff --git a/recipes-kernel/dtc/python3-dtc_1.6.1.bb b/recipes-kernel/dtc/python3-dtc_1.6.1.bb index 90889314..39295652 100644 --- a/recipes-kernel/dtc/python3-dtc_1.6.1.bb +++ b/recipes-kernel/dtc/python3-dtc_1.6.1.bb | |||
@@ -20,7 +20,7 @@ inherit distutils3 | |||
20 | 20 | ||
21 | DISTUTILS_SETUP_PATH = "${S}/pylibfdt" | 21 | DISTUTILS_SETUP_PATH = "${S}/pylibfdt" |
22 | 22 | ||
23 | do_configure_prepend() { | 23 | do_configure:prepend() { |
24 | oe_runmake -C "${S}" version_gen.h | 24 | oe_runmake -C "${S}" version_gen.h |
25 | mv "${S}/version_gen.h" "${DISTUTILS_SETUP_PATH}/" | 25 | mv "${S}/version_gen.h" "${DISTUTILS_SETUP_PATH}/" |
26 | } | 26 | } |
diff --git a/recipes-kernel/lopper/lopper.bb b/recipes-kernel/lopper/lopper.bb index 274d5b9a..ae280ee7 100644 --- a/recipes-kernel/lopper/lopper.bb +++ b/recipes-kernel/lopper/lopper.bb | |||
@@ -9,7 +9,7 @@ S = "${WORKDIR}/git" | |||
9 | 9 | ||
10 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=8e5f5f691f01c9fdfa7a7f2d535be619" | 10 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=8e5f5f691f01c9fdfa7a7f2d535be619" |
11 | 11 | ||
12 | RDEPENDS_${PN} = " \ | 12 | RDEPENDS:${PN} = " \ |
13 | python3-core \ | 13 | python3-core \ |
14 | python3-dtc \ | 14 | python3-dtc \ |
15 | python3-humanfriendly \ | 15 | python3-humanfriendly \ |