summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Clark <christopher.w.clark@gmail.com>2017-10-02 12:47:36 -0700
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-10-04 16:54:36 -0400
commitf0e708ea8c88ff9efce91bdd70432acbe53fec87 (patch)
tree97a54379c1ae4d7bd4fd783940f38030f0adb95b
parent44e74c9aa74c818181058f6d4b660309b35c6db4 (diff)
downloadmeta-virtualization-f0e708ea8c88ff9efce91bdd70432acbe53fec87.tar.gz
xen-guest-image-minimal: fix making PCI a x86-only dependency
The logic for restricting the xen-pciback kernel module to x86-only images was incorrect, resulting in the IMAGE_INSTALL_x86 and _x86-64 variables causing the IMAGE_INSTALL variable contents to be overridden and incomplete. This correction removes the specialized IMAGE_INSTALL_x86 and _x84-64 variables. The replacement logic causes a value with conditionally-populated contents to be added to the IMAGE_INSTALL variable. Signed-off-by: Christopher Clark <christopher.clark6@baesystems.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-extended/images/xen-image-minimal.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/recipes-extended/images/xen-image-minimal.bb b/recipes-extended/images/xen-image-minimal.bb
index a01976e7..827cc879 100644
--- a/recipes-extended/images/xen-image-minimal.bb
+++ b/recipes-extended/images/xen-image-minimal.bb
@@ -10,16 +10,16 @@ IMAGE_INSTALL += " \
10 kernel-module-xen-gntalloc \ 10 kernel-module-xen-gntalloc \
11 kernel-module-xen-gntdev \ 11 kernel-module-xen-gntdev \
12 kernel-module-xen-netback \ 12 kernel-module-xen-netback \
13 ${@bb.utils.contains('MACHINE_FEATURES', 'pci', "${XEN_PCIBACK_MODULE}", '', d)} \
13 kernel-module-xen-wdt \ 14 kernel-module-xen-wdt \
14 xen-base \ 15 xen-base \
15 qemu \ 16 qemu \
16 " 17 "
17 18
18# Linux kernel option CONFIG_XEN_PCIDEV_BACKEND depends on X86 19# Linux kernel option CONFIG_XEN_PCIDEV_BACKEND depends on X86
19IMAGE_INSTALL_x86 += " \ 20XEN_PCIBACK_MODULE = ""
20 ${@bb.utils.contains('MACHINE_FEATURES', 'pci', 'kernel-module-xen-pciback', '', d)}" 21XEN_PCIBACK_MODULE_x86 = "kernel-module-xen-pciback"
21IMAGE_INSTALL_x86-64 += " \ 22XEN_PCIBACK_MODULE_x86-64 = "kernel-module-xen-pciback"
22 ${@bb.utils.contains('MACHINE_FEATURES', 'pci', 'kernel-module-xen-pciback', '', d)}"
23 23
24LICENSE = "MIT" 24LICENSE = "MIT"
25 25