summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2016-09-22 15:42:50 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-09-22 10:05:18 -0400
commitb25af25747ca319d7932806ebdb33c7d220afa71 (patch)
treee45d9e34c62943a010df4d5f1d86784d44d510a3
parent7ff08e542d15b8e0104185768debf360044af7d1 (diff)
downloadmeta-virtualization-b25af25747ca319d7932806ebdb33c7d220afa71.tar.gz
libvirt: remove .o files for ptest
When do split_and_strip_files, it may calls debugedit to deal elf files. For ptest sub-package, it fails to run debugedit with .o files. So remove the .o files which are redundant to run ptest cases. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-extended/libvirt/libvirt_1.3.5.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-extended/libvirt/libvirt_1.3.5.bb b/recipes-extended/libvirt/libvirt_1.3.5.bb
index 3eff58d2..fad56323 100644
--- a/recipes-extended/libvirt/libvirt_1.3.5.bb
+++ b/recipes-extended/libvirt/libvirt_1.3.5.bb
@@ -275,7 +275,7 @@ do_install_ptest() {
275 find ${S}/tests -maxdepth 1 -type d -exec cp -r {} ${D}${PTEST_PATH}/tests/ \; 275 find ${S}/tests -maxdepth 1 -type d -exec cp -r {} ${D}${PTEST_PATH}/tests/ \;
276 276
277 # remove .la files for ptest, they aren't required and can trigger QA errors 277 # remove .la files for ptest, they aren't required and can trigger QA errors
278 for i in `find ${D}${PTEST_PATH} -type f -name *.la`; do 278 for i in `find ${D}${PTEST_PATH} -type f \( -name *.la -o -name *.o \)`; do
279 rm -f $i 279 rm -f $i
280 done 280 done
281} 281}