summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-10-27 16:49:30 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-10-27 16:49:34 -0400
commitada27ac45fb6e6872de078d4a55185f31719e44b (patch)
tree9e18a8d32c5c339eda3b343e562e39fdc4636a6d
parent2d00a79d831f223c9fb401b44562657e85e43f3d (diff)
downloadmeta-virtualization-ada27ac45fb6e6872de078d4a55185f31719e44b.tar.gz
kernel: add linux-yocto-4.8 bbappend
We want our options and features to apply to the 4.8 kernel as well as the older ones. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-kernel/linux/linux-yocto_4.8.bbappend19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-yocto_4.8.bbappend b/recipes-kernel/linux/linux-yocto_4.8.bbappend
new file mode 100644
index 00000000..f3be89ed
--- /dev/null
+++ b/recipes-kernel/linux/linux-yocto_4.8.bbappend
@@ -0,0 +1,19 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += "file://xt-checksum.scc \
4 file://ebtables.scc \
5 file://vswitch.scc \
6 file://lxc.scc \
7 "
8KERNEL_FEATURES_append = " features/kvm/qemu-kvm-enable.scc"
9
10KERNEL_MODULE_AUTOLOAD += "openvswitch"
11KERNEL_MODULE_AUTOLOAD += "kvm"
12KERNEL_MODULE_AUTOLOAD += "kvm-amd"
13KERNEL_MODULE_AUTOLOAD += "kvm-intel"
14
15# aufs kernel support required for xen-image-minimal
16KERNEL_FEATURES_append += "${@bb.utils.contains('DISTRO_FEATURES', 'aufs', ' features/aufs/aufs-enable.scc', '', d)}"
17
18# xen kernel support
19SRC_URI += "${@bb.utils.contains('DISTRO_FEATURES', 'xen', ' file://xen.scc', '', d)}"