summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLans Zhang <jia.zhang@windriver.com>2017-01-21 13:37:53 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-01-21 23:17:34 -0500
commitab373099f54d2dd32882359a4c57bc26a17e5b76 (patch)
tree01b45c5fe12235e3e347bba970ed5a406ab8960c
parente764db31c1b9c4807a461c002e85ab84a9aae225 (diff)
downloadmeta-virtualization-ab373099f54d2dd32882359a4c57bc26a17e5b76.tar.gz
containered|runc: override GOROOT at build time
Similar to commit 01aa8f1, runc and containered also need to set GOROOT explicitly. Signed-off-by: Lans Zhang <jia.zhang@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-containers/containerd/containerd_git.bb1
-rw-r--r--recipes-containers/runc/runc_git.bb1
2 files changed, 2 insertions, 0 deletions
diff --git a/recipes-containers/containerd/containerd_git.bb b/recipes-containers/containerd/containerd_git.bb
index ca99e558..096a164c 100644
--- a/recipes-containers/containerd/containerd_git.bb
+++ b/recipes-containers/containerd/containerd_git.bb
@@ -44,6 +44,7 @@ do_compile() {
44 mkdir -p .gopath/src/"$(dirname "${CONTAINERD_PKG}")" 44 mkdir -p .gopath/src/"$(dirname "${CONTAINERD_PKG}")"
45 ln -sf ../../../.. .gopath/src/"${CONTAINERD_PKG}" 45 ln -sf ../../../.. .gopath/src/"${CONTAINERD_PKG}"
46 export GOPATH="${S}/.gopath:${S}/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go" 46 export GOPATH="${S}/.gopath:${S}/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go"
47 export GOROOT="${STAGING_DIR_NATIVE}/${nonarch_libdir}/${HOST_SYS}/go"
47 cd - 48 cd -
48 49
49 # Pass the needed cflags/ldflags so that cgo 50 # Pass the needed cflags/ldflags so that cgo
diff --git a/recipes-containers/runc/runc_git.bb b/recipes-containers/runc/runc_git.bb
index 905a751b..ed9a32e4 100644
--- a/recipes-containers/runc/runc_git.bb
+++ b/recipes-containers/runc/runc_git.bb
@@ -43,6 +43,7 @@ do_compile() {
43 43
44 (cd .gopath/src/${dname}; ln -sf ../../../../../${bname} ${bname}) 44 (cd .gopath/src/${dname}; ln -sf ../../../../../${bname} ${bname})
45 export GOPATH="${S}/.gopath:${S}/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go" 45 export GOPATH="${S}/.gopath:${S}/vendor:${STAGING_DIR_TARGET}/${prefix}/local/go"
46 export GOROOT="${STAGING_DIR_NATIVE}/${nonarch_libdir}/${HOST_SYS}/go"
46 cd - 47 cd -
47 48
48 # Pass the needed cflags/ldflags so that cgo 49 # Pass the needed cflags/ldflags so that cgo