summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-11-08 22:36:09 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-11-21 15:58:33 -0500
commit8753a622f1a3313a8459dbd45e7bd0434a271346 (patch)
treeab24bae49e671a393e0d986667ec9c39f01a018e
parent013fe63f17b2e25ba06744c7db436ca0ab01285f (diff)
downloadmeta-virtualization-8753a622f1a3313a8459dbd45e7bd0434a271346.tar.gz
oci: introduce runtime tools
The oci runtime uses config.json to configure and control containers. Most of that file can be generated via the oci runtime tools. With this package we can generate container configurations dynamically on the target. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb b/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
new file mode 100644
index 00000000..dac2d133
--- /dev/null
+++ b/recipes-containers/oci-runtime-tools/oci-runtime-tools_git.bb
@@ -0,0 +1,35 @@
1HOMEPAGE = "https://github.com/opencontainers/runtime-tools"
2SUMMARY = "oci-runtime-tool is a collection of tools for working with the OCI runtime specification"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b355a61a394a504dacde901c958f662c"
5DEPENDS = "go-cross"
6
7SRC_URI = "git://github.com/opencontainers/runtime-tools.git"
8
9SRCREV = "038b0c99b82f3c08de31f6b09e693eb24644affd"
10PV = "0.0.1+git${SRCPV}"
11
12S = "${WORKDIR}/git"
13
14inherit go-osarchmap
15
16do_compile() {
17 export GOARCH="${TARGET_GOARCH}"
18
19 export GOPATH="${S}"
20
21 # Pass the needed cflags/ldflags so that cgo
22 # can find the needed headers files and libraries
23 export CGO_ENABLED="1"
24 export CFLAGS=""
25 export LDFLAGS=""
26 export CGO_CFLAGS="${BUILDSDK_CFLAGS} --sysroot=${STAGING_DIR_TARGET}"
27 export CGO_LDFLAGS="${BUILDSDK_LDFLAGS} --sysroot=${STAGING_DIR_TARGET}"
28
29 oe_runmake
30}
31
32do_install() {
33 install -d ${D}/${sbindir}
34 install ${S}/oci-runtime-tool ${D}/${sbindir}/oci-runtime-tool
35}