summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-03-20 20:59:43 -0700
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-03-21 08:22:26 -0400
commit1b83c21436b2aec10e7b604ee5e3905441d1bb8a (patch)
treee821929076be61a8ac82db37490989d03bbe6a19
parentda1272171f5ab370bdfb9730e045d9a4ca884862 (diff)
downloadmeta-virtualization-1b83c21436b2aec10e7b604ee5e3905441d1bb8a.tar.gz
openvswitch: Fix build with musl libc
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-networking/openvswitch/openvswitch-git/0001-use-the-linux-if_packet.h-Interface-directly.patch35
-rw-r--r--recipes-networking/openvswitch/openvswitch-git/0002-Define-WAIT_ANY-if-not-provided-by-system.patch31
-rw-r--r--recipes-networking/openvswitch/openvswitch_git.bb23
3 files changed, 80 insertions, 9 deletions
diff --git a/recipes-networking/openvswitch/openvswitch-git/0001-use-the-linux-if_packet.h-Interface-directly.patch b/recipes-networking/openvswitch/openvswitch-git/0001-use-the-linux-if_packet.h-Interface-directly.patch
new file mode 100644
index 00000000..35712452
--- /dev/null
+++ b/recipes-networking/openvswitch/openvswitch-git/0001-use-the-linux-if_packet.h-Interface-directly.patch
@@ -0,0 +1,35 @@
1From 1cec65e45f011c3f52eed5e27d3d816502e36610 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 20 Mar 2017 12:12:51 -0700
4Subject: [PATCH 1/2] use the linux if_packet.h Interface directly
5
6Helps compiling with musl
7
8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9---
10 lib/netdev-linux.c | 3 +--
11 1 file changed, 1 insertion(+), 2 deletions(-)
12
13diff --git a/lib/netdev-linux.c b/lib/netdev-linux.c
14index a5a9ec1ab..9dd40acdd 100644
15--- a/lib/netdev-linux.c
16+++ b/lib/netdev-linux.c
17@@ -33,14 +33,13 @@
18 #include <linux/pkt_sched.h>
19 #include <linux/rtnetlink.h>
20 #include <linux/sockios.h>
21+#include <linux/if_packet.h>
22 #include <sys/types.h>
23 #include <sys/ioctl.h>
24 #include <sys/socket.h>
25 #include <sys/utsname.h>
26-#include <netpacket/packet.h>
27 #include <net/if.h>
28 #include <net/if_arp.h>
29-#include <net/if_packet.h>
30 #include <net/route.h>
31 #include <netinet/in.h>
32 #include <poll.h>
33--
342.12.0
35
diff --git a/recipes-networking/openvswitch/openvswitch-git/0002-Define-WAIT_ANY-if-not-provided-by-system.patch b/recipes-networking/openvswitch/openvswitch-git/0002-Define-WAIT_ANY-if-not-provided-by-system.patch
new file mode 100644
index 00000000..e44ffdaf
--- /dev/null
+++ b/recipes-networking/openvswitch/openvswitch-git/0002-Define-WAIT_ANY-if-not-provided-by-system.patch
@@ -0,0 +1,31 @@
1From 803bde12d32d16eefeae03422a0ac682e0601c43 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 20 Mar 2017 12:13:30 -0700
4Subject: [PATCH 2/2] Define WAIT_ANY if not provided by system
5
6POSIX does not define it and uses -1 directly
7some libc do not have this definitions
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 tests/test-ovn.c | 4 ++++
12 1 file changed, 4 insertions(+)
13
14diff --git a/tests/test-ovn.c b/tests/test-ovn.c
15index 2e82a6f0d..76e7db9fb 100644
16--- a/tests/test-ovn.c
17+++ b/tests/test-ovn.c
18@@ -37,6 +37,10 @@
19 #include "simap.h"
20 #include "util.h"
21
22+#ifndef WAIT_ANY
23+# define WAIT_ANY (-1) /* Any process. */
24+#endif
25+
26 /* --relops: Bitmap of the relational operators to test, in exhaustive test. */
27 static unsigned int test_relops;
28
29--
302.12.0
31
diff --git a/recipes-networking/openvswitch/openvswitch_git.bb b/recipes-networking/openvswitch/openvswitch_git.bb
index 455fab05..0ead3020 100644
--- a/recipes-networking/openvswitch/openvswitch_git.bb
+++ b/recipes-networking/openvswitch/openvswitch_git.bb
@@ -17,15 +17,20 @@ PV = "2.6.1+${SRCREV}"
17FILESEXTRAPATHS_append := "${THISDIR}/${PN}-git:" 17FILESEXTRAPATHS_append := "${THISDIR}/${PN}-git:"
18 18
19SRCREV = "f4b0e64cffb4777ff03d48621c3eadcf1d8c19f3" 19SRCREV = "f4b0e64cffb4777ff03d48621c3eadcf1d8c19f3"
20SRC_URI += "\ 20SRC_URI = "file://openvswitch-switch \
21 git://github.com/openvswitch/ovs.git;protocol=git;branch=branch-2.6 \ 21 file://openvswitch-switch-setup \
22 file://openvswitch-add-ptest-${SRCREV}.patch \ 22 file://openvswitch-testcontroller \
23 file://run-ptest \ 23 file://openvswitch-testcontroller-setup \
24 file://disable_m4_check.patch \ 24 git://github.com/openvswitch/ovs.git;protocol=git;branch=branch-2.6 \
25 file://kernel_module.patch \ 25 file://openvswitch-add-ptest-${SRCREV}.patch \
26 file://openvswitch-ptest-Fix-python-path.patch \ 26 file://run-ptest \
27 file://python-make-remaining-scripts-use-usr-bin-env.patch \ 27 file://disable_m4_check.patch \
28 " 28 file://kernel_module.patch \
29 file://openvswitch-ptest-Fix-python-path.patch \
30 file://python-make-remaining-scripts-use-usr-bin-env.patch \
31 file://0001-use-the-linux-if_packet.h-Interface-directly.patch \
32 file://0002-Define-WAIT_ANY-if-not-provided-by-system.patch \
33 "
29 34
30LIC_FILES_CHKSUM = "file://COPYING;md5=17b2c9d4c70853a09c0e143137754b35" 35LIC_FILES_CHKSUM = "file://COPYING;md5=17b2c9d4c70853a09c0e143137754b35"
31 36