summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Kiszka <jan.kiszka@siemens.com>2017-02-10 13:14:41 +0100
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-02-16 18:37:57 -0500
commit5cacf8632da2c20dc994c3b33608f0d3cea9df13 (patch)
tree527ee9b1fd21f642f698b6eb3ea98d8f19965d15
parent120745a7fcb72ece2616ce3f5ae233badb587352 (diff)
downloadmeta-virtualization-5cacf8632da2c20dc994c3b33608f0d3cea9df13.tar.gz
containerd: Fix build on 386
Go only understands "386" as target arch, not "i586". Adjust this. Signed-off-by: Jan Kiszka <jan.kiszka@siemens.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-containers/containerd/containerd_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-containers/containerd/containerd_git.bb b/recipes-containers/containerd/containerd_git.bb
index ca99e558..c2000b1c 100644
--- a/recipes-containers/containerd/containerd_git.bb
+++ b/recipes-containers/containerd/containerd_git.bb
@@ -35,6 +35,9 @@ do_compile() {
35 if [ "${TARGET_ARCH}" = "aarch64" ]; then 35 if [ "${TARGET_ARCH}" = "aarch64" ]; then
36 export GOARCH="arm64" 36 export GOARCH="arm64"
37 fi 37 fi
38 if [ "${TARGET_ARCH}" = "i586" ]; then
39 export GOARCH="386"
40 fi
38 41
39 # Set GOPATH. See 'PACKAGERS.md'. Don't rely on 42 # Set GOPATH. See 'PACKAGERS.md'. Don't rely on
40 # docker to download its dependencies but rather 43 # docker to download its dependencies but rather