summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-11-22 11:15:04 -0500
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-11-22 11:20:14 -0500
commitb8e53d99f9743b5bd1bdb8951812d129527ca915 (patch)
treea7c349e2668f25055bb04c4339749eddd554bd9d
parent9ab81946f6293f512d7d8eb65db5516781b23531 (diff)
downloadmeta-virtualization-b8e53d99f9743b5bd1bdb8951812d129527ca915.tar.gz
podman: update to 3.4.2
Bumping libpod to version v3.4.2-4-g72031783c, which comprises the following commits: 25f35ac9e Use CGO_ENABLED=1 when building natively on darwin 7c98d542b Bump to v3.4.3-dev 2ad1fd355 Bump to v3.4.2 1d6397e5c Add release notes for v3.4.2 6d9b1e4b8 Fix partial log line handling with journald log driver 8b368b5e1 Fix Zsh completion command documentation c2fb170b8 Fix flake in upgrade tests 6770fede7 VOLUME must be declared after RUN chown command cedf1a3d4 podman-generate-kube - remove empty structs from YAML e456873c0 Exclude already built sources for static build e9f6e5194 Match .c files in Makefile de852ebd0 shm_lock: Handle ENOSPC better in AllocateSemaphore fc1707dfe Minor test tweaks c8b7ca2ba pod/container create: resolve conflicts of generated names 2dc8db773 Add some information about disabling SELinux when using system volumes 93a3e720d Log Apache access_log-like entries at Info level [NO NEW TESTS NEEDED] b1ac02dcb tweak a couple of flag descriptions in help output 718de67f3 Fix bindings container log test dd6551055 test: run --cgroups=split in new cgroup df9e0fdcb Fix tests of podman image trust --raw and --json df736396e Tighten the expected output of the "podman image trust show" test 18c322d1c Use INTEGRATION_ROOT instead of current directory 3bd80ac9a Handle HTTP 409 error messages properly for Pod actions a8332f694 Fix swagger definitions 5889c2c24 Cirrus: Authorize rootless user self-ssh 2a0aad6be Add information on how podman machine is updated 0ded340e6 Fix help message case for `podman version` fa29ca710 Fix pause usage example 6bf6d7237 Set Checkpointed state to false after restore 2d6252b98 runtime: change PID existence check a208bc24d Set DOCKER_HOST in the VM 246782133 runtime: check for pause pid existence 0519e7ef8 utils: do not overwrite the err variable 2b85684ad Fix systemd PID1 test 0e1f67b72 cgroups: use SessionBusPrivateNoAutoStartup 9707ff5d4 vendor: update godbus to v5.0.6 a67bf0f92 Slirp4netns with ipv6 set net.ipv6.conf.default.accept_dad=0 47afa6d96 Fix a few problems in 'podman logs --tail' with journald driver 729310a85 If Dockerfile exists in same directory as service, we should not use it. 7275d389b Document to not set K8S envars for CNI 955d01f5a [NO NEW TESTS NEEDED] Fix off-by-one index comparision (reported by LGTM) 2ff511798 Fix some typos in documentation and comments (found by codespell) eead06b9d [CI:DOCS] Fix typo keep_id -> keep-id 8887cc7e4 podman run --memory=0 ... should not set memory limit 6f779b230 systemd: compatible with rootless mode 465e27cf1 Use exponential backoff when waiting for a journal entry 3b67336b6 Pod Rm Infra Improvements f8ede7c5e System tests: confirm that -a and -l clash c3f3e6d3b Remove infra ID from DB before removing containers b3eaa08c5 Generate Kube should not print default structs d489abf26 fuse-overlay probably means fuse-overlayfs. 34739f441 Replace 'an user' => 'a user' 9c94530bb network reload without ports should not reload ports eca1b6c0b pod create: read network mode from config 9e78185e3 volumes: be more tolerant and fix infinite loop 5c2d17e1c [backport] tag: Support tagging manifest list instead of resolving to images 46f7d2af1 Bump to v3.4.2-dev a6493ae69 Bump to v3.4.1 56a4372c2 Update release notes for v3.4.1 f05e206bd Fix test failures from backports 437ec951d system tests: socket activation: clean up 5aa89c88f Checkpoint/Restore test fixes d39e41283 Set targetPort to the port value in the kube yaml 7923bfcb0 Test-hang fix: Wait for ready + timeout on connect. c135ff76d Don't include ctr.log if not using file logging 9168db8bc Do not add TCP to protocol in generated kube yaml b5dd62f31 Don't use docker/pkg/archive, use containers/storage/pkg/archive a213661ae Fix panic in container create compat api 92ed439d2 Don't add image entrypoint to the generate kube yaml 16fb4161a Kube Gen run as user/group issues 3082ba8b7 No space in kube annotations for bind mounts b470de05b cgroups: use cgroup.controllers to read controllers 8b87793d4 Use SplitN(2) when copying env variables d458bc304 [CI:DOCS] Include manifest example usage fbe94088f podman stats: move cgroup validation to server 338e01f04 [CI:DOCS] oci-hooks.5.md: fixup section in header de6a4af5a Change podman.1 man page to show corret log-level default 326eae3b7 Add podman-plugins to upstream image ca33df146 Ensure `podman ps --sync` functions 7bbf774e8 Allow `podman stop` to be run on Stopping containers 2cd206d0f libpod: fix race when closing STDIN 37347c321 It really should be no **NEW** tests needed 62d12a2ad Add guard for BuildOptions.CommonBuildOpts c6be71486 machine: silently cleanup dangling sockets before rm if possible 835d74ac6 sdnotify test: accept MAINPID anywhere 14509a92b Allow a value of -1 to set unlimited pids limit deb7517cc Gating tests: fix permissions error cd4e10fdf [v3.4] bump c/common to v0.44.3 91f9682c7 Bump to v3.4.1-dev 6e8de00bb Bump to v3.4.0 Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-containers/podman/podman_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-containers/podman/podman_git.bb b/recipes-containers/podman/podman_git.bb
index 5ab79d30..4f6d58a2 100644
--- a/recipes-containers/podman/podman_git.bb
+++ b/recipes-containers/podman/podman_git.bb
@@ -17,7 +17,7 @@ DEPENDS = " \
17 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ 17 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
18" 18"
19 19
20SRCREV = "6e8de00bb224f9931d7402648f0177e7357ed079" 20SRCREV = "72031783c5152cc715a8f1b6dc39bb5de8bfc3ca"
21SRC_URI = " \ 21SRC_URI = " \
22 git://github.com/containers/libpod.git;branch=v3.4;protocol=https \ 22 git://github.com/containers/libpod.git;branch=v3.4;protocol=https \
23" 23"
@@ -29,7 +29,7 @@ GO_IMPORT = "import"
29 29
30S = "${WORKDIR}/git" 30S = "${WORKDIR}/git"
31 31
32PV = "3.4.0+git${SRCPV}" 32PV = "3.4.2+git${SRCPV}"
33 33
34PACKAGES =+ "${PN}-contrib" 34PACKAGES =+ "${PN}-contrib"
35 35