summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorXu, Yanfei <yanfei.xu@windriver.com>2021-06-22 17:55:31 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-06-24 12:40:18 -0400
commitbbf7ddbe0269cf3cb6d8dcae4495d7983d256016 (patch)
treec7c3dc79cf82d303e47bde0fd7e3593061570a04
parentdaac3b630f48264ace803ef9ba09c4dada7a700c (diff)
downloadmeta-virtualization-bbf7ddbe0269cf3cb6d8dcae4495d7983d256016.tar.gz
skopeo: add native and nativesdk support
1.Add native and nativesdk support. 2.Replace "multipath-tools" with "libdevmapper" and "lvm2". Because the really direct DEPENDS package is "libdevmapper" and "lvm2". Log of do_comopile as below: -----------------[cut here]--------------------- DEBUG: Executing shell function do_compile NOTE: make -j 40 BUILDTAGS= bin/skopeo CGO_CFLAGS="-I/...../usr/include" CGO_LDFLAGS="-L/...../usr/lib -lgpgme -lgpg-error -lassuan" GO111MODULE=on go build -mod=vendor "-buildmode=pie" -ldflags '-X main.gitCommit=8efffce8befc2de87670ba75d6c86ada61e869fd ' -gcflags "" -tags "" -o bin/skopeo ./cmd/skopeo Package devmapper was not found in the pkg-config search path. Perhaps you should add the directory containing `devmapper.pc' to the PKG_CONFIG_PATH environment variable No package 'devmapper' found pkg-config: exit status 1 make: *** [Makefile:134: bin/skopeo] Error 2 Signed-off-by: Yanfei Xu <yanfei.xu@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-containers/skopeo/skopeo_git.bb15
1 files changed, 14 insertions, 1 deletions
diff --git a/recipes-containers/skopeo/skopeo_git.bb b/recipes-containers/skopeo/skopeo_git.bb
index 2c292463..6c95bf3e 100644
--- a/recipes-containers/skopeo/skopeo_git.bb
+++ b/recipes-containers/skopeo/skopeo_git.bb
@@ -5,7 +5,8 @@ LIC_FILES_CHKSUM = "file://src/import/LICENSE;md5=7e611105d3e369954840a6668c4385
5 5
6DEPENDS = " \ 6DEPENDS = " \
7 gpgme \ 7 gpgme \
8 multipath-tools \ 8 libdevmapper \
9 lvm2 \
9 btrfs-tools \ 10 btrfs-tools \
10 glib-2.0 \ 11 glib-2.0 \
11 ostree \ 12 ostree \
@@ -80,4 +81,16 @@ do_install() {
80 install ${WORKDIR}/registries.conf ${D}/${sysconfdir}/containers/registries.conf 81 install ${WORKDIR}/registries.conf ${D}/${sysconfdir}/containers/registries.conf
81} 82}
82 83
84do_install_append_class-native() {
85 create_cmdline_wrapper ${D}/${sbindir}/skopeo \
86 --policy ${sysconfdir}/containers/policy.json
87}
88
89do_install_append_class-nativesdk() {
90 create_cmdline_wrapper ${D}/${sbindir}/skopeo \
91 --policy ${sysconfdir}/containers/policy.json
92}
93
83INSANE_SKIP_${PN} += "ldflags" 94INSANE_SKIP_${PN} += "ldflags"
95
96BBCLASSEXTEND = "native nativesdk"