summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Puhlman <jpuhlman@mvista.com>2018-06-08 16:08:11 -0700
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-06-11 12:05:40 -0400
commit6c354d16212ed31488a9e1f25c77dc94403e5272 (patch)
treeae4ea431da70db4c82a51d5fb352d80fa7fdf5f9
parent9afe74cd350598c92aa5faff54d93ba06d33079d (diff)
downloadmeta-virtualization-6c354d16212ed31488a9e1f25c77dc94403e5272.tar.gz
lxc: uprev 3.0.1
- Bug fix release - Fixes gcc8 build failures - Update patch for fuzz issues. - remove --disable-python and --disable-lua as they have been removed Signed-off-by: Jeremy Puhlman <jpuhlman@mvista.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-containers/lxc/files/templates-actually-create-DOWNLOAD_TEMP-directory.patch10
-rw-r--r--recipes-containers/lxc/lxc_3.0.1.bb (renamed from recipes-containers/lxc/lxc_3.0.0.bb)6
2 files changed, 7 insertions, 9 deletions
diff --git a/recipes-containers/lxc/files/templates-actually-create-DOWNLOAD_TEMP-directory.patch b/recipes-containers/lxc/files/templates-actually-create-DOWNLOAD_TEMP-directory.patch
index 359f6622..44959db5 100644
--- a/recipes-containers/lxc/files/templates-actually-create-DOWNLOAD_TEMP-directory.patch
+++ b/recipes-containers/lxc/files/templates-actually-create-DOWNLOAD_TEMP-directory.patch
@@ -22,12 +22,12 @@ Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
22 1 file changed, 1 insertion(+), 1 deletion(-) 22 1 file changed, 1 insertion(+), 1 deletion(-)
23 23
24diff --git a/templates/lxc-download.in b/templates/lxc-download.in 24diff --git a/templates/lxc-download.in b/templates/lxc-download.in
25index f875183..5f1138c 100644 25index 973783b..015a679 100644
26--- a/templates/lxc-download.in 26--- a/templates/lxc-download.in
27+++ b/templates/lxc-download.in 27+++ b/templates/lxc-download.in
28@@ -320,7 +320,7 @@ fi 28@@ -323,7 +323,7 @@ elif [ -n "${DOWNLOAD_TEMP}" ]; then
29 if ! command -V mktemp >/dev/null 2>&1; then 29 mkdir -p "${DOWNLOAD_TEMP}"
30 DOWNLOAD_TEMP="${DOWNLOAD_TEMP}/tmp/lxc-download.$$" 30 DOWNLOAD_TEMP="$(mktemp -p ${DOWNLOAD_TEMP} -d)"
31 else 31 else
32- DOWNLOAD_TEMP="${DOWNLOAD_TEMP}$(mktemp -d)" 32- DOWNLOAD_TEMP="${DOWNLOAD_TEMP}$(mktemp -d)"
33+ DOWNLOAD_TEMP="$(mktemp -p ${DOWNLOAD_TEMP} -d)" 33+ DOWNLOAD_TEMP="$(mktemp -p ${DOWNLOAD_TEMP} -d)"
@@ -35,5 +35,5 @@ index f875183..5f1138c 100644
35 35
36 # Simply list images 36 # Simply list images
37-- 37--
382.7.4 382.11.1
39 39
diff --git a/recipes-containers/lxc/lxc_3.0.0.bb b/recipes-containers/lxc/lxc_3.0.1.bb
index 4f7526bd..a77dd093 100644
--- a/recipes-containers/lxc/lxc_3.0.0.bb
+++ b/recipes-containers/lxc/lxc_3.0.1.bb
@@ -47,8 +47,8 @@ SRC_URI = "http://linuxcontainers.org/downloads/${BPN}-${PV}.tar.gz \
47 file://lxc-net \ 47 file://lxc-net \
48 " 48 "
49 49
50SRC_URI[md5sum] = "ca1db4f9dc35df9203a58ab606cdfb7a" 50SRC_URI[md5sum] = "8eb396dde561e5832ba2d505513a1935"
51SRC_URI[sha256sum] = "6230224c27f050201b372b18a9f39cd220ed584899c5f0cf73c6b313dabc8d8a" 51SRC_URI[sha256sum] = "45986c49be1c048fa127bd3e7ea1bd3347e25765c008a09a2e4c233151a2d5db"
52 52
53S = "${WORKDIR}/${BPN}-${PV}" 53S = "${WORKDIR}/${BPN}-${PV}"
54 54
@@ -76,8 +76,6 @@ PACKAGECONFIG[templates] = ",,, ${PN}-templates"
76PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux,libselinux" 76PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux,libselinux"
77PACKAGECONFIG[seccomp] ="--enable-seccomp,--disable-seccomp,libseccomp,libseccomp" 77PACKAGECONFIG[seccomp] ="--enable-seccomp,--disable-seccomp,libseccomp,libseccomp"
78PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,--without-systemdsystemunitdir,systemd," 78PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,--without-systemdsystemunitdir,systemd,"
79PACKAGECONFIG[python] = "--enable-python,--disable-python,python3,python3-core"
80PACKAGECONFIG[lua] = "--enable-lua,--disable-lua,lua,lua"
81 79
82# required by python3 to run setup.py 80# required by python3 to run setup.py
83export BUILD_SYS 81export BUILD_SYS