summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPascal Bach <pascal.bach@siemens.com>2018-05-30 11:17:59 +0200
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-05-30 08:53:25 -0400
commit4987f02577432e518e627c2c139c378b8b6a9678 (patch)
tree4ad75fbd80243635c031ca6cfbd21857ad0ac955
parent33eb70520aca4312b1767746a8d2dfeb8db7579b (diff)
downloadmeta-virtualization-4987f02577432e518e627c2c139c378b8b6a9678.tar.gz
tini: add version 0.18.0 as docker-init provider
This removes the warning that docker can't find docker-init in PATH. This recipe is based on the recipe from meta-resin. Signed-off-by: Pascal Bach <pascal.bach@siemens.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-containers/docker/docker_git.bb2
-rw-r--r--recipes-containers/tini/tini/0001-Do-not-strip-the-output-binary-allow-yocto-to-do-thi.patch28
-rw-r--r--recipes-containers/tini/tini_0.18.0.bb32
3 files changed, 61 insertions, 1 deletions
diff --git a/recipes-containers/docker/docker_git.bb b/recipes-containers/docker/docker_git.bb
index 790170e9..73e01203 100644
--- a/recipes-containers/docker/docker_git.bb
+++ b/recipes-containers/docker/docker_git.bb
@@ -74,7 +74,7 @@ RDEPENDS_${PN} = "util-linux iptables \
74 " 74 "
75RDEPENDS_${PN} += "virtual/containerd virtual/runc" 75RDEPENDS_${PN} += "virtual/containerd virtual/runc"
76 76
77RRECOMMENDS_${PN} = "kernel-module-dm-thin-pool kernel-module-nf-nat" 77RRECOMMENDS_${PN} = "kernel-module-dm-thin-pool kernel-module-nf-nat docker-init"
78RSUGGESTS_${PN} = "lxc rt-tests" 78RSUGGESTS_${PN} = "lxc rt-tests"
79DOCKER_PKG="github.com/docker/docker" 79DOCKER_PKG="github.com/docker/docker"
80 80
diff --git a/recipes-containers/tini/tini/0001-Do-not-strip-the-output-binary-allow-yocto-to-do-thi.patch b/recipes-containers/tini/tini/0001-Do-not-strip-the-output-binary-allow-yocto-to-do-thi.patch
new file mode 100644
index 00000000..6797720c
--- /dev/null
+++ b/recipes-containers/tini/tini/0001-Do-not-strip-the-output-binary-allow-yocto-to-do-thi.patch
@@ -0,0 +1,28 @@
1From b99ef9954a34cffd85a5cc09922b201ae11b494d Mon Sep 17 00:00:00 2001
2From: Theodor Gherzan <theodor@resin.io>
3Date: Mon, 5 Jun 2017 18:16:56 +0200
4Subject: [PATCH] Do not strip the output binary, allow yocto to do this
5
6Upstream-Status: Inappropriate [configuration specific]
7
8Signed-off-by: Theodor Gherzan <theodor@resin.io>
9---
10 CMakeLists.txt | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/CMakeLists.txt b/CMakeLists.txt
14index b5b93ba..c2907e2 100644
15--- a/CMakeLists.txt
16+++ b/CMakeLists.txt
17@@ -54,7 +54,7 @@ if(NOT HAS_BUILTIN_FORTIFY)
18 endif()
19
20 set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99 -Werror -Wextra -Wall -pedantic-errors -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat")
21-set (CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,-Bsymbolic-functions -Wl,-z,relro -Wl,-s")
22+set (CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,-Bsymbolic-functions -Wl,-z,relro")
23
24 # Build
25
26--
272.7.4
28
diff --git a/recipes-containers/tini/tini_0.18.0.bb b/recipes-containers/tini/tini_0.18.0.bb
new file mode 100644
index 00000000..7c124a89
--- /dev/null
+++ b/recipes-containers/tini/tini_0.18.0.bb
@@ -0,0 +1,32 @@
1HOMEPAGE = "http://github.com/krallin/tini"
2SUMMARY = "Minimal init for containers"
3DESCRIPTION = "Tini is the simplest init you could think of. All Tini does is \
4spawn a single child (Tini is meant to be run in a container), and wait for \
5it to exit all the while reaping zombies and performing signal forwarding. "
6
7SRCREV = "fec3683b971d9c3ef73f284f176672c44b448662"
8SRC_URI = " \
9 git://github.com/krallin/tini.git \
10 file://0001-Do-not-strip-the-output-binary-allow-yocto-to-do-thi.patch \
11 "
12
13LICENSE = "Apache-2.0"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=ffc9091894702bc5dcf4cc0085561ef5"
15
16S = "${WORKDIR}/git"
17
18BBCLASSEXTEND = "native"
19
20# tini links with -static, so no PIE for us
21SECURITY_CFLAGS_pn-${PN} = "${SECURITY_NO_PIE_CFLAGS}"
22
23inherit cmake
24
25do_install() {
26 mkdir -p ${D}/${bindir}
27 install -m 0755 ${B}/tini-static ${D}/${bindir}/docker-init
28}
29
30# Tini is the currently the provider for docker-init
31PROVIDES += "docker-init"
32RPROVIDES_${PN} = "docker-init"