summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2018-05-31 17:08:04 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-06-03 23:26:51 -0400
commit0d7cfe86600b0306af97578b16ec7ca264ea1346 (patch)
tree64c2f8eb8285a75592a6c657691d113525335e44
parent4987f02577432e518e627c2c139c378b8b6a9678 (diff)
downloadmeta-virtualization-0d7cfe86600b0306af97578b16ec7ca264ea1346.tar.gz
lxc: uprev to v3.0.0
Update to the latest lxc release. This requires some minor patch updates (fuzz and offset, not content) along with dropping a no longer needed fix for gcc7 (gcc 7.3 is everywhere and is patched). The ptests were already busted before the uprev so I was not able to run them but I will follow up with a fix for this. I did run against our usual usecases 'lxc-create', 'lxc-console', 'lxc-ls', 'lxc-destroy', 'lxc-start', 'lxc-execute', 'lxc-attach'... and there were no issues (outcomes matched v2.0.8). Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-containers/lxc/files/cgroups-work-around-issue-in-gcc-7.patch34
-rw-r--r--recipes-containers/lxc/files/logs-optionally-use-base-filenames-to-report-src-fil.patch8
-rw-r--r--recipes-containers/lxc/files/lxc-1.0.0-disable-udhcp-from-busybox-template.patch6
-rw-r--r--recipes-containers/lxc/lxc_3.0.0.bb (renamed from recipes-containers/lxc/lxc_2.0.8.bb)5
4 files changed, 9 insertions, 44 deletions
diff --git a/recipes-containers/lxc/files/cgroups-work-around-issue-in-gcc-7.patch b/recipes-containers/lxc/files/cgroups-work-around-issue-in-gcc-7.patch
deleted file mode 100644
index 90740fb3..00000000
--- a/recipes-containers/lxc/files/cgroups-work-around-issue-in-gcc-7.patch
+++ /dev/null
@@ -1,34 +0,0 @@
1From 58a2d817a82100d287c60c63315d81445cdba3f9 Mon Sep 17 00:00:00 2001
2From: Mark Asselstine <mark.asselstine@windriver.com>
3Date: Thu, 15 Jun 2017 15:12:08 -0400
4Subject: [PATCH] cgroups: work around issue in gcc 7
5
6This works around
7https://bugzilla.yoctoproject.org/show_bug.cgi?id=11672
8https://gcc.gnu.org/bugzilla/show_bug.cgi?id=78969
9
10By removing a single cgroup entry. For the majority of usecases this
11loss of a single entry should not be an issue and once gcc 7 is fixed
12we can revert this.
13
14Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
15---
16 src/lxc/cgroups/cgfsng.c | 2 +-
17 1 file changed, 1 insertion(+), 1 deletion(-)
18
19diff --git a/src/lxc/cgroups/cgfsng.c b/src/lxc/cgroups/cgfsng.c
20index ebd548b..c520abd 100644
21--- a/src/lxc/cgroups/cgfsng.c
22+++ b/src/lxc/cgroups/cgfsng.c
23@@ -1373,7 +1373,7 @@ static inline bool cgfsng_create(void *hdata)
24 offset = cgname + len - 5;
25
26 again:
27- if (idx == 1000) {
28+ if (idx == 999) {
29 ERROR("Too many conflicting cgroup names");
30 goto out_free;
31 }
32--
332.7.4
34
diff --git a/recipes-containers/lxc/files/logs-optionally-use-base-filenames-to-report-src-fil.patch b/recipes-containers/lxc/files/logs-optionally-use-base-filenames-to-report-src-fil.patch
index 583b6f1c..f430601a 100644
--- a/recipes-containers/lxc/files/logs-optionally-use-base-filenames-to-report-src-fil.patch
+++ b/recipes-containers/lxc/files/logs-optionally-use-base-filenames-to-report-src-fil.patch
@@ -31,9 +31,9 @@ diff --git a/configure.ac b/configure.ac
31index deba90b..c1ed67b 100644 31index deba90b..c1ed67b 100644
32--- a/configure.ac 32--- a/configure.ac
33+++ b/configure.ac 33+++ b/configure.ac
34@@ -357,6 +357,15 @@ AM_COND_IF([ENABLE_PYTHON], 34@@ -356,6 +356,15 @@ AM_COND_IF([ENABLE_PYTHON],
35 PKG_CHECK_MODULES([PYTHONDEV], [python3 >= 3.2],[],[AC_MSG_ERROR([You must install python3-dev])]) 35 [], [enable_examples=yes])
36 AC_DEFINE_UNQUOTED([ENABLE_PYTHON], 1, [Python3 is available])]) 36 AM_CONDITIONAL([ENABLE_EXAMPLES], [test "x$enable_examples" = "xyes"])
37 37
38+# Enable basenames in the logs for source files 38+# Enable basenames in the logs for source files
39+AC_ARG_ENABLE([log-src-basename], 39+AC_ARG_ENABLE([log-src-basename],
@@ -51,7 +51,7 @@ diff --git a/src/lxc/log.h b/src/lxc/log.h
51index 76bd4df..4365977 100644 51index 76bd4df..4365977 100644
52--- a/src/lxc/log.h 52--- a/src/lxc/log.h
53+++ b/src/lxc/log.h 53+++ b/src/lxc/log.h
54@@ -74,8 +74,13 @@ struct lxc_log_locinfo { 54@@ -77,8 +77,13 @@ struct lxc_log_locinfo {
55 int line; 55 int line;
56 }; 56 };
57 57
diff --git a/recipes-containers/lxc/files/lxc-1.0.0-disable-udhcp-from-busybox-template.patch b/recipes-containers/lxc/files/lxc-1.0.0-disable-udhcp-from-busybox-template.patch
index 723be277..07a12ff7 100644
--- a/recipes-containers/lxc/files/lxc-1.0.0-disable-udhcp-from-busybox-template.patch
+++ b/recipes-containers/lxc/files/lxc-1.0.0-disable-udhcp-from-busybox-template.patch
@@ -11,14 +11,14 @@ diff --git a/templates/lxc-busybox.in b/templates/lxc-busybox.in
11index cb425ec..bb8c951 100644 11index cb425ec..bb8c951 100644
12--- a/templates/lxc-busybox.in 12--- a/templates/lxc-busybox.in
13+++ b/templates/lxc-busybox.in 13+++ b/templates/lxc-busybox.in
14@@ -84,7 +84,6 @@ EOF 14@@ -111,7 +111,6 @@ EOF
15 #!/bin/sh 15 #!/bin/sh
16 /bin/syslogd 16 /bin/syslogd
17 /bin/mount -a 17 /bin/mount -a
18-/bin/udhcpc 18-/bin/udhcpc
19 EOF 19 EOF
20 20
21 # executable 21 # executable
22-- 22---
231.7.11.7 231.7.11.7
24 24
diff --git a/recipes-containers/lxc/lxc_2.0.8.bb b/recipes-containers/lxc/lxc_3.0.0.bb
index 46fa9a75..7158d0a3 100644
--- a/recipes-containers/lxc/lxc_2.0.8.bb
+++ b/recipes-containers/lxc/lxc_3.0.0.bb
@@ -40,13 +40,12 @@ SRC_URI = "http://linuxcontainers.org/downloads/${BPN}-${PV}.tar.gz \
40 file://lxc-fix-B-S.patch \ 40 file://lxc-fix-B-S.patch \
41 file://lxc-doc-upgrade-to-use-docbook-3.1-DTD.patch \ 41 file://lxc-doc-upgrade-to-use-docbook-3.1-DTD.patch \
42 file://logs-optionally-use-base-filenames-to-report-src-fil.patch \ 42 file://logs-optionally-use-base-filenames-to-report-src-fil.patch \
43 file://cgroups-work-around-issue-in-gcc-7.patch \
44 file://dnsmasq.conf \ 43 file://dnsmasq.conf \
45 file://lxc-net \ 44 file://lxc-net \
46 " 45 "
47 46
48SRC_URI[md5sum] = "7bfd95280522d7936c0979dfea92cdb5" 47SRC_URI[md5sum] = "ca1db4f9dc35df9203a58ab606cdfb7a"
49SRC_URI[sha256sum] = "0d8e34b302cfe4c40c6c9ae5097096aa5cc2c1dfceea3f0f22e3e16c4a4e8494" 48SRC_URI[sha256sum] = "6230224c27f050201b372b18a9f39cd220ed584899c5f0cf73c6b313dabc8d8a"
50 49
51S = "${WORKDIR}/${BPN}-${PV}" 50S = "${WORKDIR}/${BPN}-${PV}"
52 51