diff options
author | Bruce Ashfield <bruce.ashfield@gmail.com> | 2023-04-03 09:49:16 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2023-04-05 16:03:56 -0400 |
commit | 71f56e048618980f60e78292eef045a0ee597ec2 (patch) | |
tree | d9bcffa743b87db27ce7c2f227f964b5ec68bbb6 | |
parent | 9094997ac932f772dac2251222677d5a11c48008 (diff) | |
download | meta-virtualization-71f56e048618980f60e78292eef045a0ee597ec2.tar.gz |
cobra: update to 1.6.0
Bumping cobra to version v1.6.0-32-g4dd4b25, which comprises the following commits:
4dd4b25 Update main image to better handle dark background (#1883)
45360a5 Allow sourcing zsh completion script (#1917)
c8a20a1 Document suggested layout for subcommands (#1930)
b197a24 Update projects_using_cobra.md (#1932)
9e6b58a update copyright year (#1927)
fb36524 ci: test Golang 1.20 (#1925)
c7300f0 ci: deprecate go 1.16 (#1926)
567ea8e Add support for PowerShell 7.2+ (#1916)
3daa4b9 Add keeporder to shell completion (#1903)
a516d41 Removes stale bot from GitHub action (#1908)
e839bb3 build(deps): bump golangci/golangci-lint-action from 3.3.1 to 3.4.0 (#1902)
87ebcd8 Update shell_completions.md (#1907)
8b8ee87 Improve MarkFlagsMutuallyExclusive example in User Guide (#1904)
d022c0f Add documentation about disabling completion descriptions (#1901)
4fa4fdf build(deps): bump github.com/inconshreveable/mousetrap (#1872)
b4f979a completions: do not detect arguments with dash as 2nd char as flag (#1817)
bf11ab6 fix: func name in doc strings (#1885)
fdffa5a Update badge route (#1884)
f25a3c6 fix: conflict import name with variable (#1879)
9235920 ci: deprecate go 1.15 (#1866)
a6f198b Update kubescape org (#1874)
7bb1440 build(deps): bump golangci/golangci-lint-action from 3.2.0 to 3.3.1 (#1851)
6200c8e Makefile: add target richtest (#1865)
c6b9971 fix: force ForEach-Object to return array in pwsh completion (#1850)
4305498 Update stale.yml (#1863)
ad6db7f Create unit test illustrating unknown flag bug (#1854)
6b0bd30 fix: don't remove flag value that matches subcommand name (#1781)
cc7e235 Add Sia to projects using Cobra (#1844)
10cf7be Check for group presence after full initialization (#1839)
4b9d00d Replace deprecated ExactValidArgs with MatchAll in user_guide and shell_completions example (#1836)
badcce1 style(bash-v2): various cleanups (#1702)
1424b7b Add Constellation to projects using cobra. (#1829)
8607918 feat: make InitDefaultCompletionCmd public (#1467)
2169adb Add groups for commands in help (#1003)
212ea40 Include --help and --version flag in completion (#1813)
d4040ad Allow user to add completion for powershell alias (#1621)
23fc5e0 ci: add minimum GitHub token permissions for workflows (#1792)
93d1913 Add OnFinalize method (#1788)
07034fe build(deps): bump actions/stale from 5 to 6 (#1815)
3dc9761 Add allero to list of projects using cobra (#1819)
7039e1f Add '--version' flag to Help output (#1707)
fce8d8a Expose ValidateRequiredFlags and ValidateFlagGroups (#1760)
a281c8b Document option to hide the default completion cmd (#1779)
459fc5f ci: add workflow_dispatch (#1387)
6d978a9 add missing license headers (#1809)
4065a33 ci: use action/setup-go's cache (#1783)
7e289f4 Adjustments to documentation (#1656)
fe08012 Rename Powershell completion tests (#1803)
d689184 Support for case-insensitive command names (#1802)
70e53f6 Deprecate ExactValidArgs() and test combinations of args validators (#1643)
2e8ba6f Use correct stale action `exempt-` yaml keys (#1800)
0580724 With go 1.18, we must use go install for a binary (#1726)
2a7647f Clarify SetContext documentation (#1748)
7045405 ci: test on Golang 1.19 (#1782)
22b6179 fix: show flags that shadow parent persistent flag in child help (#1776)
dbf85f6 Update gopkg.in/yaml.v2 to gopkg.in/yaml.v3 (#1766)
f911c0b fix(bash-v2): activeHelp length check syntax (#1762)
7790bf9 fix: correct command path in see_also for YAML doc (#1771)
6bf8cd8 build(deps): bump github.com/inconshreveable/mousetrap (#1774)
965924a docs: add zitadel to the list (#1772)
162534f doc: Add Okteto for projects using Cobra (#1759)
a0aadc6 Spelling for GitHub CLI (#1744)
69083f8 Add Cilium to projects using Cobra (#1745)
bba9331 doc: Add CloudQuery for projects using Cobra (#1742)
3d38d18 Add KubeVirt as a project using cobra (#1741)
06b06a9 Bump golangci/golangci-lint-action from 3.1.0 to 3.2.0 (#1697)
5f2ec3c Update shell completion to respect flag groups (#1659)
b9ca594 use errors.Is() to check for errors (#1730)
ea94a3d undefined or nil Args default to ArbitraryArgs (#1612)
7c9831d Fix handling of descriptions for bash v3 (#1735)
ed7bb9d Add unit test for fish completion (#1515)
f464d6c Add Active Help support (#1482)
7dc8b00 Bump actions/setup-go from 2 to 3 (#1660)
87ea180 Modify brew prefix path in macOS system (#1719)
ca8e3c2 Add Pulumi as a project using cobra (#1720)
37d481d fix: Don't complete _command on zsh (#1690)
5b11656 perf(bash-v2): read directly to COMPREPLY on descriptionless short circuit (#1700)
ffa8860 Change links from http:// to https:// (#1695)
e1ded5c fix(bash-v2): skip empty completions when filtering descriptions (#1691)
8afe9d1 Bump github.com/cpuguy83/go-md2man/v2 from 2.0.1 to 2.0.2 (#1688)
25f5bb5 Prefer ReplaceAll instead of Replace(..., -1) (#1530)
9e88759 perf(bash-v2): speed up filtering menu-complete descriptions (#1692)
fb80311 perf(bash-v2): speed up filtering entries with descriptions (#1689)
95d7df1 perf(bash-v2): short-circuit descriptionless candidate lists (#1686)
f17e5a2 style(bash): out is not an array variable, do not refer to it as such (#1684)
09d6ba6 perf(bash-v2): standard completion optimizations (#1683)
4f0facb style(bash-v2): out is not an array variable, do not refer to it as such (#1681)
2722a75 perf(bash-v2): use backslash escape string expansion for tab (#1682)
d8184d3 Fix typo sh completion docs (#1678)
b9460cc Bump codelytv/pr-size-labeler from 1.8.0 to 1.8.1 (#1661)
89d7b83 Add Polygon Edge as a project using Cobra (#1672)
68b6b24 Add ability to mark flags as required or exclusive as a group (#1654)
bf6cb58 Wrap printf tab with quotes (#1665)
9d15fe6 Update stale-bot (#1609)
5271cf4 ci/test: RICHGO_FORCE_COLOR (#1647)
ab42c93 Adds size labeler GitHub action (#1610)
52e6099 Bump actions/checkout from 2 to 3 (#1619)
5414d3d Bump golangci/golangci-lint-action from 2 to 3.1.0 (#1615)
cf0df73 Bump actions/labeler from 3 to 4 (#1620)
3723151 Bump actions/cache from 2 to 3 (#1640)
1568491 Bump actions/stale from 1 to 5 (#1618)
d622355 Changed branch name in the cobra generator link to 'main' (#1645)
03c3eb7 Add Kubescape to projects (#1642)
3a1795b Fix Command.Context comment (#1639)
f848943 Add Command.SetContext (#1551)
5d066b7 Introduce FixedCompletions (#1574)
94e552d Add backwards-compatibility tests for legacyArgs() (#1547)
8cc7be2 feat: Add how to load completions in your current zsh session (#1608)
65b1195 ci: test on Golang 1.18 (#1635)
37463cf Remove CHANGELOG.md as it isn't updated (#1634)
81d27c8 fix some typos (#1625)
5b2b9e9 Removes viper dependency by removing cobra/ CLI tool (#1604)
9369465 labeler: fix syntax
e1b831e Updates labeler for new labels (#1613)
8267283 Add MAINTAINERS file (alphabetical order) (#1545)
6d2dc43 Add Pixie to projects. (#1581)
a599632 Fix install command (#1576)
7cabfeb Update Go Doc link and badge (#1593)
e04ec72 Bump license year to 2022 in golden files (#1575)
cb9d7b1 Bump github.com/spf13/viper from 1.10.0 to 1.10.1 (#1567)
178edbb Bump github.com/spf13/viper from 1.9.0 to 1.10.0 (#1561)
9054739 Remove __complete cmd for program without subcmds (#1563)
19c9c74 Always include the os package import when generating the root command (#1557)
01e05b8 Bump github.com/spf13/viper from 1.8.1 to 1.9.0 (#1554)
36bff0a fix root.go.golden (#1552)
1854bb5 Fix some typos (mostly found by codespell) (#1514)
ff2c55e chore(ci): use golangci-lint-action (#1477)
1beb476 fix: Duplicate error message from cobra init boilerplates (#1463)
6f84ef4 Provide option to hide default 'completion' cmd (#1541)
ee75a2b Remove trailing spaces from bash completion command description (#1520)
25bab5a Fix invalid shell completion when used with ~/.cobra.yaml (#1510)
3fed3ef Support different bash completion options (#1509)
507caf5 completions: fix mixed tab/spaces indentation (#1473)
c7a4421 fix: typo in {bash,zsh}_completions.go (#1459)
c3573e2 Completion: Capitalize short desc, and remove extra space from long (#1455)
dd40ab0 feat: improve completions help formatting (#1444)
d298d79 Update shell_completions.md to have automatically rootcmd (#1372)
6f19fa9 fix: unbound variables in bash completion (#1321)
d65ba12 github: add dependabot configuration file (#1427)
45e521e enable composing PositionalArgs (#896)
9e1d6f1 args_test: add helper functions (#1426)
62a72cd fix(diff): use arg '--strip-trailing-cr' (#949)
442031e Allow specifying licenses using their SPDX identifier (#1159)
78969f9 Remove "Lesser" from header for GPL-2.0 template (#880)
3c84bf8 Small correction in User Guide (#1009)
3ba5f15 Projects using cobra update (#1454)
bfacc59 Addressing typos identified by @marckhouzam
2682562 Simplifying goGet function
cf87fc4 Updating generator documentation and links
c97b7ec Update documentation to reflect the module aware generator
9388e79 Cobra generator now works within Go modules
c9edb78 Change generator default license to none
dcf42b2 Change generator to require opting in to viper.
c0dd5cd Removing unused imports when not using Viper
f09e947 readme: remove ToC, since it's now shown by GitHub (#1429)
d2c0cb3 DisableFlagParsing must disable flag completion (#1161)
c1973d3 Update projects-using markdown with Tanzu (#1501)
4fd30b6 ci: test golang 1.16.x and 1.17.x too (#1425)
2a52778 go.mod: cpuguy83/go-md2man/v2 v2.0.1 (#1460)
56060d1 Add Meroxa CLI (#1377)
de187e8 Fix flag completion (#1438)
07861c8 Fix documentation (#1434)
5738d6b Add install instructions for zsh on Mac OS (#1417)
5d46ac9 custom comp: do not complete flags after args when interspersed is false (#1308)
3c8a19e fix RegisterFlagCompletionFunc concurrent map writes error (#1423)
2dea4f2 Bump to viper 1.8.1 (#1433)
b361960 Bash completion V2 with completion descriptions (#1146)
d0f318d ci: deprecate Travis CI
8eaca5f drop mitchellh/go-homedir (#853)
ace6b14 readme: split 'Getting Started' into 'user_guide.md'
701fa6c chore(deps): update viper
9a43267 fix home directory config not loading (#1282)
4590150 Correcting misspelled words (#1349)
c2e21bd Fix multiple fish completion issues (#1249)
95d23d2 Fix zsh for DirectiveNoSpace and DirectiveNoFileComp (#1213)
2d94892 Custom completion handle multiple shorhand flags together (#1258)
6d00909 Pass context to completion (#1265)
7223a99 powershell completion fix no file comp directive (#1363)
06e4b59 Allow fish comp to support trailing empty lines (#1284)
3ed6a39 ci/MSYS2: go install @latest (#1366)
eb3b639 Bash completion variable leak fixes (#1352)
b55fa79 Add PR labeler with pull_request_target (#1338)
b312f0a Create 'completion' command automatically (#1192)
ded486a Fix trailing whitespace in the powershell completion script (#1342)
893ebf6 Fix typo
be1efc8 Update CHANGELOG.md for v1.1.3
7f95502 Update CHANGELOG.md for v1.1.2
07445ea Copyedit shell-completion related documentation
b73b344 ci: add GitHub Actions workflow 'Test' (#1339)
652c755 Use golangci-lint (#1044)
1d71ff0 Deprecate Go < 1.14 (#1323)
1135bde Update gopkg.in/yaml.v2 to v2.4.0
9df156e Cobra User Contract (#1292)
ff416ad Revert "Add the ability to specify a filePostpender in GenMarkdownTreeCustom (#1270)" (#1317)
23a6174 Add the ability to specify a filePostpender in GenMarkdownTreeCustom (#1270)
4384b91 Bump license year to 2021 in golden files (#1309)
a4ab3fa powershell completion with custom comp (#1208)
471c9ac Add the new Twitch CLI to to projects_using_cobra.md (#1301)
7df62f7 fix typos (#1274)
39b5a91 README.md Readability Improvements (#1228)
08c51e5 Add ORY Hydra & Kratos to projects_using_cobra.md (#1273)
86f8bfd fix manpage building with new go-md2man (#1255)
f32f4ef Don't use yaml.v2 2.3.0 which has a breaking change (#1259)
142dfb1 Add example for making persistent flags required (#1135)
723d0c3 Add tendermint and cosmos-sdk to the list of projects using cobra (#855)
b97b5ea fix: fish output redirection (#1247)
f64bfa1 Fix zsh completion not working on the first time in a shell session (#1237)
40d34bc Fix stderr printing functions (#894)
0bc8bfb Remove secondary go mod to prevent broken `go get` (#1233)
7f8e83d Modifying "snake-case" to "kebab-case" for clarity. (#1196)
8a39cb2 Bug fix in README (#1199)
2a8d0f3 Adding Kool to list of projects using cobra (#1224)
6c06523 add arduino-cli to projects using cobra (#1117)
8a63648 Handle linebreaks in custom completions. (#1162)
50258f1 Complete subcommands when TraverseChildren is set (#1171)
02a0d2f doc: GenMarkdown skip Synopsis on empty long cmd (#1207)
9ed1d71 bugfix/cli: Temporary fix for go get on cobra cli (#1200)
8cfa4b4 Add documentation for Use (#1188)
81e0311 modules: add a secondary go.mod to segregate CLI dependencies (#1139)
5cdf8e2 Fix typo (#1187)
a0b86e5 Correct a typo in doc/util.go (#1184)
a738b60 Add CONTRIBUTING.md (#1183)
96dc555 Update projects_using_cobra.md (#1147)
0e27f22 Add slack badge to point to cobra slack channel (#1181)
c6fe2d4 Improve zsh completion documentation (#1169)
19e41cf Adding werf to projects using cobra (#1163)
b95db64 Add golangci-lint in project using cobra (#1150)
884edc5 update viper and pflag (#1012)
675ae5f Fish does not accept - or : in vars (#1122)
5d52907 Update README.md (#1154)
207dc47 Close #1152 by upgrading yaml.v2 to v2.3.0 (#1153)
2c5a0d3 Extend Go completions and revamp zsh comp (#1070) (#1070)
0431872 Add completion for help command (#1136)
ed7b60e YAML documentation contains "Usage" (#1037)
1d3ac91 Update projects_using_cobra.md (#1113)
94a87a7 disable periodic labeler (#1112)
5155946 Ignore required flags when DisableFlagParsing (#1095)
aa5badd Metal Stack CLI is using cobra as well (#1094)
a7aaa7c replace labeler action with periodic-labeler (#1097)
f8fdd17 Complete command names even if ValidArgs present (#1088)
e392f32 Man pages won't have auto gen tag when option is disabled (#1104)
41fd44e Fix cobra init cmd help documentation (#1108)
44d55fb Fix cobra command README (#1106)
11ba63f Add Helm as project using Cobra (#1103)
090d94f Move projects using Cobra (#1090)
8c638d3 Fixed typo. (#1087)
a684a6d Fish completion using Go completion (#1048)
7fead4b Remove/replace SetOutput on Command - deprecated (#1078)
4741428 Add Github CLI to list of projects using Cobra (#1034)
b84ef40 Rename BashCompDirectives to ShellCompDirectives (#1082)
b80aeb1 Add support for custom completions in Go (#1035)
138b98f add support for autolabel stale PR (#1075)
d88d9a0 Add Labeler Actions (#1074)
bbffa3a rm circle ci badge (#1073)
f628835 Replace deprecated SetOutput func with SetOut and SetErr in test (#1053)
6607e6b Partial Revert of #922 (#1068)
95f2f73 Add short version flag -v when not otherwise set (#996)
39cf99f leverage makefile to run build tasks (#976)
3c26245 Correct documentation for InOrStdin (#929)
0da0687 Add support for context.Context
21cab29 fix: undefined er (#1039)
89c7ffb Bump year on golden files (#1010)
bf26895 Fix regression when calling *_custom_func (#1001)
447f182 format tpl/main.go templates (#980)
0d9d2d4 Revert change so help is printed on stdout again (#1004)
b04b5bf substitute wrong word in md_docs (#998)
77e4d5a Update md2man to v2.0.0 (#977)
8a4b46f update viper to v1.4.0 (#953)
c022f6f Update README.md (#944)
48e6ac4 update doc w/ newer cmd/root.go example (#973)
3745fcd add goreportcard to readme (#971)
19cf35e fix: ensure that testproject is removed even after a failure (#948)
606aa57 Used goimports to fix import order (#912)
4f2877d clean(travis): remove shellcheck from before_install (#947)
b80588d fix undefined cfgFile in documentation (#924)
993cc53 Adjustments per PR review feedback from @bogem
d851963 Correct all complaints from goimports
51f06c7 Correct all complaints from golint
9334a46 Return an error in the case of unrunnable subcommand
9552679 Add idiomatic handling of go error in distinct main func
af29f95 Add ignore of cobra posix binary and all of intellij generated files
1c9c46d Update Generator Docs to reflect changes brought in #817 (#904)
2d7544e fix missing newline in cmd/add (#905)
9a31ddf Add Linkerd to list of projects using Cobra (#892)
21f39ca bash: fix shellcheck errors (#889)
f2b07da fixing linter issues
b635726 considering stderr in UsageString
e35034f Add tests
cb27ce1 Deprecate and maintain backwards compatibility
618bc00 Allow for explicit output to err/stderr
0ea93dd Fixed linter issues
4a716d1 Extending redirection to stdout, stderr, stdin
5f23f55 Update README.md
9eb9f5c Add gardenctl to projects build using Cobra
2411ac5 remove unused struct fields
984374f clean up testproject files after test executes
11aa612 test add
303a3e5 vgo - strip out unused methods
0bb1506 remove commented field in struct
2fea75b vgo - add command working
3c42f84 fix duplicated dir
221bae3 depricate package name flag
b8ad19a reorder some operations
732e4db vgo - trim some uneeded data from struct
c7ac101 vgo - fixing up the add op to work with vgo
3741457 add CommandTemplate
50665e9 vgo - update golden templates
642c3c7 vgo - compare generated files against golden files
e993d53 vgo - take named directory or current wd
04af6ae vgo - add todo
c3b51f3 simplify test
4c22a20 vgo - remove unused methods
73b5215 vgo - fix format
44c2d48 fix calling to createLicenseFile
91dbcb7 remove commented code
5b1685f vgo - generate license
abab9aa vgo - add Create method to Project struct
69420a9 vgo - create directory
17dc9f8 fixing up templates more
26d210e vgo - fixing up the root template
c356c64 add .idea/* to gitignore
80ea290 vgo-support - re-working code generator
d658160 Add markdown file explaining support for PowerShell
21ccc7b Add basic PowerShell completions
e2c45ac Started working on Unified API for the various shell completions:
601d830 typo in zsh-completions.md
edbb671 zsh-completions: implemented argument completion.
d262154 zsh-completion: tidy up function and variable names
8822449 zsh-completion: added escapinng of single quotes in flag description.
66a9880 zsh-completion: test to verify that we're always running on root cmd.
7b62c7d zsh-completion: --version and --help still doesn't work correctly
7ce08e2 zsh-completion: completion should always parse the root command!
91e80cc zsh-completion: remove bad test
0d9a33d zsh-completion: remove temporary file
50f3859 zsh-completion: added support for filename globbing.
bda855a zsh-completions: fixed zsh completion markdown file name.
dd577bd zsh-completion: added zsh-completion documentation.
461a39d zsh-completion: removed forgotten function.
df12a0a zsh-completion: two fixes for identifying flag usage:
e9ee8f0 zsh-completion: removed the _dep_ files.
ec4b8c9 zsh-completions: revised flags completion rendering + new features:
e8018e8 zsh-completion template refactoring:
2662787 zsh-completion: added support for subcommand description.
f0508c8 zsh-completion ignores hidden commands and flags :)
a15d099 zsh-completion fixed reference to cmd name
7e2436b First try at better zsh completions:
67fc483 added variable to allow configuration of mousetrap message duration (#809)
5755ecf [TrivialPatches] Typos in README.md, fix and update CI, update projects list... (#840)
ba1052d Fix two word flags (#807)
7547e83 Run tests against go 1.11 and drop 1.9 (#737)
d2d81d9 Fix too many underscore for __custom_func (#794)
fe5e611 doc: obey SOURCE_DATE_EPOCH with manpage generation (#735)
f619abc Added ExactValidArgs (#765)
40172f1 Remove unneeded imports from README.md example (#767)
8d114be README: Remove Unneeded Newline (#746)
99dc123 Replace Giant Swarm 'swarm' with 'gsctl' (#738)
6fd8e29 Qualify custom bash func name (#730)
ff0d02e fix typo in doc/man_docs.go (#732)
7c4570c #716 - Removed useless libraries in readme (#717)
a114f31 fix test build breakage with go1.11 (#712)
1e58aa3 Include a basic example #465 (#631)
ef82de7 Fixed code sample for bash completion (#687)
0ab5b6b doc: hide hidden parent flags (#686)
7ee208b support completions for command aliases (#669)
6154259 remove dot after the abs path (#672)
cd30c2a typo: fix incorrect (#668)
4dab30c Add support for ignoring parse errors (#662)
a1f051b Update the Travis and CircleCI Go versions (#651)
c439c4f Terminate the stripping of flags when -- is found (#649)
c6c44e6 Update the bash completion example for kubectl (#645)
6644d46 Prefix bash functions with root command name (#643)
a1e4933 Bash completion aliases (#638)
1a618fb Do not add a space after a single flag completion (#625)
be77323 Try out CircleCI. (#630)
fd32f09 Fix generated bash completion for Bash 3 (OSX) (#520)
9395926 Add Execute func example in README.md (#629)
c2bbfaa Add usage example for required flags (#627)
eb58983 Add `CalledAs` method to cobra.Command (w/ tests) (#567)
9979838 Fix attemptd assignment to non-variable in bash 3 (#628)
3a7eb14 fix grammatical error in command.go (#626)
f91529f Fix a couple typos (#621)
0c34d16 cmd: Fix #612 (#614)
b95ab73 Remove trailing whitespace in rootcmd (#606)
ccaecb1 Ensure that '--version' flag works properly for root command (#595)
c156af3 Explain OnInitialize better in the GoDoc (#594)
de2d9c4 Add alibaba/pouch in README.md (#593)
3a5f27b doc: Add a necessary blank line after SEE ALSO (#592)
45a52e2 doc: Remove one additional blank line after Synopsis (#591)
8678368 Add documentation for '--version' flag to README (#590)
b1ec2ce Add support for --version flag (#584)
1be1d28 Make rootCmd private
fb02817 Fix README example to be consistent with others (#585)
19e54c4 Update error message for missing required flags (#580)
34ceca5 Disable flags in UseLine (#552)
d6948b7 Fix minor typo (#579)
2da4a54 Improve tests in doc/
d6a4305 Edit ResetFlags and ResetCommands descriptions
65c8acb Improve tests
099c5ae Add dots in comments of args.go
18eefcd Add tests for args.go
f634327 Fix typo (#573)
b3426bb Remove confusing duplicate Execute from README (#554)
7b2c5ac Create new buffer if not present yet (#549)
7cd9cc6 add test for c.Name() if c.Use gets changed (#548)
40f1880 Delete name field from Command (#547)
845c905 Fix typo
4d6af28 enforce required flags (#502)
5020481 Grammar addition (#543)
83b1f03 Add a TraverseChildren option to allow for flags on each command in the hierarchy (#299)
419e0f8 doc: add ReST doc generation (#537)
bc69223 Fix dead link in README for cobra generator
e8e7fe0 Shorten README
d5bde60 cmd: Fix text of custom license
0dacccf Improve consistency of flags when using SetGlobalNormalizationFunc (#522)
e5f66de Support default value of $GOPATH (#532)
b787445 Use func (c *Command) consistently (#530)
4de692c adding a GenZshCompletionFile function to mirror bash_completion (#529)
3c0b56b correct spelling mistake (#524)
2df9a53 Fix MinimumArgs
cb74738 Retab README.md
1723331 Update documentation
8bcacfe Add more examples of Args field
4a7b7e6 *following
cb731b8 Specify that parent's name is a variable for clarity. #514
b26b538 Fix remaining reproducibility in TestGoldenAddCmd
3da102d cmd: Fix golden tests if user has config at $HOME
99838a5 cmd: Small fixes
d7ba195 Add basic zsh completion (command hierarchy only)
9e024b6 cmd: Refine formatting of included licenses
a1b7d3c cmd: Add a blank line between copyright and license
75c6acf cmd: Add "-u" to output unified diff in golden tests
cb9cf94 Restore the use of cobra.OnInitialize in cobra executable
d4c40bb travis: Update Go versions
750ba8a Fix reproducibility in TestGolden{Add,Init}Cmd
161584f Fix minor typos: "Know" → "Known"
34594c7 Fix TestGlobalNormFuncPropagation() on gccgo
90fc11b Update README.md
f20b4e9 Refactor TakesArgs to use an interface for arg validation.
d89c499 Allow commands to explicitly state if they do, or do not take arbitrary arguments
715f41b cmd: Ignore hidden files in isEmpty
d994347 Delete tab in the long description of help
c46add8 Add ability to disable mousetrap
8c6fa02 Fix InitDefaultHelpCmd when custom help command is set
4d647c8 Print err instead of home
6471e3d Rename main func to initConfig
f9d3497 Fix RootCmd var name
d638dcb Improve readability of README
e458bb7 Reword `become unexpected errors` to `encounter errors`
31694f1 Add missing 'and' in comment
99b5d83 Show messages if deprecated flags are used
b4dbd37 cmd: Fix tests
defa97f cmd: Fix output root.go of init with --viper=false
d7cfb13 Update README.md
99ff933 cmd: Add possibility to specify the target package
84f4716 Make BenchmarkBashCompletion more honest
66da711 __ltrim_colon_completions is not always available on macOS (#459)
8d4ce35 Update README.md
e606913 Fix typos
4a1a7b0 cmd: Don't print errors from execute to prevent duplication of errors
c446db2 cmd: Delete projectBase flag
7918bf6 Add explanation for viper.BindPflag in README.md
ca57f0f doc: Ad help flag and cmd when generating docs
52ae6a1 Make initHelpCmd public (#436)
ca5710c Fix link to cobra lib in README.md
4ba54a0 Edit installation command in README.md (#451)
fb1f399 Add benchmark for GenBashCompletion
de6b168 Simplify bash_completions.go
4cdb38c cmd: Use correct HasPrefix function for paths
e9078fc cmd: Make more accurate error when there is no $GOPATH
fa9ac85 cmd: Make detailed error when project not in $GOPATH
51b7cf5 Fix tests so they give correct args (#445)
b536627 cmd: Fix some gometalinter complaints
d941496 cmd: Fix error message from go-homedir
a28055b cmd: Fix minor bugs in init command (#446)
90687e7 Update pflag link in README (#444)
7d22e77 Fix incorrect merge of pflag.CommandLine to cmd.Flags()
3454e0e cmd: Fix package name when adding command
4673102 Updating bash_completions to clarify markdown (#442)
1362f95 Clean README.md (#441)
347767f Partial revert of 4d2c4af 'Improve template mechanism' (#439)
eceb483 Divide fields of Command for readability
90d2fd8 Group fields of Command
1251aef Rename Docker to Moby in README.md
e97db2b cmd: Fix tests
4db577d Fix docs for Command
6bfe2ba doc: Add docs
3dc7f13 cmd: Fix docs
d236d29 cmd: Make tmpl local variable
c0bd07d Use cobra create instead of cobra init in README.md (#396)
4d2c4af Improve template mechanisms
d83a1d7 Add comment for InitDefaultHelpFlag
fe69f2e Make initHelpFlag public
db6b9a8 cmd: Fix incorrect initialzation by `cobra init .`
7bd35d3 cmd: Fix incorrect cmd dir
7bb5276 cmd: Fix panic if cmd ends on dash or underscore
efbe9b0 cmd: Use Fatalf instead of Fatal
76a9a66 cmd: Add tests
d20925b cmd: Small correctives
84cba62 cmd: Make detection of $HOME work on all systems
6bcf163 cmd: Validate cmd names
903e5b7 cmd: Fix trimSrcPath doc
66cfd1f cmd: Reuse template in helpers
0dd1c42 cmd: Add more docs
32756eb cmd: Rewrite
4061f41 Use pflag.ShorthandLookup
8f0203b Update README.md
69f86e6 Update README.md
6f647b1 Update .travis.yml
bc8a58f docs: Update README.md
7b1b6e8 cmd: Edit license texts
e2f2121 cmd: Use 'this program' instead of appName in licenses
3d7bff8 Revert "Get rid of flagErrorBuf (#417)"
6dd9084 doc: Use w.Write instead of fmt in yaml_docs
97af803 doc: Cleanup md_docs
de484ee doc: Refactor man docs
ea3c5be Add TestHelpFlagInHelp
867d414 Initialize help flag in initHelpCmd
6ed17b5 cmd: Add more possible matches for bsd licenses
c68a90d Add built-in licenses info to README
164be37 cmd: Add AGPL license
1efd892 cmd: Add LGPL license
6d4267f cmd: Delete redundant symbols from helpers_test.go and licenses.go
78a8032 cmd: Move some license functions from helpers.go to licenses.go
28fe9aa cmd: Fix GPL 3 License header
47029cc cmd: Delete extra whitespace from GPL 3 License header
f4f10f6 Simplify stripFlags
63121c8 Delete Parse from Go projects that uses cobra
9890b7b Simplify stripFlags function
aea9481 Fix typo at docstring for HasHelpSubCommands (#309)
a4f017e Add rclone to list of users (#334)
c4f4d75 Use go get so missing dependencies are fetched (#406)
681a777 Delete checkHelpFunc
10f6b9d Make `go path bin` clearer in README
0a4540b Refactor licenses to many files (#323)
f58a8d6 Add TestSortedFlags
e135867 Make parentsPflags more flexible
3e61377 Use AddFlagSet instead of self-written function
458d797 Add merging of CommandLine flags to Root command
37a4355 Fix tests
3d89ed4 Add only missing persistent flags of parents in mergePersistentFlags
6202b59 Refactor flags mechanisms
a3cd8ab Use os.Getenv("HOME") instead of "$HOME" for windows compatibility (#337)
b655df6 Get rid of flagErrorBuf (#417)
f95d58b Fix #401 (#402)
b6cb395 Fix typo in docstring (#360)
0a0df1e Use valid exit code value in `os.Exit` call (#405)
9350054 Keep only one newline between Aliases and Flags in help (#410)
5deb57b Fixed completion of dash parameters arguments (#415)
7aeaa2c Avoid storing pointer to nil (#411)
6421115 doc: Fix govet complaints (#408)
7be4bed remove help command before adding it (#399)
16c014f Add "docker" to readme
0960ff7 Rename IsHelpCommand to IsAdditionalHelpTopicCommand (#398)
24bb44a Fix SilenceUsage and SilenceErrors in readme (#397)
fcd0c5a Some fixes related to help command (#394)
92ea23a Fix subcommand locations with NoOptDefValue flags (#391)
ee40558 Update the Travis Go versions
b5d8e8f cache command name (#390)
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-containers/go-spf13-cobra/spf13-cobra_git.bb | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-containers/go-spf13-cobra/spf13-cobra_git.bb b/recipes-containers/go-spf13-cobra/spf13-cobra_git.bb index d00cbeaf..e5c442f4 100644 --- a/recipes-containers/go-spf13-cobra/spf13-cobra_git.bb +++ b/recipes-containers/go-spf13-cobra/spf13-cobra_git.bb | |||
@@ -9,8 +9,8 @@ SRCNAME = "cobra" | |||
9 | PKG_NAME = "github.com/spf13/${SRCNAME}" | 9 | PKG_NAME = "github.com/spf13/${SRCNAME}" |
10 | SRC_URI = "git://${PKG_NAME};destsuffix=git/src/${PKG_NAME};branch=main;protocol=https" | 10 | SRC_URI = "git://${PKG_NAME};destsuffix=git/src/${PKG_NAME};branch=main;protocol=https" |
11 | 11 | ||
12 | SRCREV = "b5d8e8f46a2f829f755b6e33b454e25c61c935e1" | 12 | SRCREV = "4dd4b25de38418174a6e859e8a32eaccca32dccc" |
13 | PV = "v0.0.1+git${SRCPV}" | 13 | PV = "v1.6.0+git${SRCPV}" |
14 | 14 | ||
15 | S = "${WORKDIR}/git" | 15 | S = "${WORKDIR}/git" |
16 | 16 | ||