summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-10-08 10:53:39 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-10-08 10:53:39 -0400
commit96c644f896b14b246e57fbb80a7fbb86cea93d31 (patch)
tree65547751c246ff902e31e8c20c9bf04958307d22
parentfcb0c3a663d46c7e8f1f093e27a32a30e9ff2811 (diff)
downloadmeta-virtualization-96c644f896b14b246e57fbb80a7fbb86cea93d31.tar.gz
devtoos: introduce 'yq'
yq is used by some builds to do command line parsing of yaml config files. We introduce the recipe/package and all of its dependencies. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-devtools/yq/yq_git.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/recipes-devtools/yq/yq_git.bb b/recipes-devtools/yq/yq_git.bb
new file mode 100644
index 00000000..05975aa9
--- /dev/null
+++ b/recipes-devtools/yq/yq_git.bb
@@ -0,0 +1,52 @@
1SUMMARY = "a lightweight and portable command-line YAML processor "
2HOMEPAGE = "https://github.com/mikefarah/yq"
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=090d381b4b3eb93194e8cbff4aaae2de"
6
7SRCREV_yq = "e0f5cb3c5958e57c7f250a7030e92c768c1b2b19"
8SRCREV_color = "daf2830f2741ebb735b21709a520c5f37d642d85"
9SRCREV_lexer = "81f720df2c51e9f1e1d387b17a0af386ed2b257d"
10SRCREV_debug = "fa7b53cdfc9105c70f134574002f406232921437"
11SRCREV_errors = "614d223910a179a466c1767a985424175c39b465"
12SRCREV_cobra = "b97b5ead31f7d34f764ac8666e40c214bb8e06dc"
13SRCREV_pflag = "6971c29c4a22981adeaee7f4b437c0cffe08c031"
14SRCREV_logging = "b2cb9fa56473e98db8caba80237377e83fe44db5"
15SRCREV_yaml = "eeeca48fe7764f320e4870d231902bf9c1be2c08"
16
17SRC_URI = "git://${GO_IMPORT};name=yq \
18 git://github.com/fatih/color;name=color;destsuffix=build/vendor/src/github.com/fatih/color \
19 git://github.com/goccy/go-yaml;name=lexer;destsuffix=build/vendor/src/github.com/goccy/go-yaml/ \
20 git://github.com/kylelemons/godebug;name=debug;destsuffix=build/vendor/src/github.com/kylelemons/godebug/ \
21 git://github.com/pkg/errors;name=errors;destsuffix=build/vendor/src/github.com/pkg/errors/ \
22 git://github.com/spf13/cobra;name=cobra;destsuffix=build/vendor/src/github.com/spf13/cobra \
23 git://github.com/spf13/pflag;name=pflag;destsuffix=build/vendor/src/github.com/spf13/pflag \
24 git://github.com/op/go-logging.git;name=logging;destsuffix=build/vendor/src/gopkg.in/op/go-logging.v1 \
25 git://github.com/go-yaml/yaml.git;name=yaml;branch=v3;destsuffix=build/vendor/src/gopkg.in/yaml.v3 \
26 "
27
28PV = "1.13.1+git${SRCREV_yq}"
29GO_IMPORT = "github.com/mikefarah/yq"
30
31inherit go
32
33do_compile_prepend() {
34 # arrange for some of the golang built ins to be found
35 (
36 cd ${WORKDIR}/build/src/
37 ln -sf ${STAGING_DIR_TARGET}/${prefix}/lib/go/src/cmd/vendor/golang.org .
38 )
39
40 # arrange for the fetched dependencies to be found
41 export GOPATH="${GOPATH}:${WORKDIR}/build/vendor/"
42}
43
44
45do_install_append() {
46 # these bring in dependencies for the -dev package on bash, and we don't
47 # need them .. so we remove them to avoid needing that rdepends
48 rm -rf ${D}/${prefix}/lib/go/src/${GO_IMPORT}/debian/rules
49 rm -rf ${D}/${prefix}/lib/go/src/${GO_IMPORT}/scripts
50}
51
52BBCLASSEXTEND = "native"