summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2019-07-22 14:48:07 +0000
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-07-22 14:48:07 +0000
commit95b848f2198018b44e44f3526a9de67a3c89c3c7 (patch)
treef9207787606034cd92bf12fe2e682a41b3af5f6b
parent37a554a2491499aabc88959348544e325e533f71 (diff)
downloadmeta-virtualization-95b848f2198018b44e44f3526a9de67a3c89c3c7.tar.gz
containers/go/build: don't override global package strip flags
When the go-lang container recipes were first created there were issues with strip and the resulting binaries. As such, strip was inhibited for the various packages. This variable is now set in the default classes, and tests show that strip works on the binaries (saving up to 2M on disk for some binaries) with no runtime issues found. So we drop our explicit set of the inhibit and let the build proceed by the defaults. If issues are found, we can re-enable the setting or bbappends can turn it back on for builds showing issues. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-containers/containerd/containerd.inc1
-rw-r--r--recipes-containers/cri-o/cri-o_git.bb1
-rw-r--r--recipes-containers/docker/docker.inc2
-rw-r--r--recipes-containers/kubernetes/kubernetes_git.bb1
-rw-r--r--recipes-containers/runc/runc.inc1
-rw-r--r--recipes-core/runv/runv_git.bb1
-rw-r--r--recipes-networking/cni/cni_git.bb1
7 files changed, 0 insertions, 8 deletions
diff --git a/recipes-containers/containerd/containerd.inc b/recipes-containers/containerd/containerd.inc
index 2a2d8c5c..e226edf1 100644
--- a/recipes-containers/containerd/containerd.inc
+++ b/recipes-containers/containerd/containerd.inc
@@ -95,7 +95,6 @@ do_install() {
95 95
96FILES_${PN} += "${systemd_system_unitdir}/*" 96FILES_${PN} += "${systemd_system_unitdir}/*"
97 97
98INHIBIT_PACKAGE_STRIP = "1"
99INSANE_SKIP_${PN} += "ldflags already-stripped" 98INSANE_SKIP_${PN} += "ldflags already-stripped"
100 99
101COMPATIBLE_HOST = "^(?!(qemu)?mips).*" 100COMPATIBLE_HOST = "^(?!(qemu)?mips).*"
diff --git a/recipes-containers/cri-o/cri-o_git.bb b/recipes-containers/cri-o/cri-o_git.bb
index 1a56dc45..c27aef78 100644
--- a/recipes-containers/cri-o/cri-o_git.bb
+++ b/recipes-containers/cri-o/cri-o_git.bb
@@ -143,7 +143,6 @@ FILES_${PN}-config = "${sysconfdir}/crio/config/*"
143FILES_${PN} += "${systemd_unitdir}/system/*" 143FILES_${PN} += "${systemd_unitdir}/system/*"
144FILES_${PN} += "/usr/local/bin/*" 144FILES_${PN} += "/usr/local/bin/*"
145 145
146INHIBIT_PACKAGE_STRIP = "1"
147INSANE_SKIP_${PN} += "ldflags already-stripped" 146INSANE_SKIP_${PN} += "ldflags already-stripped"
148 147
149deltask compile_ptest_base 148deltask compile_ptest_base
diff --git a/recipes-containers/docker/docker.inc b/recipes-containers/docker/docker.inc
index eacaf7f4..149ca824 100644
--- a/recipes-containers/docker/docker.inc
+++ b/recipes-containers/docker/docker.inc
@@ -52,6 +52,4 @@ GROUPADD_PARAM_${PN} = "-r docker"
52 52
53COMPATIBLE_HOST = "^(?!(qemu)?mips).*" 53COMPATIBLE_HOST = "^(?!(qemu)?mips).*"
54 54
55# DO NOT STRIP docker
56INHIBIT_PACKAGE_STRIP = "1"
57INSANE_SKIP_${PN} += "ldflags textrel" 55INSANE_SKIP_${PN} += "ldflags textrel"
diff --git a/recipes-containers/kubernetes/kubernetes_git.bb b/recipes-containers/kubernetes/kubernetes_git.bb
index 516afa31..ea347197 100644
--- a/recipes-containers/kubernetes/kubernetes_git.bb
+++ b/recipes-containers/kubernetes/kubernetes_git.bb
@@ -106,6 +106,5 @@ FILES_kubectl = "${bindir}/kubectl"
106FILES_kube-proxy = "${bindir}/kube-proxy" 106FILES_kube-proxy = "${bindir}/kube-proxy"
107FILES_${PN}-misc = "${bindir}" 107FILES_${PN}-misc = "${bindir}"
108 108
109INHIBIT_PACKAGE_STRIP = "1"
110 109
111deltask compile_ptest_base 110deltask compile_ptest_base
diff --git a/recipes-containers/runc/runc.inc b/recipes-containers/runc/runc.inc
index 5a2ca31a..46fd09dc 100644
--- a/recipes-containers/runc/runc.inc
+++ b/recipes-containers/runc/runc.inc
@@ -64,4 +64,3 @@ do_install() {
64 ln -sf runc ${D}/${bindir}/docker-runc 64 ln -sf runc ${D}/${bindir}/docker-runc
65} 65}
66 66
67INHIBIT_PACKAGE_STRIP = "1"
diff --git a/recipes-core/runv/runv_git.bb b/recipes-core/runv/runv_git.bb
index 0301dd28..ef94f096 100644
--- a/recipes-core/runv/runv_git.bb
+++ b/recipes-core/runv/runv_git.bb
@@ -78,5 +78,4 @@ deltask compile_ptest_base
78 78
79FILES_${PN} += "/usr/local/bin/*" 79FILES_${PN} += "/usr/local/bin/*"
80 80
81INHIBIT_PACKAGE_STRIP = "1"
82INSANE_SKIP_${PN} += "ldflags already-stripped" 81INSANE_SKIP_${PN} += "ldflags already-stripped"
diff --git a/recipes-networking/cni/cni_git.bb b/recipes-networking/cni/cni_git.bb
index 4c1714ae..d07154bb 100644
--- a/recipes-networking/cni/cni_git.bb
+++ b/recipes-networking/cni/cni_git.bb
@@ -92,7 +92,6 @@ do_install() {
92 92
93FILES_${PN} += "/opt/cni/bin/*" 93FILES_${PN} += "/opt/cni/bin/*"
94 94
95INHIBIT_PACKAGE_STRIP = "1"
96INSANE_SKIP_${PN} += "ldflags already-stripped" 95INSANE_SKIP_${PN} += "ldflags already-stripped"
97 96
98deltask compile_ptest_base 97deltask compile_ptest_base