summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2019-09-24 02:09:54 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-09-24 17:46:57 -0400
commit164408a170b074017c7bad1a90316a5de0c2dd88 (patch)
tree9782de30d96ab535cefd368c67289cc700c66eed
parent484a75a824c841c82df9952a315a710e29abf5d2 (diff)
downloadmeta-virtualization-164408a170b074017c7bad1a90316a5de0c2dd88.tar.gz
docker: rename docker -> docker-moby and introduce virtual/docker
The recipe which was providing the default "docker" package was aligned with the moby repositories. In order to make that alignment clear, we rename that recipe docker-moby. To allow easier switching between the docker providing recipes, we introduce a virtual/docker PROVIDES to the common .inc file (and hence each recipe). This allows users to chose what they want via the standard PREFERRED_PROVIDER mechanism. Also to allow existing package lists and image installs to continue to work without changes, we make sure that the implementation specific docker-<foo> packages RPROVIDE docker. If any packages are missed, we'll add them to this list in future updates. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-containers/docker/docker-moby.bb (renamed from recipes-containers/docker/docker_git.bb)0
-rw-r--r--recipes-containers/docker/docker.inc9
2 files changed, 9 insertions, 0 deletions
diff --git a/recipes-containers/docker/docker_git.bb b/recipes-containers/docker/docker-moby.bb
index e45f87e0..e45f87e0 100644
--- a/recipes-containers/docker/docker_git.bb
+++ b/recipes-containers/docker/docker-moby.bb
diff --git a/recipes-containers/docker/docker.inc b/recipes-containers/docker/docker.inc
index 149ca824..8b1b123c 100644
--- a/recipes-containers/docker/docker.inc
+++ b/recipes-containers/docker/docker.inc
@@ -31,6 +31,15 @@ RDEPENDS_${PN} += "virtual/containerd virtual/runc"
31 31
32RRECOMMENDS_${PN} = "kernel-module-dm-thin-pool kernel-module-nf-nat" 32RRECOMMENDS_${PN} = "kernel-module-dm-thin-pool kernel-module-nf-nat"
33 33
34PROVIDES += "virtual/docker"
35
36# we want all the docker variant recpes to be installable via "docker"
37PACKAGE_NAME = "docker"
38RPROVIDES_${PN} += "docker"
39RPROVIDES_${PN}-dbg += "docker-dbg"
40RPROVIDES_${PN}-dev += "docker-dev"
41RPROVIDES_${PN}-contrip += "docker-dev"
42
34inherit pkgconfig 43inherit pkgconfig
35PACKAGECONFIG ??= "docker-init" 44PACKAGECONFIG ??= "docker-init"
36PACKAGECONFIG[seccomp] = "seccomp,,libseccomp" 45PACKAGECONFIG[seccomp] = "seccomp,,libseccomp"